summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2d75bf3495c2..887f9100e3f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -65,7 +65,7 @@ _major=4.19
pkgver=4.19.5
_srcpatch="${pkgver}"
_srcname="linux-${pkgver}"
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/Algodev-github/bfq-mq/"
license=('GPL2')
@@ -108,8 +108,8 @@ sha256sums=('8c839ec29cce7eb0e8ef7eaa10d1eb9d84d2be2521e352fb4f9414e76856ef75'
'eb3cb1a9e487c54346b798b57f5b505f8a85fd1bc839d8f00b2925e6a7d74531'
'1baeb84a779bde01ebf748fc7a86a3643df264a3edf22eac333e880877ab40fc'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- '75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
- '5f6ba52aaa528c4fa4b1dc097e8930fad0470d7ac489afcb13313f289ca32184'
+ 'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
+ '9a8584660c399a6f0c62fc47572ea3f801c08aac50caab2557ce094119ba4195'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'37c115ad797afc7e47615dc56c6416932b6645e16da097ddcfa401df41a31248')
validpgpkeys=(
@@ -266,22 +266,19 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd $_srcname
msg2 "Installing boot image..."
- local image="$pkgdir/boot/vmlinuz-$pkgbase"
- install -Dm644 "$(make -s image_name)" "$image"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
- # systemd expects to find the kernel here to allow hibernation
- # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- ln -sr "$image" "$modulesdir/vmlinuz"
-
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"