summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da734b591086..b2cd19f13791 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ _cachy_config=${_cachy_config-y}
# ATTENTION - only one of the following values can be selected:
# 'bore' - select 'Burst-Oriented Response Enhancer'
# 'hardened' - select 'BORE Scheduler hardened' ## kernel with hardened config and hardening patches with the bore scheduler
-# 'cachyos' - select 'Sched-Ext Scheduler Framework Variant Scheduler'
+# 'cachyos' - select 'Sched-Ext Scheduler Framework Variant Scheduler with BORE Scheduler'
# 'eevdf' - select 'EEVDF Scheduler'
# 'rt' - select EEVDF, but includes a series of realtime patches
# 'rt-bore' - select Burst-Oriented Response Enhancer, but includes a series of realtime patches
@@ -202,8 +202,9 @@ fi
## List of CachyOS schedulers
case "$_cpusched" in
- cachyos) # CachyOS Scheduler (Sched-ext + Cachy Sauce)
- source+=("${_patchsource}/sched/0001-sched-ext.patch");;
+ cachyos) # CachyOS Scheduler (Sched-ext + BORE + Cachy Sauce)
+ source+=("${_patchsource}/sched/0001-sched-ext.patch"
+ "${_patchsource}/sched/0001-bore-cachy-ext.patch");;
bore) ## BORE Scheduler
source+=("${_patchsource}/sched/0001-bore-cachy.patch");;
echo) ## ECHO Scheduler
@@ -274,7 +275,7 @@ prepare() {
[ -z "$_cpusched" ] && _die "The value is empty. Choose the correct one again."
case "$_cpusched" in
- cachyos) scripts/config -e SCHED_CLASS_EXT;;
+ cachyos) scripts/config -e SCHED_CLASS_EXT -e SCHED_BORE;;
bore|hardened) scripts/config -e SCHED_BORE;;
echo) scripts/config -e ECHO_SCHED;;
eevdf) ;;