summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 21 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0baaf483f1d5..0e1b39ce3667 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -70,7 +70,7 @@ _per_gov=y
### Enable TCP_CONG_BBR2
_tcp_bbr2=y
-### Running with a 1000HZ, 750Hz, 600 Hz or 500Hz tick rate
+### Running with a 1000HZ, 750Hz, 600 Hz, 500Hz, 300Hz, 250Hz and 100Hz tick rate
_HZ_ticks=750
## Choose between perodic, idle or full
@@ -174,7 +174,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux CFS scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=1
+pkgrel=2
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -401,10 +401,28 @@ prepare() {
scripts/config --disable HZ_300 \
--enable HZ_500 \
--set-val HZ 500
- else
+ elif [ "$_HZ_ticks" = "300" ]; then
echo "Setting tick rate to 300Hz..."
scripts/config --enable HZ_300 \
--set-val HZ 300
+ elif [ "$_HZ_ticks" = "250" ]; then
+ echo "Setting tick rate to 250Hz..."
+ scripts/config --disable HZ_300 \
+ --enable HZ_250 \
+ --set-val HZ 250
+ elif [ "$_HZ_ticks" = "100" ]; then
+ echo "Setting tick rate to 100Hz..."
+ scripts/config --disable HZ_300 \
+ --enable HZ_100 \
+ --set-val HZ 100
+ else
+ if [ -n "$_HZ_ticks" ]; then
+ error "The value $_HZ_ticks is invalid. Choose the correct one again."
+ else
+ error "The value is empty. Choose the correct one again."
+ fi
+ error "Selecting Setting tick rate failed!"
+ exit
fi
### Disable NUMA