summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 30 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 09fdadda5428..dfd4a54fc3cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -125,7 +125,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=5.18
-_minor=12
+_minor=13
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -135,7 +135,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux cacULE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=4
+pkgrel=1
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -338,8 +338,10 @@ prepare() {
scripts/config --disable HZ_300 \
--enable HZ_500 \
--set-val HZ 500
- elif [ "$_HZ_ticks" = "300" ]; then
+ else
echo "Setting tick rate to 300Hz..."
+ scripts/config --enable HZ_300 \
+ --set-val HZ 300
fi
### Disable NUMA
@@ -382,7 +384,7 @@ prepare() {
fi
### Select tick type
- if [ "$_tickrate" = "perodic" ]; then
+ if [ "$_tickrate" = "periodic" ]; then
echo "Enabling periodic ticks..."
scripts/config --disable NO_HZ_IDLE \
--disable NO_HZ_FULL \
@@ -390,14 +392,14 @@ prepare() {
--disable NO_HZ_COMMON \
--enable HZ_PERIODIC
elif [ "$_tickrate" = "idle" ]; then
- echo "Enabling tickless idle..."
+ echo "Enabling idle ticks.."
scripts/config --disable HZ_PERIODIC \
--disable NO_HZ_FULL \
--enable NO_HZ_IDLE \
--enable NO_HZ \
--enable NO_HZ_COMMON
elif [ "$_tickrate" = "full" ]; then
- echo "Enabling tickless idle..."
+ echo "Enabling full ticks..."
scripts/config --disable HZ_PERIODIC \
--disable NO_HZ_IDLE \
--disable CONTEXT_TRACKING_FORCE \
@@ -406,6 +408,14 @@ prepare() {
--enable NO_HZ \
--enable NO_HZ_COMMON \
--enable CONTEXT_TRACKING
+ else
+ if [ -n "$_tickrate" ]; then
+ error "The value $_tickrate is invalid. Choose the correct one again."
+ else
+ error "The value is empty. Choose the correct one again."
+ fi
+ error "Selecting the tick rate failed!"
+ exit
fi
### Select preempt type
@@ -419,7 +429,7 @@ prepare() {
--enable PREEMPTION \
--enable PREEMPT_DYNAMIC
elif [ "$_preempt" = "voluntary" ]; then
- echo "Enabling tickless idle..."
+ echo "Enabling voluntary preempt..."
scripts/config --enable PREEMPT_BUILD \
--disable PREEMPT_NONE \
--enable PREEMPT_VOLUNTARY \
@@ -427,8 +437,8 @@ prepare() {
--enable PREEMPT_COUNT \
--enable PREEMPTION \
--disable PREEMPT_DYNAMIC
- elif [ "$_tickrate" = "server" ]; then
- echo "Enabling tickless idle..."
+ elif [ "$_preempt" = "server" ]; then
+ echo "Enabling server preempt..."
scripts/config --enable PREEMPT_NONE_BUILD \
--enable PREEMPT_NONE \
--disable PREEMPT_VOLUNTARY \
@@ -436,6 +446,14 @@ prepare() {
--disable PREEMPT_COUNT \
--disable PREEMPTION \
--disable PREEMPT_DYNAMIC
+ else
+ if [ -n "$_preempt" ]; then
+ error "The value $_preempt is invalid. Choose the correct one again."
+ else
+ error "The value is empty. Choose the correct one again."
+ fi
+ error "Selecting PREEMPT failed!"
+ exit
fi
### Enable O3
@@ -839,8 +857,8 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('40b74d0942f255da07481710e1083412d06e37e45b8f9d9e34ae856db37b9527'
- '290cfc52f209df028b8693fcbeed276564ca1d1c13023ebed3faa3d56d6d6ede'
+sha256sums=('430e1affe62fcca274f217b150290995a33ceb0d5ad5e72ca6ee8a2d28276bda'
+ 'b275b38abee79f05cd8f03d1284dd1faf498867e9ecf54ea9a7784afb36efe20'
'ce8bf7807b45a27eed05a5e1de5a0bf6293a3bbc2085bacae70cd1368f368d1f'
- '37763b7f098fadd029923dafb952f9c9485ff3527e48087b6c5e557e043fa324'
+ '6578c745064c71ba0fb9d59fd4b4d224516368607241f5613fad05c44f2ae842'
'767e142a3f0af19ee8a50287c453f34657fdf93451d5c94a4a8190b56715feb6')