summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bda225d31605..89ab2ec5c0ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -141,7 +141,7 @@ _stable=${_major}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux BORE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=1
+pkgrel=2
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -175,11 +175,11 @@ if [ -n "$_build_zfs" ]; then
fi
## BMQ Scheduler
if [ "$_cpusched" = "bmq" ]; then
- source+=("${_patchsource}/sched/0001-prjc.patch")
+ source+=("${_patchsource}/sched/0001-prjc-cachy.patch")
fi
## PDS Scheduler
if [ "$_cpusched" = "pds" ]; then
- source+=("${_patchsource}/sched/0001-prjc.patch")
+ source+=("${_patchsource}/sched/0001-prjc-cachy.patch")
fi
## BORE Scheduler
if [ "$_cpusched" = "bore" ]; then
@@ -199,8 +199,8 @@ if [ "$_cpusched" = "tt" ]; then
fi
## Hardened Patches with BORE Scheduler
if [ "$_cpusched" = "hardened" ]; then
- source+=("${_patchsource}/sched/0001-bore-sched.patch"
- "${_patchsource}/0001-hardening.patch")
+ source+=("${_patchsource}/sched/0001-bore.patch"
+ "${_patchsource}/misc/0001-hardened.patch")
fi
## Kernel CFI Patch
if [ -n "$_use_kcfi" ]; then
@@ -835,7 +835,7 @@ for _p in "${pkgname[@]}"; do
done
sha256sums=('ff240c579b9ee1affc318917de07394fc1c3bb49dac25ec1287370c2e15005a8'
- '42d2127e3fb3bc96024c8af9d3eaead69007f64b1096d13767249bd9afeb043c'
+ 'c2dc560ac5577e42a5bc09b9d238fdf19997d6e2c5ea0593487ab31536e89d0d'
'ce8bf7807b45a27eed05a5e1de5a0bf6293a3bbc2085bacae70cd1368f368d1f'
'4575169c1ed71ddc0ae0d832d0c8df75b506f1bf6891b9166dbb23e628fbfb21'
- 'd6b282e1a9f9e8671bf3b071b2da7976f3ca44715b9eaab1badf26c211658034')
+ 'b26fd58b045b853fabc4d14868cd6c709a34c8cfed6cc09ac7a2bcc39a8f2acf')