summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 18 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b700c579659c..456c830366da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,14 +22,12 @@ _futex2=y
#enable winesync
_winesync=y
-### Running with a 2000 HZ, 1000HZ, 750Hz, 600Hz or 500HZ tick rate
+### Running with a 2000 HZ, 1000HZ, 750Hz or 500HZ tick rate
_2k_HZ_ticks=
_1k_HZ_ticks=
-_750_HZ_ticks=
-_600_HZ_ticks=y
+_750_HZ_ticks=y
_500_HZ_ticks=
-
### Disable MQ-Deadline I/O scheduler
_mq_deadline_disable=y
@@ -125,7 +123,7 @@ elif [ "$_cpusched" = "rdb" ]; then
pkgbase=linux-cacule-rdb
fi
pkgver=5.14.12
-pkgrel=2
+pkgrel=3
arch=(x86_64 x86_64_v3)
pkgdesc='Linux-cacule Kernel by CachyOS and with some other patches and other improvements'
_gittag=v${pkgver%.*}-${pkgver##*.}
@@ -147,7 +145,10 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${pkgver:0:1}.x/linux-${pkgver
"${_caculepatches}/v5.14/cacule-5.14-full.patch"
"${_patchsource}/0001-CK-TIMER.patch"
"${_patchsource}/misc/0008-remove-LightNVM.patch"
- "${_patchsource}/0001-misc.patch"
+ "${_patchsource}/misc/amd/0006-amd-cppc.patch"
+ "${_patchsource}/misc/zen-tweaks-cacule.patch"
+ "${_patchsource}/ll-patches/0001-LL-kconfig-add-750Hz-timer-interrupt-kernel-config-o.patch"
+ "${_patchsource}/ll-patches/0003-sched-core-nr_migrate-256-increases-number-of-tasks-.patch"
"${_patchsource}/ll-patches/0004-mm-set-8-megabytes-for-address_space-level-file-read.patch"
"${_patchsource}/android-patches/0001-android-export-symbold-and-enable-building-ashmem-an.patch"
"${_patchsource}/bbr2-patches/0001-bbr2-5.14-introduce-BBRv2.patch"
@@ -157,7 +158,7 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${pkgver:0:1}.x/linux-${pkgver
"${_patchsource}/futex-xanmod-patches-v2/0001-futex-resync-from-gitlab.collabora.com.patch"
"${_patchsource}/futex2-xanmod-patches-v2/0001-futex2-resync-from-gitlab.collabora.com.patch"
"${_patchsource}/ksmbd-patches-v17/0001-ksmbd-patches.patch"
- "${_patchsource}/hwmon-patches-v4/0001-hwmon-patches.patch"
+ "${_patchsource}/hwmon-patches/0001-hwmon-patches.patch"
"${_patchsource}/lqx-patches/0001-lqx-patches.patch"
"${_patchsource}/lrng-patches-v2/0001-lrng-patches.patch"
"${_patchsource}/lru-patches-v4/0001-lru-patches.patch"
@@ -166,7 +167,7 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${pkgver:0:1}.x/linux-${pkgver
"${_patchsource}/zen-patches-v3/0001-zen-patches.patch"
"${_patchsource}/zstd-patches-v2/0001-zstd-patches.patch"
"${_patchsource}/security-patches/0001-security-patches.patch"
- "${_patchsource}/zstd-upstream-patches-v7/0001-zstd-upstream-patches.patch"
+ "${_patchsource}/zstd-upstream-patches-v6/0001-zstd-upstream-patches.patch"
"${_patchsource}/ntfs3-patches-v14/0001-ntfs3-patches.patch"
"${_patchsource}/0001-ksm.patch"
"${_patchsource}/0001-cpu-patches.patch"
@@ -263,13 +264,6 @@ prepare() {
scripts/config --set-val CONFIG_HZ 750
fi
- ### Optionally set tickrate to 600HZ
- if [ -n "$_600_HZ_ticks" ]; then
- echo "Setting tick rate to 750HZ..."
- scripts/config --disable CONFIG_HZ_300
- scripts/config --enable CONFIG_HZ_600
- scripts/config --set-val CONFIG_HZ 600
- fi
### Optionally set tickrate to 500HZ
if [ -n "$_500_HZ_ticks" ]; then
echo "Setting tick rate to 500HZ..."
@@ -384,11 +378,13 @@ prepare() {
fi
if [ "$_cpusched" = "cacule" ]; then
echo "Selecting CacULE scheduler..."
+ scripts/config --disable CONFIG_SCHED_ALT
scripts/config --enable CONFIG_CACULE_SCHED
scripts/config --disable CONFIG_CACULE_RDB
fi
if [ "$_cpusched" = "rdb" ]; then
echo "Enabling CacULE-RDB scheduler..."
+ scripts/config --disable CONFIG_SCHED_ALT
scripts/config --enable CONFIG_CACULE_SCHED
scripts/config --enable CONFIG_CACULE_RDB
scripts/config --set-val CONFIG_RDB_INTERVAL 19
@@ -639,12 +635,15 @@ _package-headers() {
}
md5sums=('a52286fe206a3f7664ca5a6c5995b9ed'
- '8975770d14d545289b62ecd40e5abefc'
+ 'e2d5c8ee1654b4076fcf9f4b0d7ffa10'
'581faf85cd625c41bbdd0cadbd0e451e'
'024a0126cfcd18e000a2241f35c4d69e'
'04c5865e765e07cff0649824c2a8d810'
'eb39a5681a153f5a1f5a67e8b9e957a5'
- '552446adb1a3943570fedbb783115377'
+ '430972ae1e936f99d8dc2a1f4fdaf774'
+ '9d7612159f8745044254077ce8a76df6'
+ 'f8e172e9ea554bbb1053eb122c3ace35'
+ 'af7328eb8c72c754e5bc8c7be1ca2f1c'
'f0d84fc024b9933bc19db696e0393a4e'
'e45c7962a78d6e82a0d3808868cd6ac0'
'196d6ac961497aa880264b83160eb140'
@@ -654,7 +653,7 @@ md5sums=('a52286fe206a3f7664ca5a6c5995b9ed'
'fd934f7d11131d5a5043e4aea640583b'
'8a96c5e8346bd5b430776ac8a41f96b0'
'f71331c247285499ca42b63d707831a6'
- '3f3f573e48ed67d7acc0733e99a888a5'
+ 'bad682a72d2549f409caea361fb0456f'
'6787c78ba3e7b0a34fbba9c50da7e3b4'
'366c90b64f9582c0733b8fb607a07594'
'8adcaccbb5c0ebd4bc81144e16b92627'
@@ -663,7 +662,7 @@ md5sums=('a52286fe206a3f7664ca5a6c5995b9ed'
'cfef1423ad1e6aecad63f0d5eacaea37'
'808981a36c81165953017e5e432c1fa1'
'f6a1c51adfc68fb7b52dc5715a9cb5a7'
- 'f818b58bb2c6a30cd6fe88a8bd434b90'
+ '6bce25efd0395a4d0a9e0fc52e0d93e4'
'0636779d32ba47bda25d3edb5fbd08c9'
'566435a0444ee45816599f2e0e362c7a'
'bb22330e270bf36ccf53cb04d6b496d2'