summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD74
1 files changed, 38 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8507548e5ff6..71710a4beb07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,7 +52,7 @@ _use_auto_optimization=y
_use_optimization_select=
### Use LLVM with FULL-LTO
-_use_llvm_lto=
+_use_llvm_lto=y
## Enable CFI (booting seems to be broken at nvidia based systems)
_use_cfi=
@@ -78,10 +78,8 @@ _localmodcfg=
_use_current=
pkgbase=linux-cacule
-pkgname=('linux-cacule' 'linux-cacule-headers')
-pkgname=("${pkgbase}" "${pkgbase}-headers")
-pkgver=5.14.9
-pkgrel=3
+pkgver=5.14.10
+pkgrel=1
arch=(x86_64 x86_64_v3)
pkgdesc='Linux-CacULE Kernel by Hamad Marri and with some other patchsets'
_gittag=v${pkgver%.*}-${pkgver##*.}
@@ -99,38 +97,37 @@ _patchsource="https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.
source=("https://cdn.kernel.org/pub/linux/kernel/v${pkgver:0:1}.x/linux-${pkgver}.tar.xz"
"config"
# "${_patchsource}/arch-patches/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch"
- "${_patchsource}/arch-patches-v9/0001-arch-patches.patch"
- "${_caculepatches}/v5.14/cacule-5.14.patch"
+ "${_patchsource}/arch-patches-v10/0001-arch-patches.patch"
+ "${_caculepatches}/v5.14/cacule-5.14-full.patch"
"${_patchsource}/misc/amd/0006-amd-cppc.patch"
"${_patchsource}/misc/zen-tweaks-cacule.patch"
"${_patchsource}/ll-patches/0001-LL-kconfig-add-750Hz-timer-interrupt-kernel-config-o.patch"
"${_patchsource}/ll-patches/0003-sched-core-nr_migrate-256-increases-number-of-tasks-.patch"
"${_patchsource}/ll-patches/0004-mm-set-8-megabytes-for-address_space-level-file-read.patch"
-# "${_patchsource}/bfq-patches-v2/0001-bfq-patches.patch"
"${_patchsource}/android-patches/0001-android-export-symbold-and-enable-building-ashmem-an.patch"
"${_patchsource}/bbr2-patches/0001-bbr2-5.14-introduce-BBRv2.patch"
"${_patchsource}/block-patches/0001-block-patches.patch"
"${_patchsource}/btrfs-patches-v5/0001-btrfs-patches.patch"
"${_patchsource}/fixes-miscellaneous-v5/0001-fixes-miscellaneous.patch"
- "${_patchsource}/futex-zen-patches/0001-futex-resync-from-gitlab.collabora.com.patch"
- "${_patchsource}/futex2-zen-patches/0001-futex2-resync-from-gitlab.collabora.com.patch"
+ "${_patchsource}/futex-xanmod-patches-v2/0001-futex-resync-from-gitlab.collabora.com.patch"
+ "${_patchsource}/futex2-xanmod-patches-v2/0001-futex2-resync-from-gitlab.collabora.com.patch"
+ "${_patchsource}/ksmbd-patches-v14/0001-ksmbd-patches.patch"
"${_patchsource}/hwmon-patches/0001-hwmon-patches.patch"
"${_patchsource}/lqx-patches/0001-lqx-patches.patch"
"${_patchsource}/lrng-patches-v2/0001-lrng-patches.patch"
"${_patchsource}/lru-zen-patches-v3/0001-lru-zen-patches.patch"
- "${_patchsource}/pf-patches-v7/0001-pf-patches.patch"
+ "${_patchsource}/pf-patches-v8/0001-pf-patches.patch"
"${_patchsource}/xanmod-patches-v2/0001-xanmod-patches.patch"
"${_patchsource}/zen-patches-v3/0001-zen-patches.patch"
"${_patchsource}/zstd-patches-v2/0001-zstd-patches.patch"
- "${_patchsource}/zstd-upstream-patches-v3/0001-zstd-upstream-patches.patch"
- "${_patchsource}/ntfs3-patches-v12/0001-ntfs3-patches.patch"
+ "${_patchsource}/0013-zstd.patch"
+ "${_patchsource}/ntfs3-patches-v13/0001-ntfs3-patches.patch"
"${_patchsource}/0001-cpu-patches.patch"
"${_patchsource}/0001-winesync.patch"
"${_patchsource}/0001-v4l2loopback.patch"
"${_patchsource}/0001-ksm.patch"
- "auto-cpu-optimization.sh"
+ "auto-cpu-optimization.sh"
)
-
if [ -n "$_use_cfi" ]; then
source+=("${_patchsource}/0002-clang-cfi.patch")
fi
@@ -144,9 +141,6 @@ source+=("${_patchsource}/0001-PGO.patch")
BUILD_FLAGS=(
LLVM=1
LLVM_IAS=1
- CC=clang
- CXX=clang++
-
)
fi
@@ -154,6 +148,7 @@ export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
+
prepare() {
cd "${srcdir:?}/linux-${pkgver}" || (
echo -e "\E[1;31mCan't cd to ${srcdir:?}/linux-${pkgver} directory! Prepare failed! \E[0m"
@@ -390,13 +385,13 @@ build() {
make ${BUILD_FLAGS[*]} all
}
-package_linux-cacule() {
- pkgdesc="The ${pkgdesc} and modules"
- depends=(coreutils kmod initramfs )
- optdepends=('crda: to set the correct wireless channels of your country'
- 'linux-firmware: firmware images needed for some devices')
- provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
- replaces=()
+_package() {
+ pkgdesc="The $pkgdesc kernel and modules"
+ depends=('coreutils' 'kmod' 'initramfs')
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
+ provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
cd "${srcdir:?}/linux-${pkgver}" || (
echo -e "\E[1;31mCan't cd to ${srcdir:?}/linux-${pkgver} directory! Package linux kernel failed! \E[0m"
@@ -422,8 +417,7 @@ package_linux-cacule() {
}
-package_linux-cacule-headers() {
-
+_package-headers() {
pkgdesc="Headers and scripts for building modules for the ${pkgdesc}"
depends=("linux-cacule=${pkgver}" "pahole")
@@ -510,10 +504,10 @@ package_linux-cacule-headers() {
}
-md5sums=('9f4fe4d784f3c5dd34e9251f83202eba'
- '7839772ac5e87811414056eb77568025'
- '8542cc6a9b34330f0cb82bdfca0a106d'
- '40a9380b2884f5d417791f06389ba57e'
+md5sums=('c467f0e8c5ab6e0ec7c47555ea4a8da3'
+ 'f35189d2e99654c84a601c0fb3c7272e'
+ '581faf85cd625c41bbdd0cadbd0e451e'
+ '024a0126cfcd18e000a2241f35c4d69e'
'430972ae1e936f99d8dc2a1f4fdaf774'
'9d7612159f8745044254077ce8a76df6'
'f8e172e9ea554bbb1053eb122c3ace35'
@@ -524,20 +518,28 @@ md5sums=('9f4fe4d784f3c5dd34e9251f83202eba'
'a3f2cbf318dd2a63af9673f9e34e7125'
'2c4d1d4e79d228af39f84ed4caea2f09'
'c5a1e8c50dd049b2f1b44d43d6754235'
- '0849b25513dc47e3defa00f26f60eedb'
- '2891eb036469d04995d9b21a5e389d8a'
+ 'fd934f7d11131d5a5043e4aea640583b'
+ '8a96c5e8346bd5b430776ac8a41f96b0'
+ '72cb6f5a61e9c678dd676a2647ab3803'
'bad682a72d2549f409caea361fb0456f'
'6787c78ba3e7b0a34fbba9c50da7e3b4'
'366c90b64f9582c0733b8fb607a07594'
'd24fd0f81fbeed243b1b71fde7659548'
- '251d3ca43d625a38db441fb76742e56a'
+ 'fad618c6e6c06ee3700791f9c3c3995a'
'28864f14bf33bad92e57bc48bc5c2c78'
'cfef1423ad1e6aecad63f0d5eacaea37'
'808981a36c81165953017e5e432c1fa1'
- '74db4069a1c3985e5de43cf28f44e693'
- '4b65874d11375bd5084ff1998be17166'
+ '2cd671c79536f8ae6b58d874c8496433'
+ '82c0c2242d2a9d317b2601380f87488a'
'bb22330e270bf36ccf53cb04d6b496d2'
'4c493a3e0f3486be8ad1b6c67c9c6917'
'95eb4457f95f3f8dd153983612ee65c0'
'566435a0444ee45816599f2e0e362c7a'
'21c98f19e883879dd3336c1fa143fd31')
+pkgname=("$pkgbase" "$pkgbase-headers" )
+ for _p in "${pkgname[@]}"; do
+ eval "package_$_p() {
+ $(declare -f "_package${_p#$pkgbase}")
+ _package${_p#$pkgbase}
+ }"
+ done