summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a843eadfe129..adf0feb7ecc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,8 +26,10 @@ use_selinux=n
use_tomoyo=n
use_yama=n
use_apparmor=
-## Apply Kernel Optimization
+## Apply Kernel automatic Optimization
_use_optimization=y
+## Apply Kernel Optimization selecting
+_use_optimizatio_select=
# Only compile active modules to VASTLY reduce the number of modules built and
# the build time.
@@ -50,8 +52,8 @@ _use_current=
pkgbase=linux-cacule
pkgname=("${pkgbase}" "${pkgbase}-headers")
-pkgver=5.13.11
-pkgrel=4
+pkgver=5.13.12
+pkgrel=1
arch=(x86_64 x86_64_v3)
pkgdesc='Linux Kernel with cacule scheduler and lto compiled'
_gittag=v${pkgver%.*}-${pkgver##*.}
@@ -126,6 +128,11 @@ prepare() {
if [ -n "$_use_optimization" ]; then
sh "${srcdir}"/auto-cpu-optimization.sh
fi
+ if [ -n "$_use_optimization_select" ]; then
+ source "${startdir}"/configure
+
+ cpu_arch
+ fi
### Optionally set tickrate to 2000HZ
if [ -n "$_2k_HZ_ticks" ]; then
echo "Setting tick rate to 2k..."
@@ -428,7 +435,7 @@ package_linux-cacule-headers() {
}
-md5sums=('89020a90124a6798054a03c7a2ead059'
+md5sums=('6e1728b2021ca19cc9273f080e6c44c7'
'90e0ff7a76ecab7ef1eb0c31242832dc'
'9f9b916ed39dc125db45d0bff672f4c0'
'078da517ec2d54283af81d7da3af671a'