summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 25 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c98bb4fa3a97..397f877fb93c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -119,8 +119,8 @@ elif [ "$_cpusched" = "cacule" ]; then
elif [ "$_cpusched" = "rdb" ]; then
pkgbase=linux-cacule-rdb
fi
-pkgver=5.14.14
-pkgrel=2
+pkgver=5.14.15
+pkgrel=1
arch=(x86_64 x86_64_v3)
pkgdesc='Linux-cacule Kernel by CachyOS and with some other patches and other improvements'
_gittag=v${pkgver%.*}-${pkgver##*.}
@@ -143,28 +143,27 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${pkgver:0:1}.x/linux-${pkgver
"${_patchsource}/0001-preempt-hz-cfs.patch"
"${_patchsource}/cpufreq-patches/0001-cpufreq-patches.patch"
"${_patchsource}/misc/0008-remove-LightNVM.patch"
- "${_patchsource}/0001-slub.patch"
- "${_patchsource}/misc/amd/0011-amd-ptdma.patch"
+ "${_patchsource}/amd64-patches/0001-amd64-patches.patch"
"${_patchsource}/0001-clearlinux-patches.patch"
"${_patchsource}/ll-patches/0004-mm-set-8-megabytes-for-address_space-level-file-read.patch"
"${_patchsource}/android-patches/0001-android-export-symbold-and-enable-building-ashmem-an.patch"
"${_patchsource}/bbr2-patches/0001-bbr2-5.14-introduce-BBRv2.patch"
"${_patchsource}/block-patches-v2/0001-block-patches.patch"
"${_patchsource}/btrfs-patches-v9/0001-btrfs-patches.patch"
- "${_patchsource}/fixes-miscellaneous-v7/0001-fixes-miscellaneous.patch"
+ "${_patchsource}/fixes-miscellaneous-v8/0001-fixes-miscellaneous.patch"
"${_patchsource}/futex-xanmod-patches-v2/0001-futex-resync-from-gitlab.collabora.com.patch"
"${_patchsource}/futex2-xanmod-patches-v2/0001-futex2-resync-from-gitlab.collabora.com.patch"
- "${_patchsource}/ksmbd-patches-v19/0001-ksmbd-patches.patch"
- "${_patchsource}/hwmon-patches-v5/0001-hwmon-patches.patch"
+ "${_patchsource}/ksmbd-patches-v20/0001-ksmbd-patches.patch"
+ "${_patchsource}/hwmon-patches-v6/0001-hwmon-patches.patch"
"${_patchsource}/lqx-patches/0001-lqx-patches.patch"
- "${_patchsource}/lrng-patches-v2/0001-lrng-patches.patch"
+ "${_patchsource}/lrng-patches-v3/0001-lrng-patches.patch"
"${_patchsource}/lru-patches-v4/0001-lru-patches.patch"
"${_patchsource}/pf-patches-v9/0001-pf-patches.patch"
"${_patchsource}/xanmod-patches-v2/0001-xanmod-patches.patch"
- "${_patchsource}/zen-patches-v3/0001-zen-patches.patch"
+ "${_patchsource}/zen-patches-v4/0001-zen-patches.patch"
"${_patchsource}/zstd-patches-v2/0001-zstd-patches.patch"
"${_patchsource}/security-patches/0001-security-patches.patch"
- "${_patchsource}/zstd-upstream-patches-v6/0001-zstd-upstream-patches.patch"
+ "${_patchsource}/zstd-upstream-patches-v7/0001-zstd-upstream-patches.patch"
"${_patchsource}/ntfs3-patches-v14/0001-ntfs3-patches.patch"
"${_patchsource}/0001-ksm.patch"
"${_patchsource}/0001-cpu-patches.patch"
@@ -460,7 +459,12 @@ prepare() {
echo "Enable AMD PSTATE v2 driver"
scripts/config --enable CONFIG_X86_AMD_PSTATE
scripts/config --enable CONFIG_AMD_PTDMA
-
+ echo "Enable Anbox"
+ scripts/config --enable CONFIG_ASHMEM
+ scripts/config --enable CONFIG_ANDROID
+ scripts/config --enable CONFIG_ANDROID_BINDER_IPC
+ scripts/config --enable CONFIG_ANDROID_BINDERFS
+ scripts/config --enable CONFIG_ANDROID_BINDER_DEVICES="binder,hwbinder,vndbinder"
### Optionally disable NUMA for 64-bit kernels only
@@ -635,36 +639,35 @@ _package-headers() {
}
-md5sums=('9646d53502447936773c65cac149572c'
- '8323695696b586914cfbcc332776ee1a'
+md5sums=('54c6f1371128e1a80dd700f52223aa64'
+ '6529bd047a9c58dd974669dff7e9e638'
'581faf85cd625c41bbdd0cadbd0e451e'
- '024a0126cfcd18e000a2241f35c4d69e'
+ '355493924bbb428dfc2255d5a30c68d0'
'04c5865e765e07cff0649824c2a8d810'
'f88c3290ece724c81921059df14965cf'
'b87b77bd4273817f2b792d6fe965e417'
'eb39a5681a153f5a1f5a67e8b9e957a5'
- '0464f6f1267bae4d87ee97a305d32467'
- 'e2a4af58b9d784226792fdc71d2cabba'
+ 'b1274beeffe2ef126cc67f0b3f50dbbd'
'54f750c0e08b4e5b51a49c494a6891d6'
'f0d84fc024b9933bc19db696e0393a4e'
'e45c7962a78d6e82a0d3808868cd6ac0'
'196d6ac961497aa880264b83160eb140'
'1eaf224f9f46096efb75c153b712d702'
'08183676295d4a89a2c65b1bc326ae3f'
- '7c0ff8bd5d8f1069ab34aec2060109c9'
+ 'a4008ce93063573f7f1baaeb4ed3b12d'
'fd934f7d11131d5a5043e4aea640583b'
'8a96c5e8346bd5b430776ac8a41f96b0'
- 'c5cc719fcd48592d437610c19b9a997b'
- '5c9334532387ae8df80cff9bb5890954'
+ '67f36f551469ac2d7176cbb4c61872ff'
+ '7b5a8b5c7531a316618e6a4d529f8505'
'6787c78ba3e7b0a34fbba9c50da7e3b4'
- '366c90b64f9582c0733b8fb607a07594'
+ '30fb6c409c94cae36e150ec88ae8f74e'
'8adcaccbb5c0ebd4bc81144e16b92627'
'607228871a4127c31baae7b1d66866bc'
'28864f14bf33bad92e57bc48bc5c2c78'
- 'cfef1423ad1e6aecad63f0d5eacaea37'
+ 'b90912780974bd4ee160def1d02e30c5'
'808981a36c81165953017e5e432c1fa1'
'f6a1c51adfc68fb7b52dc5715a9cb5a7'
- 'f818b58bb2c6a30cd6fe88a8bd434b90'
+ 'e2013a225d186772851d566b4db89d53'
'0636779d32ba47bda25d3edb5fbd08c9'
'566435a0444ee45816599f2e0e362c7a'
'bb22330e270bf36ccf53cb04d6b496d2'