summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 730b5924369c..05e1842ba066 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -49,7 +49,7 @@ use_yama=n
use_apparmor=
## Apply Kernel automatic Optimization
-_use_auto_optimization=y
+_use_auto_optimization=
## Apply Kernel Optimization selecting
_use_optimization_select=
@@ -75,8 +75,8 @@ _use_current=
pkgbase=linux-cacule-rdb
pkgname=('linux-cacule-rdb' 'linux-cacule-rdb-headers')
pkgname=("${pkgbase}" "${pkgbase}-headers")
-pkgver=5.14.6
-pkgrel=2
+pkgver=5.14.7
+pkgrel=1
arch=(x86_64 x86_64_v3)
pkgdesc='Linux-CacULE-RDB Kernel by Hamad Marri and with some other patchsets compiled'
_gittag=v${pkgver%.*}-${pkgver##*.}
@@ -97,9 +97,9 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${pkgver:0:1}.x/linux-${pkgver
"${_patchsource}/misc/0007-string.patch"
"${_patchsource}/misc/allpollingrate.patch"
"${_patchsource}/misc/0001-LL-kconfig-add-750Hz-timer-interrupt-kernel-config-o.patch"
- "${_patchsource}/misc/0001-AMD-CPPC.patch"
+# "${_patchsource}/misc/0001-AMD-CPPC.patch"
"${_patchsource}/misc/zen-tweaks-cacule.patch"
- "${_patchsource}/bfq-patches-v2/0001-bfq-patches.patch"
+# "${_patchsource}/bfq-patches-v2/0001-bfq-patches.patch"
"${_patchsource}/android-patches/0001-android-export-symbold-and-enable-building-ashmem-an.patch"
"${_patchsource}/bbr2-patches/0001-bbr2-5.14-introduce-BBRv2.patch"
"${_patchsource}/block-patches/0001-block-patches.patch"
@@ -117,7 +117,7 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${pkgver:0:1}.x/linux-${pkgver
"${_patchsource}/zen-patches/0001-zen-patches.patch"
"${_patchsource}/zstd-patches-v2/0001-zstd-patches.patch"
"${_patchsource}/zstd-upstream-patches-v3/0001-zstd-upstream-patches.patch"
- "${_patchsource}/ntfs3-patches-v7/0001-ntfs3-patches.patch"
+ "${_patchsource}/ntfs3-patches-v9/0001-ntfs3-patches.patch"
"${_patchsource}/0001-cpu-patches.patch"
"${_patchsource}/0001-winesync.patch"
"${_patchsource}/0001-v4l2loopback.patch"
@@ -183,7 +183,7 @@ prepare() {
### Optionally set tickrate to 500HZ
if [ -n "$_750_HZ_ticks" ]; then
- echo "Setting tick rate to 500HZ..."
+ echo "Setting tick rate to 750HZ..."
scripts/config --disable CONFIG_HZ_300
scripts/config --enable CONFIG_HZ_750
scripts/config --set-val CONFIG_HZ 750
@@ -352,7 +352,8 @@ prepare() {
scripts/config --enable CONFIG_NTFS3_64BIT_CLUSTER
scripts/config --enable CONFIG_NTFS3_LZX_XPRESS
scripts/config --enable CONFIG_NTFS3_FS_POSIX_ACL
- scripts/config --enable CONFIG_x86_AMD_PSTATE
+ scripts/config --enable CONFIG_ZEN_INTERACTIVE
+# scripts/config --enable CONFIG_x86_AMD_PSTATE
### Optionally use running kernel's config
# code originally by nous; http://aur.archlinux.org/packages.php?ID=40191
if [ -n "$_use_current" ]; then
@@ -518,16 +519,14 @@ package_linux-cacule-rdb-headers() {
}
-md5sums=('006dc61878252d9f0e2a0b0bd9d134ff'
- '8066473543540ff55225fa1b6a88eaca'
+md5sums=('4119cf1e59ef6f109b9be9451a0899ae'
+ 'c2d3bfc527c90284817e31e4888b0175'
'7524899b1b1c14e6d993be59dc68faf3'
'024a0126cfcd18e000a2241f35c4d69e'
'd6e5581b4fade267a28deb8e73d236f5'
'f154315498da9bf593c11d88041bde48'
'f8e172e9ea554bbb1053eb122c3ace35'
- '302cbad3c979395f37307a094f6d8fd5'
'9d7612159f8745044254077ce8a76df6'
- '58eab1d2000ac3fa1d6ab933b13397cc'
'e45c7962a78d6e82a0d3808868cd6ac0'
'196d6ac961497aa880264b83160eb140'
'a3f2cbf318dd2a63af9673f9e34e7125'
@@ -543,7 +542,7 @@ md5sums=('006dc61878252d9f0e2a0b0bd9d134ff'
'381bc4f0ff885e9b67e5899476a30416'
'808981a36c81165953017e5e432c1fa1'
'74db4069a1c3985e5de43cf28f44e693'
- 'a967dc62d8a3bbd772f2594a6257cc2a'
+ '6e67c94d6dbc63b910f78b6480962993'
'bb22330e270bf36ccf53cb04d6b496d2'
'4c493a3e0f3486be8ad1b6c67c9c6917'
'95eb4457f95f3f8dd153983612ee65c0'