summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD314
1 files changed, 171 insertions, 143 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1093a831f434..88cd3e887868 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,168 +1,182 @@
-# Maintainer: graysky <graysky AT archlinux DOT us>
+# Maintainer: graysky <therealgraysky AT protonmail DOT com>
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
### BUILD OPTIONS
-# Set these variables to ANYTHING that is not null to enable them
+# Any/all of the next three variables may be set to ANYTHING
+# that is not null to enable their respective build options
# Tweak kernel options prior to a build via nconfig
_makenconfig=
-# Optionally select a sub architecture by number if building in a clean chroot
-# Leaving this entry blank will require user interaction during the build
-# which will cause a failure to build if using makechrootpkg. Note that the
-# generic (default) option is 32.
-#
-# Note - the march=native option is unavailable by this method, use the nconfig
-# and manually select it.
-#
-# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
-# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3)
-# 3. AMD 61xx/7x50/PhenomX3/X4/II/K10 (MK10)
-# 4. AMD Barcelona (MBARCELONA)
-# 5. AMD Bobcat (MBOBCAT)
-# 6. AMD Jaguar (MJAGUAR)
-# 7. AMD Bulldozer (MBULLDOZER)
-# 8. AMD Piledriver (MPILEDRIVER)
-# 9. AMD Steamroller (MSTEAMROLLER)
-# 10. AMD Excavator (MEXCAVATOR)
-# 11. AMD Zen (MZEN)
-# 12. AMD Zen 2 (MZEN2)
-# 13. Intel P4 / older Netburst based Xeon (MPSC)
-# 14. Intel Atom (MATOM)
-# 15. Intel Core 2 (MCORE2)
-# 16. Intel Nehalem (MNEHALEM)
-# 17. Intel Westmere (MWESTMERE)
-# 18. Intel Silvermont (MSILVERMONT)
-# 19. Intel Goldmont (MGOLDMONT)
-# 20. Intel Goldmont Plus (MGOLDMONTPLUS)
-# 21. Intel Sandy Bridge (MSANDYBRIDGE)
-# 22. Intel Ivy Bridge (MIVYBRIDGE)
-# 23. Intel Haswell (MHASWELL)
-# 24. Intel Broadwell (MBROADWELL)
-# 25. Intel Skylake (MSKYLAKE)
-# 26. Intel Skylake X (MSKYLAKEX)
-# 27. Intel Cannon Lake (MCANNONLAKE)
-# 28. Intel Ice Lake (MICELAKE)
-# 29. Intel Cascade Lake (MCASCADELAKE)
-# 30. Intel Cooper Lake (MCOOPERLAKE)
-# 31. Intel Tiger Lake (MTIGERLAKE)
-# 32. Generic-x86-64 (GENERIC_CPU)
-# 33. Native optimizations autodetected by GCC (MNATIVE)
-
-_subarch=
-
-# Compile ONLY used modules to VASTLYreduce the number of modules built
-# and the build time.
+# Only compile select modules to reduce the number of modules built
#
# To keep track of which modules are needed for your specific system/hardware,
-# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
-# This PKGBUILD read the database kept if it exists
-#
+# give module_db a try: https://aur.archlinux.org/packages/modprobed-db
+# This PKGBUILD reads the database kept if it exists
# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
_localmodcfg=
-### IMPORTANT: Do no edit below this line unless you know what you're doing
+# Compile using clang rather than gcc
+_clangbuild=
+
+# Optionally select a sub architecture by number or leave blank which will
+# require user interaction during the build. Note that the generic (default)
+# option is 39.
+_subarch=
+# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
+# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3) (NEW)
+# 3. AMD 61xx/7x50/PhenomX3/X4/II/K10 (MK10) (NEW)
+# 4. AMD Barcelona (MBARCELONA) (NEW)
+# 5. AMD Bobcat (MBOBCAT) (NEW)
+# 6. AMD Jaguar (MJAGUAR) (NEW)
+# 7. AMD Bulldozer (MBULLDOZER) (NEW)
+# 8. AMD Piledriver (MPILEDRIVER) (NEW)
+# 9. AMD Steamroller (MSTEAMROLLER) (NEW)
+# 10. AMD Excavator (MEXCAVATOR) (NEW)
+# 11. AMD Zen (MZEN) (NEW)
+# 12. AMD Zen 2 (MZEN2) (NEW)
+# 13. AMD Zen 3 (MZEN3) (NEW)
+# 14. AMD Zen 4 (MZEN4) (NEW)
+# 15. Intel P4 / older Netburst based Xeon (MPSC)
+# 16. Intel Core 2 (MCORE2)
+# 17. Intel Atom (MATOM)
+# 18. Intel Nehalem (MNEHALEM) (NEW)
+# 19. Intel Westmere (MWESTMERE) (NEW)
+# 20. Intel Silvermont (MSILVERMONT) (NEW)
+# 21. Intel Goldmont (MGOLDMONT) (NEW)
+# 22. Intel Goldmont Plus (MGOLDMONTPLUS) (NEW)
+# 23. Intel Sandy Bridge (MSANDYBRIDGE) (NEW)
+# 24. Intel Ivy Bridge (MIVYBRIDGE) (NEW)
+# 25. Intel Haswell (MHASWELL) (NEW)
+# 26. Intel Broadwell (MBROADWELL) (NEW)
+# 27. Intel Skylake (MSKYLAKE) (NEW)
+# 28. Intel Skylake X (MSKYLAKEX) (NEW)
+# 29. Intel Cannon Lake (MCANNONLAKE) (NEW)
+# 30. Intel Ice Lake (MICELAKE) (NEW)
+# 31. Intel Cascade Lake (MCASCADELAKE) (NEW)
+# 32. Intel Cooper Lake (MCOOPERLAKE) (NEW)
+# 33. Intel Tiger Lake (MTIGERLAKE) (NEW)
+# 34. Intel Sapphire Rapids (MSAPPHIRERAPIDS) (NEW)
+# 35. Intel Rocket Lake (MROCKETLAKE) (NEW)
+# 36. Intel Alder Lake (MALDERLAKE) (NEW)
+# 37. Intel Raptor Lake (MRAPTORLAKE) (NEW)
+# 38. Intel Meteor Lake (MMETEORLAKE) (NEW)
+# 39. Generic-x86-64 (GENERIC_CPU)
+# 40. Generic-x86-64-v2 (GENERIC_CPU2) (NEW)
+# 41. Generic-x86-64-v3 (GENERIC_CPU3) (NEW)
+# 42. Generic-x86-64-v4 (GENERIC_CPU4) (NEW)
+# 43. Intel-Native optimizations autodetected by the compiler (MNATIVE_INTEL) (NEW)
+# 44. AMD-Native optimizations autodetected by the compiler (MNATIVE_AMD) (NEW)
+
+### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-pkgver=5.9.11
+pkgver=6.8.1
+_upstream=arch1
pkgrel=1
-_ckpatchversion=1
arch=(x86_64)
url="https://wiki.archlinux.org/index.php/Linux-ck"
-license=(GPL2)
+license=(GPL-2.0-only)
makedepends=(
- bc kmod libelf
+ bc
+ cpio
+ gettext
+ libelf
+ pahole
+ perl
+ python
+ tar
+ xz
+)
+[[ -n "$_clangbuild" ]] && makedepends+=(clang llvm lld python)
+options=(
+ !debug
+ !strip
)
-options=('!strip')
-_ckpatch="patch-5.9-ck${_ckpatchversion}"
-_gcc_more_v='20201113'
+
+# https://ck-hack.blogspot.com/2021/08/514-and-future-of-muqss-and-ck-once.html
+# acknowledgment to xanmod for initially keeping the hrtimer patches up to date
+_ckhrtimer=linux-6.8.y
+_commit=ae3cbb29c43ca1baa6781f547d17b8ee5663e9d7
+
+_gcc_more_v=20240221.2
source=(
- "https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sign}
- config # the main kernel config file
- "enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz"
- "http://ck.kolivas.org/patches/5.0/5.9/5.9-ck${_ckpatchversion}/$_ckpatch.xz"
- 0000-sphinx-workaround.patch
- 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-Bluetooth-Fix-LL-PRivacy-BLE-device-fails-to-connect.patch
+ "https://www.kernel.org/pub/linux/kernel/v6.x/linux-$pkgver.tar".{xz,sign}
+ config # the main kernel config file
+ "https://github.com/archlinux/linux/releases/download/v$pkgver-$_upstream/linux-v$pkgver-$_upstream.patch.zst"
+ "more-uarches-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/$_gcc_more_v.tar.gz"
+ "ck-hrtimer-$_commit.tar.gz::https://github.com/graysky2/linux-patches/archive/$_commit.tar.gz"
)
validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+ ABAF11C65A2970B130ABE3C479BE3E4300411886 # Linus Torvalds
+ 647F28654894E3BD457199BE38DBBDC86092693E # Greg Kroah-Hartman
)
-b2sums=('fbcf8b93e4a37e0f45c2de4275ecdfdb80ade1a6cf7e2b62cb331cce2d8fc247eedc14c5c37583b6e10cce58515ec3c9e541f21d067ee8d19567f9edcf065b62'
- 'SKIP'
- '834e3290b80055fb99855cebb175152d42800c0e4750e7e1c1e65448783772174c4b6d9194fea7d59a6b41dca8a438628b2692a308ccdfd2d1ced3e0af422d4c'
- '7f1eb5938472f57748216bd00e0c875feab99fc1c5cb89babfea467ee30ca5c8e9fc5a691efe2e602bef1ea79820c5383822d7cec354b48d23321ccda8ee8127'
- 'c19099ad66168db4608dee44e1913c07c035bc002a91267abc2e1eadf1788ddb5be3b17e3fdfeddcba96526dfa2b9fcc43a5dd0f8236d94c864e6477924a6718'
- 'b4e1377d97ad7e8144d6e55b6d43731e3271a5aec65b65ca6d81026a95f15f549b9303fb3c6f492099ca691e3f65f4cf7f0c3aa742df03b396d7f6d81813aa95'
- '1647fc2b71cf7e01806369b436f000eace66f1004e399321b45046196149e2768539ca72ffa7660ec801dd1c6532a10a2dd40a2329fd65aea1e404530b75d539'
- '2e68bde14361ab367a3ad682a8f4f7d6b0df2516073f7645d2d1183b6063f440a79644037f9a577bad2182fcfd03e16846becc297dd9b0e3ca0b43afd00bf5e1')
-
-export KBUILD_BUILD_HOST=archlinux
-export KBUILD_BUILD_USER=$pkgbase
-export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
+sha256sums=('8d0c8936e3140a0fbdf511ad7a9f21121598f3656743898f47bb9052d37cff68'
+ 'SKIP'
+ 'c2b00c84c4b543db431e06604d939a62f93107d18369f4d9860dc8062b01ab45'
+ '376db82b4613c3942932fde99d54c3dea1e4b29ab23d8b86daa6414327e6244d'
+ '1d3ac3e581cbc5108f882fcdc75d74f7f069654c71bad65febe5ba15a7a3a14f'
+ '111adfc5b9c7d3bfd7d1a06286e7bee853dd1f51ecca3948eed39710eaf51381')
prepare() {
cd linux-${pkgver}
- echo "Setting version..."
- scripts/setlocalversion --save-scmversion
+ msg2 "Setting version..."
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
- local src
- for src in "${source[@]}"; do
- src="${src%%::*}"
- src="${src##*/}"
- [[ $src = 0*.patch ]] || continue
- echo "Applying patch $src..."
- patch -Np1 < "../$src"
- done
+ msg2 "Applying Arch Linux $_upstream patch set"
+ patch -p1 -i ../linux-v$pkgver-$_upstream.patch || exit 1
+
+ # remove the -archx suffix
+ sed -i s'/^EXTRAVERSION =.*/EXTRAVERSION =/' Makefile
echo "Setting config..."
cp ../config .config
- # disable CONFIG_DEBUG_INFO=y at build time otherwise memory usage blows up
- # and can easily overwhelm a system with 32 GB of memory using a tmpfs build
- # partition ... this was introduced by FS#66260, see:
- # https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=663b08666b269eeeeaafbafaee07fd03389ac8d7
- sed -i -e 's/CONFIG_DEBUG_INFO=y/# CONFIG_DEBUG_INFO is not set/' \
- -i -e '/CONFIG_DEBUG_INFO_DWARF4=y/d' \
- -i -e '/CONFIG_DEBUG_INFO_BTF=y/d' ./.config
-
# https://bbs.archlinux.org/viewtopic.php?pid=1824594#p1824594
- sed -i -e 's/# CONFIG_PSI_DEFAULT_DISABLED is not set/CONFIG_PSI_DEFAULT_DISABLED=y/' ./.config
+ scripts/config --enable CONFIG_PSI_DEFAULT_DISABLED
# https://bbs.archlinux.org/viewtopic.php?pid=1863567#p1863567
- sed -i -e '/CONFIG_LATENCYTOP=/ s,y,n,' \
- -i -e '/CONFIG_SCHED_DEBUG=/ s,y,n,' ./.config
+ scripts/config --disable CONFIG_LATENCYTOP
+ scripts/config --disable CONFIG_SCHED_DEBUG
# FS#66613
# https://bugzilla.kernel.org/show_bug.cgi?id=207173#c6
- sed -i -e 's/CONFIG_KVM_WERROR=y/# CONFIG_KVM_WERROR is not set/' ./.config
+ scripts/config --disable CONFIG_KVM_WERROR
+
+ # ck recommends 1000 Hz tick and the hrtimer patches in lieu of ck1
+ scripts/config --enable CONFIG_HZ_1000
+
+ # these are ck's htrimer patches
+ echo "Patching with ck hrtimer patches..."
- # fix naming schema in EXTRAVERSION of ck patch set
- sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../${_ckpatch}"
+ for i in ../linux-patches-"$_commit"/"$_ckhrtimer"/ck-hrtimer/0*.patch; do
+ patch -Np1 -i $i
+ done
- # ck patchset itself
- echo "Patching with ck patchset..."
- patch -Np1 -i ../"${_ckpatch}"
+ if [[ -n "$_clangbuild" ]]; then
+ scripts/config -e LTO_CLANG_THIN
+ export _LLVM=1
+ export _LLVM_IAS=$_LLVM
+ fi
# non-interactively apply ck1 default options
# this isn't redundant if we want a clean selection of subarch below
- make olddefconfig
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM olddefconfig
+ diff -u ../config .config || :
# https://github.com/graysky2/kernel_gcc_patch
# make sure to apply after olddefconfig to allow the next section
- echo "Patching to enable GCC optimization for other uarchs..."
- patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v5.8+.patch"
+ msg2 "Patching to enable GCC optimization for other uarchs..."
+ patch -Np1 -i "$srcdir/kernel_compiler_patch-$_gcc_more_v/more-uarches-for-kernel-6.8-rc4+.patch"
if [ -n "$_subarch" ]; then
# user wants a subarch so apply choice defined above interactively via 'yes'
- yes "$_subarch" | make oldconfig
+ yes "$_subarch" | make LLVM=$_LLVM LLVM_IAS=$_LLVM oldconfig
else
# no subarch defined so allow user to pick one
- make oldconfig
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM oldconfig
fi
### Optionally load needed modules for the make localmodconfig
@@ -170,7 +184,7 @@ prepare() {
if [ -n "$_localmodcfg" ]; then
if [ -f $HOME/.config/modprobed.db ]; then
echo "Running Steven Rostedt's make localmodconfig now"
- make LSMOD=$HOME/.config/modprobed.db localmodconfig
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM LSMOD="$HOME/.config/modprobed.db" localmodconfig
else
echo "No modprobed.db data found"
exit
@@ -178,31 +192,47 @@ prepare() {
fi
make -s kernelrelease > version
- echo "Prepared $pkgbase version $(<version)"
+ msg2 "Prepared $pkgbase version $(<version)"
- [[ -z "$_makenconfig" ]] || make nconfig
+ [[ -z "$_makenconfig" ]] || make LLVM=$_LLVM LLVM_IAS=$_LLVM nconfig
# save configuration for later reuse
cat .config > "${startdir}/config.last"
+
+ # uncomment if you want to build with distcc
+ ### sed -i '/HAVE_GCC_PLUGINS/d' arch/x86/Kconfig
}
build() {
cd linux-${pkgver}
- make all
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM all
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM -C tools/bpf/bpftool vmlinux.h feature-clang-bpf-co-re=1
}
_package() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the ck1 patchset featuring MuQSS CPU scheduler"
- depends=(coreutils kmod initramfs)
- optdepends=('crda: to set the correct wireless channels of your country'
- 'linux-firmware: firmware images needed for some devices')
- provides=("linux-ck=${pkgver}")
+ pkgdesc="The Linux kernel and modules with ck's hrtimer patches"
+ depends=(
+ coreutils
+ initramfs
+ kmod
+ )
+ optdepends=(
+ 'wireless-regdb: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ )
+ provides=(
+ KSMBD-MODULE
+ VIRTUALBOX-GUEST-MODULES
+ WIREGUARD-MODULE
+ )
+ replaces=(
+ virtualbox-guest-modules-arch
+ wireguard-arch
+ )
#groups=('ck-generic')
cd linux-${pkgver}
-
- local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+ local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
@@ -217,19 +247,16 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- #make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
- # not needed since not building with CONFIG_DEBUG_INFO=y
+ ZSTD_CLEVEL=19 make LLVM=$_LLVM LLVM_IAS=$_LLVM INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
- make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
-
- # remove build and source links
- rm "$modulesdir"/{source,build}
+ # remove build link
+ rm "$modulesdir"/build
}
_package-headers() {
pkgdesc="Headers and scripts for building modules for ${pkgbase/linux/Linux} kernel"
- depends=('linux-ck') # added to keep kernel and headers packages matched
- provides=("linux-ck-headers=${pkgver}" "linux-headers=${pkgver}")
+ depends=(pahole "$pkgbase") # added to keep kernel and headers packages matched
#groups=('ck-generic')
cd linux-${pkgver}
@@ -237,16 +264,16 @@ _package-headers() {
echo "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
- localversion.* version vmlinux
+ localversion.* version vmlinux tools/bpf/bpftool/vmlinux.h
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
- # add objtool for external module building and enabled VALIDATION_STACK option
+ # required when STACK_VALIDATION is enabled
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
- # add xfs and shmem for aufs building
- mkdir -p "$builddir"/{fs/xfs,mm}
+ # required when DEBUG_INFO_BTF_MODULES is enabled
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
echo "Installing headers..."
cp -t "$builddir" -a include
@@ -256,14 +283,17 @@ _package-headers() {
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/13146
+ # https://bugs.archlinux.org/task/13146
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
- # http://bugs.archlinux.org/task/20402
+ # https://bugs.archlinux.org/task/20402
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
+ # https://bugs.archlinux.org/task/71392
+ install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
+
echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
@@ -287,7 +317,7 @@ _package-headers() {
echo "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
@@ -299,14 +329,12 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
- #echo "Stripping vmlinux..."
- #strip -v $STRIP_STATIC "$builddir/vmlinux"
- # not needed since not building with CONFIG_DEBUG_INFO=y
+ echo "Stripping vmlinux..."
+ strip -v $STRIP_STATIC "$builddir/vmlinux"
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
-
}
pkgname=("$pkgbase" "$pkgbase-headers")