summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD193
1 files changed, 96 insertions, 97 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ece9091aabe6..88cd3e887868 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ _clangbuild=
# Optionally select a sub architecture by number or leave blank which will
# require user interaction during the build. Note that the generic (default)
-# option is 36.
+# option is 39.
_subarch=
# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
@@ -37,115 +37,103 @@ _subarch=
# 11. AMD Zen (MZEN) (NEW)
# 12. AMD Zen 2 (MZEN2) (NEW)
# 13. AMD Zen 3 (MZEN3) (NEW)
-# 14. Intel P4 / older Netburst based Xeon (MPSC)
-# 15. Intel Core 2 (MCORE2)
-# 16. Intel Atom (MATOM)
-# 17. Intel Nehalem (MNEHALEM) (NEW)
-# 18. Intel Westmere (MWESTMERE) (NEW)
-# 19. Intel Silvermont (MSILVERMONT) (NEW)
-# 20. Intel Goldmont (MGOLDMONT) (NEW)
-# 21. Intel Goldmont Plus (MGOLDMONTPLUS) (NEW)
-# 22. Intel Sandy Bridge (MSANDYBRIDGE) (NEW)
-# 23. Intel Ivy Bridge (MIVYBRIDGE) (NEW)
-# 24. Intel Haswell (MHASWELL) (NEW)
-# 25. Intel Broadwell (MBROADWELL) (NEW)
-# 26. Intel Skylake (MSKYLAKE) (NEW)
-# 27. Intel Skylake X (MSKYLAKEX) (NEW)
-# 28. Intel Cannon Lake (MCANNONLAKE) (NEW)
-# 29. Intel Ice Lake (MICELAKE) (NEW)
-# 30. Intel Cascade Lake (MCASCADELAKE) (NEW)
-# 31. Intel Cooper Lake (MCOOPERLAKE) (NEW)
-# 32. Intel Tiger Lake (MTIGERLAKE) (NEW)
-# 33. Intel Sapphire Rapids (MSAPPHIRERAPIDS) (NEW)
-# 34. Intel Rocket Lake (MROCKETLAKE) (NEW)
-# 35. Intel Alder Lake (MALDERLAKE) (NEW)
-# 36. Generic-x86-64 (GENERIC_CPU)
-# 37. Generic-x86-64-v2 (GENERIC_CPU2) (NEW)
-# 38. Generic-x86-64-v3 (GENERIC_CPU3) (NEW)
-# 39. Generic-x86-64-v4 (GENERIC_CPU4) (NEW)
-# 40. Intel-Native optimizations autodetected by GCC (MNATIVE_INTEL) (NEW)
-# 41. AMD-Native optimizations autodetected by GCC (MNATIVE_AMD) (NEW)
+# 14. AMD Zen 4 (MZEN4) (NEW)
+# 15. Intel P4 / older Netburst based Xeon (MPSC)
+# 16. Intel Core 2 (MCORE2)
+# 17. Intel Atom (MATOM)
+# 18. Intel Nehalem (MNEHALEM) (NEW)
+# 19. Intel Westmere (MWESTMERE) (NEW)
+# 20. Intel Silvermont (MSILVERMONT) (NEW)
+# 21. Intel Goldmont (MGOLDMONT) (NEW)
+# 22. Intel Goldmont Plus (MGOLDMONTPLUS) (NEW)
+# 23. Intel Sandy Bridge (MSANDYBRIDGE) (NEW)
+# 24. Intel Ivy Bridge (MIVYBRIDGE) (NEW)
+# 25. Intel Haswell (MHASWELL) (NEW)
+# 26. Intel Broadwell (MBROADWELL) (NEW)
+# 27. Intel Skylake (MSKYLAKE) (NEW)
+# 28. Intel Skylake X (MSKYLAKEX) (NEW)
+# 29. Intel Cannon Lake (MCANNONLAKE) (NEW)
+# 30. Intel Ice Lake (MICELAKE) (NEW)
+# 31. Intel Cascade Lake (MCASCADELAKE) (NEW)
+# 32. Intel Cooper Lake (MCOOPERLAKE) (NEW)
+# 33. Intel Tiger Lake (MTIGERLAKE) (NEW)
+# 34. Intel Sapphire Rapids (MSAPPHIRERAPIDS) (NEW)
+# 35. Intel Rocket Lake (MROCKETLAKE) (NEW)
+# 36. Intel Alder Lake (MALDERLAKE) (NEW)
+# 37. Intel Raptor Lake (MRAPTORLAKE) (NEW)
+# 38. Intel Meteor Lake (MMETEORLAKE) (NEW)
+# 39. Generic-x86-64 (GENERIC_CPU)
+# 40. Generic-x86-64-v2 (GENERIC_CPU2) (NEW)
+# 41. Generic-x86-64-v3 (GENERIC_CPU3) (NEW)
+# 42. Generic-x86-64-v4 (GENERIC_CPU4) (NEW)
+# 43. Intel-Native optimizations autodetected by the compiler (MNATIVE_INTEL) (NEW)
+# 44. AMD-Native optimizations autodetected by the compiler (MNATIVE_AMD) (NEW)
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-pkgver=5.19.11
+pkgver=6.8.1
+_upstream=arch1
pkgrel=1
arch=(x86_64)
url="https://wiki.archlinux.org/index.php/Linux-ck"
-license=(GPL2)
+license=(GPL-2.0-only)
makedepends=(
- bc libelf cpio perl tar xz
+ bc
+ cpio
+ gettext
+ libelf
+ pahole
+ perl
+ python
+ tar
+ xz
)
[[ -n "$_clangbuild" ]] && makedepends+=(clang llvm lld python)
-options=('!strip')
+options=(
+ !debug
+ !strip
+)
# https://ck-hack.blogspot.com/2021/08/514-and-future-of-muqss-and-ck-once.html
# acknowledgment to xanmod for initially keeping the hrtimer patches up to date
-_ckhrtimer=linux-5.19.y
-_commit=9b792e6dc19ee6bd70e7c71f579f4d87ff929c60
+_ckhrtimer=linux-6.8.y
+_commit=ae3cbb29c43ca1baa6781f547d17b8ee5663e9d7
-_gcc_more_v=20220315
+_gcc_more_v=20240221.2
source=(
- "https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sign}
- config # the main kernel config file
+ "https://www.kernel.org/pub/linux/kernel/v6.x/linux-$pkgver.tar".{xz,sign}
+ config # the main kernel config file
+ "https://github.com/archlinux/linux/releases/download/v$pkgver-$_upstream/linux-v$pkgver-$_upstream.patch.zst"
"more-uarches-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/$_gcc_more_v.tar.gz"
"ck-hrtimer-$_commit.tar.gz::https://github.com/graysky2/linux-patches/archive/$_commit.tar.gz"
- 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-drm-i915-psr-Use-full-update-In-case-of-area-calcula.patch
- 0003-drm-i915-Ensure-damage-clip-area-is-within-pipe-area.patch
- 0004-mm-vmscan-fix-extreme-overreclaim-and-swap-floods.patch
- 0005-soundwire-intel-use-pm_runtime_resume-on-component-p.patch
- 0006-Bluetooth-fix-deadlock-for-RFCOMM-sk-state-change.patch
- 0007-ASoC-Intel-sof_sdw-add-support-for-Dell-SKU-0AFF.patch
)
validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+ ABAF11C65A2970B130ABE3C479BE3E4300411886 # Linus Torvalds
+ 647F28654894E3BD457199BE38DBBDC86092693E # Greg Kroah-Hartman
)
-sha256sums=('5554d2f90b806bb3454fcf3432882cf85077d660a89db5a4e8d7375271e3d973'
+sha256sums=('8d0c8936e3140a0fbdf511ad7a9f21121598f3656743898f47bb9052d37cff68'
'SKIP'
- '7dcbed3f72a2a84dd5b40bbe38c8fa2d82d1d68fcaa657f40163a6123a19886f'
- '5a29d172d442a3f31a402d7d306aaa292b0b5ea29139d05080a55e2425f48c5c'
- '7037fa27b33666a3bd20c888c667efb218e95e45af8debe591896cc79fe69c76'
- '85fa81ddbc48c0775f220a378348ad0d9766a03cbecd277a814cf3b579d45108'
- '5e7e99006fad5f53c575530f669e7e339d3533cdc3e38381d4fdc1b9d570d221'
- '36e19de5c004a8bc91ee82c049f40fc90d2f4902f97faf3a14e75025f2a40d13'
- '33025678ce2804ec8855537cb7801226e769c3e7d27ff9edd706de526d89686e'
- '3ad14c8a2bfbbc1a0b3a54d01d7cb9698e564cf0e8047da0ae8d6c1d20d98f36'
- '04a844a87d0cbf7a2210f59aab07ee203fdb36959d5d3f69f7f86124ee760768'
- '6c0faae6fe0c624fe80776f12b53ec917acfbc07811222c41640a3d1dfff5353')
+ 'c2b00c84c4b543db431e06604d939a62f93107d18369f4d9860dc8062b01ab45'
+ '376db82b4613c3942932fde99d54c3dea1e4b29ab23d8b86daa6414327e6244d'
+ '1d3ac3e581cbc5108f882fcdc75d74f7f069654c71bad65febe5ba15a7a3a14f'
+ '111adfc5b9c7d3bfd7d1a06286e7bee853dd1f51ecca3948eed39710eaf51381')
prepare() {
cd linux-${pkgver}
msg2 "Setting version..."
- scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
- local src
- for src in "${source[@]}"; do
- src="${src%%::*}"
- src="${src##*/}"
- [[ $src = 0*.patch ]] || continue
- echo "Applying patch $src..."
- patch -Np1 < "../$src"
- done
+ msg2 "Applying Arch Linux $_upstream patch set"
+ patch -p1 -i ../linux-v$pkgver-$_upstream.patch || exit 1
+
+ # remove the -archx suffix
+ sed -i s'/^EXTRAVERSION =.*/EXTRAVERSION =/' Makefile
echo "Setting config..."
cp ../config .config
- # disable CONFIG_DEBUG_INFO=y at build time otherwise memory usage blows up
- # and can easily overwhelm a system with 32 GB of memory using a tmpfs build
- # partition ... this was introduced by FS#66260, see:
- # https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=663b08666b269eeeeaafbafaee07fd03389ac8d7
- scripts/config --disable CONFIG_DEBUG_INFO
- scripts/config --disable CONFIG_CGROUP_BPF
- scripts/config --disable CONFIG_BPF_LSM
- scripts/config --disable CONFIG_BPF_PRELOAD
- scripts/config --disable CONFIG_BPF_LIRC_MODE2
- scripts/config --disable CONFIG_BPF_KPROBE_OVERRIDE
-
# https://bbs.archlinux.org/viewtopic.php?pid=1824594#p1824594
scripts/config --enable CONFIG_PSI_DEFAULT_DISABLED
@@ -180,8 +168,8 @@ prepare() {
# https://github.com/graysky2/kernel_gcc_patch
# make sure to apply after olddefconfig to allow the next section
- echo "Patching to enable GCC optimization for other uarchs..."
- patch -Np1 -i "$srcdir/kernel_compiler_patch-$_gcc_more_v/more-uarches-for-kernel-5.17+.patch"
+ msg2 "Patching to enable GCC optimization for other uarchs..."
+ patch -Np1 -i "$srcdir/kernel_compiler_patch-$_gcc_more_v/more-uarches-for-kernel-6.8-rc4+.patch"
if [ -n "$_subarch" ]; then
# user wants a subarch so apply choice defined above interactively via 'yes'
@@ -204,7 +192,7 @@ prepare() {
fi
make -s kernelrelease > version
- echo "Prepared $pkgbase version $(<version)"
+ msg2 "Prepared $pkgbase version $(<version)"
[[ -z "$_makenconfig" ]] || make LLVM=$_LLVM LLVM_IAS=$_LLVM nconfig
@@ -218,21 +206,33 @@ prepare() {
build() {
cd linux-${pkgver}
make LLVM=$_LLVM LLVM_IAS=$_LLVM all
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM -C tools/bpf/bpftool vmlinux.h feature-clang-bpf-co-re=1
}
_package() {
pkgdesc="The Linux kernel and modules with ck's hrtimer patches"
- depends=(coreutils kmod initramfs)
- optdepends=('wireless-regdb: to set the correct wireless channels of your country'
- 'linux-firmware: firmware images needed for some devices')
- provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE KSMBD-MODULE)
- replaces=(virtualbox-guest-modules-arch wireguard-arch)
+ depends=(
+ coreutils
+ initramfs
+ kmod
+ )
+ optdepends=(
+ 'wireless-regdb: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ )
+ provides=(
+ KSMBD-MODULE
+ VIRTUALBOX-GUEST-MODULES
+ WIREGUARD-MODULE
+ )
+ replaces=(
+ virtualbox-guest-modules-arch
+ wireguard-arch
+ )
#groups=('ck-generic')
cd linux-${pkgver}
-
- local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+ local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
@@ -247,16 +247,16 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make LLVM=$_LLVM LLVM_IAS=$_LLVM INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ ZSTD_CLEVEL=19 make LLVM=$_LLVM LLVM_IAS=$_LLVM INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
DEPMOD=/doesnt/exist modules_install # Suppress depmod
- # remove build and source links
- rm "$modulesdir"/{source,build}
+ # remove build link
+ rm "$modulesdir"/build
}
_package-headers() {
pkgdesc="Headers and scripts for building modules for ${pkgbase/linux/Linux} kernel"
- depends=("$pkgbase") # added to keep kernel and headers packages matched
+ depends=(pahole "$pkgbase") # added to keep kernel and headers packages matched
#groups=('ck-generic')
cd linux-${pkgver}
@@ -264,7 +264,7 @@ _package-headers() {
echo "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
- localversion.* version vmlinux
+ localversion.* version vmlinux tools/bpf/bpftool/vmlinux.h
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
@@ -273,7 +273,7 @@ _package-headers() {
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
# required when DEBUG_INFO_BTF_MODULES is enabled
- #install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
echo "Installing headers..."
cp -t "$builddir" -a include
@@ -317,7 +317,7 @@ _package-headers() {
echo "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
@@ -331,7 +331,6 @@ _package-headers() {
echo "Stripping vmlinux..."
strip -v $STRIP_STATIC "$builddir/vmlinux"
- # not needed since not building with CONFIG_DEBUG_INFO=y
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"