summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e1a68ee8188..1abcc00b50c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,14 +52,14 @@ _BFQ_enable_=
pkgname=(linux-ck linux-ck-headers)
_kernelname=-ck
_srcname=linux-4.7
-pkgver=4.7.2
-pkgrel=2
+pkgver=4.7.3
+pkgrel=1
arch=('i686' 'x86_64')
url="https://wiki.archlinux.org/index.php/Linux-ck"
license=('GPL2')
makedepends=('kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
-_ckpatchversion=2
+_ckpatchversion=3
_ckpatchname="patch-4.7-ck${_ckpatchversion}"
_gcc_patch='enable_additional_cpu_optimizations_for_gcc_v4.9+_kernel_v3.15+.patch'
_bfqpath='http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.7.0-v8r2'
@@ -85,13 +85,13 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"$_bfqpath/$_bfqp4")
sha256sums=('5190c3d1209aeda04168145bf50569dc0984f80467159b1dc50ad731e3285f10'
'SKIP'
- '031cb0e7b86f2ef2cc4d0dde9d73495f68e8d23e4c41f50f7f95b065ee33a71d'
+ '826b96e794d325abf430e8d6c3279a21e97e3ec321a3962b9dd6966693b14d88'
'SKIP'
- 'e922ba93f4ea0fcf33592c1bcaeb6a273307ead9e5444c58c859d95bc2d2aeee'
- 'a6ccd0aed869a94c51b1f0395420015e4aa0e9489c3a5486443abcbd8f1c9bc4'
+ 'f06f784ffb10bbe665015c2530a1726957ded6ae0e2fa454662053daf288c719'
+ '58f516b8b1aed68a1f1925c6136b9f281d74a9f1009e2feeddca9eb54841dc61'
'2b3ebf5446aa3cac279842ca00bc1f2d6b7ff1766915282c201d763dbf6ca07e'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- 'd5bbe3b866f1744d95e6d0cc4442748c05be48be032d0014baced73ecac82152'
+ '437f0be184042e44826fa76fce08b5daea1a7d2e85e7c63177e109efb50793f1'
'cf0f984ebfbb8ca8ffee1a12fd791437064b9ebe0712d6f813fd5681d4840791'
'a6bd81bbb2f72cfd6ad992fdeff4bac1cb7c58a8edfc3fcd76c1d7275f73d284'
'144b54e95a1ffca88066e41f3c46c47df442d6497684e204e9f4312faab75572'
@@ -116,7 +116,7 @@ prepare() {
# patch source with ck patchset with BFS
# fix double name in EXTRAVERSION
sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "${srcdir}/${_ckpatchname}"
- msg "Patching source with ck1 including BFS v0.480"
+ msg "Patching source with ck3 including BFS v0.490"
patch -Np1 -i "${srcdir}/${_ckpatchname}"
# Patch source to enable more gcc CPU optimizatons via the make nconfig
@@ -241,8 +241,8 @@ build() {
}
package_linux-ck() {
- pkgdesc='Linux Kernel with the ck1 patchset featuring the Brain Fuck Scheduler v0.480.'
- #_Kpkgdesc='Linux Kernel and modules with the ck1 patchset featuring the Brain Fuck Scheduler v0.480.'
+ pkgdesc='Linux Kernel with the ck3 patchset featuring the Brain Fuck Scheduler v0.490.'
+ #_Kpkgdesc='Linux Kernel and modules with the ck3 patchset featuring the Brain Fuck Scheduler v0.490.'
#pkgdesc="${_Kpkgdesc}"
depends=('coreutils' 'linux-firmware' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country' 'nvidia-ck: nVidia drivers for linux-ck' 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')