summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 13 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a042f17020f1..8c67ff7b1e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -43,45 +43,43 @@ _use_current=
### Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-_srcname=linux-4.8
-pkgver=4.8.17
+_srcname=linux-4.9
+pkgver=4.9.3
pkgrel=1
-_ckpatchversion=8
+_ckpatchversion=1
arch=('i686' 'x86_64')
url="https://wiki.archlinux.org/index.php/Linux-ck"
license=('GPL2')
makedepends=('kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
-_ckpatchname="patch-4.8-ck${_ckpatchversion}"
+_ckpatchname="patch-4.9-ck${_ckpatchversion}"
_gcc_patch='enable_additional_cpu_optimizations_for_gcc_v4.9+_kernel_v3.15+.patch'
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
- "http://ck.kolivas.org/patches/4.0/4.8/4.8-ck${_ckpatchversion}/${_ckpatchname}.xz"
+ "http://ck.kolivas.org/patches/4.0/4.9/4.9-ck${_ckpatchversion}/${_ckpatchname}.xz"
"http://repo-ck.com/source/gcc_patch/${_gcc_patch}.gz"
# the main kernel config files
- 'config.x86_64' 'config'
+ 'config' 'config.x86_64'
# pacman hook for initramfs regeneration
'99-linux.hook'
# standard config files for mkinitcpio ramdisk
'linux.preset'
'change-default-console-loglevel.patch'
- 'net_handle_no_dst_on_skb_in_icmp6_send.patch'
'0001-x86-fpu-Fix-invalid-FPU-ptrace-state-after-execve.patch'
)
-sha256sums=('3e9150065f193d3d94bcf46a1fe9f033c7ef7122ab71d75a7fb5a2f0c9a7e11a'
+sha256sums=('029098dcffab74875e086ae970e3828456838da6e0ba22ce3f64ef764f3d7f1a'
'SKIP'
- '1e4be6f6a8eab3edcd0899db382fe1a9330320c603a9ad2c32ebb1dc6f53b3db'
+ '4465c0367becfdec0cd4ce3eb7e0f07e1bb1033bc26d49f08489a95596c782f6'
'SKIP'
- 'cea596c606da2125946154a0121ea0516583f659ad823c93669ad5d25bbc3ef7'
+ '5b9d8f4ef73f87e8595de66ccc38bad86e290fd9453bd536b9cc950f5344b82d'
'c26b4b76ca3b3dc864e1470001b46f65e007252e984e9b3c6cc8e90a18b7317f'
- '807b03333c8b0c30ace5026857ab1ca9f12457b5a599c34f4fd2e5163ffc72f8'
- 'e6fb480819d176fac7f1bf447c7c9e3217bcc64a345c6d3966f98d6e845f66d8'
+ 'f9593b21535146c9a9bc50fc360ccb1aec5eff3af271dc73d1bece670636a12d'
+ '5e2ffe1a014fbd8efc075552e3b3b946eda23ff3b5e1feee464af6374d5ba254'
'834bd254b56ab71d73f59b3221f056c72f559553c04718e350ab2a3e2991afe0'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- 'b595a1588bafb3d732841cd1b73633970706914f57f2d215c9f1494212d13989'
'3e955e0f1aae96bb6c1507236adc952640c9bd0a134b9995ab92106a33dc02d9')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -96,9 +94,6 @@ prepare() {
# add upstream patch
patch -p1 -i "${srcdir}/patch-${pkgver}"
- # https://bugzilla.kernel.org/show_bug.cgi?id=189851
- patch -p1 -i "${srcdir}/net_handle_no_dst_on_skb_in_icmp6_send.patch"
-
# Revert a commit that causes memory corruption in i686 chroots on our
# build server ("valgrind bash" immediately crashes)
# https://bugzilla.kernel.org/show_bug.cgi?id=190061
@@ -218,8 +213,8 @@ build() {
}
_package() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the ck8 patchset featuring MuQSS CPU scheduler v0.144"
- #_Kpkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the ck8 patchset featuring MuQSS CPU scheduler v0.144"
+ pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the ck1 patchset featuring MuQSS CPU scheduler v0.150"
+ #_Kpkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the ck1 patchset featuring MuQSS CPU scheduler v0.150"
#pkgdesc="${_Kpkgdesc}"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country')