summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e597a6c00906..731bb23f392a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,14 +52,14 @@ _BFQ_enable_=
pkgname=(linux-ck linux-ck-headers)
_kernelname=-ck
_srcname=linux-4.3
-pkgver=4.3.2
+pkgver=4.3.3
pkgrel=1
arch=('i686' 'x86_64')
url="https://wiki.archlinux.org/index.php/Linux-ck"
license=('GPL2')
makedepends=('kmod' 'inetutils' 'bc')
options=('!strip')
-_ckpatchversion=2
+_ckpatchversion=3
_ckpatchname="patch-4.3-ck${_ckpatchversion}"
_gcc_patch="enable_additional_cpu_optimizations_for_gcc_v4.9+_kernel_v3.15+.patch"
_bfqpath="http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.3.0-v7r8"
@@ -70,7 +70,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'config.x86_64' 'config'
'linux-ck.preset'
'change-default-console-loglevel.patch'
-# ck2
+# ck3
"http://ck.kolivas.org/patches/4.0/4.3/4.3-ck${_ckpatchversion}/${_ckpatchname}.xz"
# gcc
"http://repo-ck.com/source/gcc_patch/${_gcc_patch}.gz"
@@ -80,13 +80,13 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"${_bfqpath}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-v7r8-for-4.3.0.patch")
sha256sums=('4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae'
'SKIP'
- 'a96b8a4e90887dea82066b4d804ac193700c200b6c0075fecba0b691b0240a5e'
+ '95cd81fcbb87953f672150d60950548edc04a88474c42de713b91811557fefa5'
'SKIP'
'cce1f9916ae58b61f22068a3afe2fd6fc82ffc97c76d56622ea17d8cc603dbb2'
'8e83d9306376750632e87bed77d4caf3475a4390a8f6673d58ee959b3722f12c'
'2b3ebf5446aa3cac279842ca00bc1f2d6b7ff1766915282c201d763dbf6ca07e'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- 'efd397f975cc79aabd2914ec331bdaeef9927b3c038a3f682c72b7a6e13feb64'
+ '483c12e130285cbcb49648012416323a5cb8dd8a477fa064d96c2f53019f1b31'
'cf0f984ebfbb8ca8ffee1a12fd791437064b9ebe0712d6f813fd5681d4840791'
'ebeb62206999b2749ac43bb287a6a2a5db4f6b1b688a90cefa1ceb5db94aa490'
'91b7cb42b8337b768e5329da205a6b61211628ec99b1e308e0e9d5283b2c86eb'
@@ -110,7 +110,7 @@ prepare() {
# patch source with ck patchset with BFS
# fix double name in EXTRAVERSION
sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "${srcdir}/${_ckpatchname}"
- msg "Patching source with ck2 including BFS v0.466"
+ msg "Patching source with ck3 including BFS v0.467"
patch -Np1 -i "${srcdir}/${_ckpatchname}"
# Patch source to enable more gcc CPU optimizatons via the make nconfig
@@ -234,8 +234,8 @@ build() {
}
package_linux-ck() {
- pkgdesc='Linux Kernel with the ck2 patchset featuring the Brain Fuck Scheduler v0.466.'
- #_Kpkgdesc='Linux Kernel and modules with the ck2 patchset featuring the Brain Fuck Scheduler v0.466.'
+ pkgdesc='Linux Kernel with the ck3 patchset featuring the Brain Fuck Scheduler v0.467.'
+ #_Kpkgdesc='Linux Kernel and modules with the ck3 patchset featuring the Brain Fuck Scheduler v0.467.'
#pkgdesc="${_Kpkgdesc}"
depends=('coreutils' 'linux-firmware' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country' 'nvidia-ck: nVidia drivers for linux-ck' 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')