summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD324
1 files changed, 324 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05fa03c5d8a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,324 @@
+# Maintainer: vinibali <vinibali1 AT gmail DOT com>
+# Contributor: graysky <graysky AT archlinux DOT us>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+
+### BUILD OPTIONS
+# Set these variables to ANYTHING that is not null to enable them
+
+# Tweak kernel options prior to a build via nconfig
+_makenconfig=
+
+# Optionally select a sub architecture by number if building in a clean chroot
+# Leaving this entry blank will require user interaction during the build
+# which will cause a failure to build if using makechrootpkg. Note that the
+# generic (default) option is 32.
+#
+# Note - the march=native option is unavailable by this method, use the nconfig
+# and manually select it.
+#
+# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
+# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3)
+# 3. AMD 61xx/7x50/PhenomX3/X4/II/K10 (MK10)
+# 4. AMD Barcelona (MBARCELONA)
+# 5. AMD Bobcat (MBOBCAT)
+# 6. AMD Jaguar (MJAGUAR)
+# 7. AMD Bulldozer (MBULLDOZER)
+# 8. AMD Piledriver (MPILEDRIVER)
+# 9. AMD Steamroller (MSTEAMROLLER)
+# 10. AMD Excavator (MEXCAVATOR)
+# 11. AMD Zen (MZEN)
+# 12. AMD Zen 2 (MZEN2)
+# 13. Intel P4 / older Netburst based Xeon (MPSC)
+# 14. Intel Atom (MATOM)
+# 15. Intel Core 2 (MCORE2)
+# 16. Intel Nehalem (MNEHALEM)
+# 17. Intel Westmere (MWESTMERE)
+# 18. Intel Silvermont (MSILVERMONT)
+# 19. Intel Goldmont (MGOLDMONT)
+# 20. Intel Goldmont Plus (MGOLDMONTPLUS)
+# 21. Intel Sandy Bridge (MSANDYBRIDGE)
+# 22. Intel Ivy Bridge (MIVYBRIDGE)
+# 23. Intel Haswell (MHASWELL)
+# 24. Intel Broadwell (MBROADWELL)
+# 25. Intel Skylake (MSKYLAKE)
+# 26. Intel Skylake X (MSKYLAKEX)
+# 27. Intel Cannon Lake (MCANNONLAKE)
+# 28. Intel Ice Lake (MICELAKE)
+# 29. Intel Cascade Lake (MCASCADELAKE)
+# 30. Intel Cooper Lake (MCOOPERLAKE)
+# 31. Intel Tiger Lake (MTIGERLAKE)
+# 32. Generic-x86-64 (GENERIC_CPU)
+# 33. Native optimizations autodetected by GCC (MNATIVE)
+
+_subarch=
+
+# Compile ONLY used modules to VASTLYreduce the number of modules built
+# and the build time.
+#
+# To keep track of which modules are needed for your specific system/hardware,
+# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
+# This PKGBUILD read the database kept if it exists
+#
+# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
+_localmodcfg=
+
+### IMPORTANT: Do no edit below this line unless you know what you're doing
+
+pkgbase=linux-ck-lts
+pkgver=5.10.75
+pkgrel=1
+_ckpatchversion=1
+arch=(x86_64)
+url="https://wiki.archlinux.org/index.php/Linux-ck"
+license=(GPL2)
+makedepends=(
+ bc kmod libelf cpio perl tar xz
+)
+options=('!strip')
+_ckpatch="patch-5.10-ck${_ckpatchversion}"
+_gcc_more_v='20201113'
+source=(
+ "https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sign}
+ config # the main kernel config file
+ "enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/$_gcc_more_v.tar.gz"
+ "http://ck.kolivas.org/patches/5.0/5.10/5.10-ck${_ckpatchversion}/$_ckpatch.xz"
+ 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
+ 0002-HID-quirks-Add-Apple-Magic-Trackpad-2-to-hid_have_sp.patch
+)
+validpgpkeys=(
+ 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
+ '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+)
+b2sums=('7f636f61ad70c6a23859b8ad97c29bb1526f2f69f2d05e9470dea1ae169b8e9bebb86b90e90d89b7897915ec5de871836e528cfeb7f4b46408200b7e6cb9f495'
+ 'SKIP'
+ '74b6ea3f314aa8291c9e2c3b5763f9b0c8aabbc0e714e30529f557955a7a315b44b0cd2f2d665ffe3ba48e7df71274c5901d3891ed395191ceb6ca88f69cdb1a'
+ '7f1eb5938472f57748216bd00e0c875feab99fc1c5cb89babfea467ee30ca5c8e9fc5a691efe2e602bef1ea79820c5383822d7cec354b48d23321ccda8ee8127'
+ '067f3389124fdd937ca69e9e9568b1b3194791960a093e81037051eb6d25e80b40bf7f60c61373ac9e92bff9db760766009b1e6f9ee8429a883bb7fce2d60f8a'
+ '99474f274431a7491ffc1a2b7fd20aad76699c0a9b442b8ce3459bade402ec002e4b67a40e1cc8b802752add70ee6ce77cc8055b8f4c2d81adfcd001d8a2eb13'
+ '3264190050a0cac1b63057c08dbcf07d351a370b08eccc70122e44a935e7e41f64fbb7444e986773266d69c3f6354d3c2e49282d6308dca4ec24a92dc93ff917')
+
+export KBUILD_BUILD_HOST=archlinux
+export KBUILD_BUILD_USER=$pkgbase
+export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
+
+prepare() {
+ cd linux-${pkgver}
+
+ echo "Setting version..."
+ scripts/setlocalversion --save-scmversion
+ echo "-$pkgrel" > localversion.10-pkgrel
+ echo "${pkgbase#linux}" > localversion.20-pkgname
+
+ local src
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = 0*.patch ]] || continue
+ echo "Applying patch $src..."
+ patch -Np1 < "../$src"
+ done
+
+ echo "Setting config..."
+ cp ../config .config
+
+ # disable CONFIG_DEBUG_INFO=y at build time otherwise memory usage blows up
+ # and can easily overwhelm a system with 32 GB of memory using a tmpfs build
+ # partition ... this was introduced by FS#66260, see:
+ # https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=663b08666b269eeeeaafbafaee07fd03389ac8d7
+ scripts/config --disable CONFIG_DEBUG_INFO
+ scripts/config --disable CONFIG_CGROUP_BPF
+ scripts/config --disable CONFIG_BPF_LSM
+ scripts/config --disable CONFIG_BPF_PRELOAD
+ scripts/config --disable CONFIG_BPF_LIRC_MODE2
+ scripts/config --disable CONFIG_BPF_KPROBE_OVERRIDE
+
+ # https://bbs.archlinux.org/viewtopic.php?pid=1824594#p1824594
+ scripts/config --enable CONFIG_PSI_DEFAULT_DISABLED
+
+ # https://bbs.archlinux.org/viewtopic.php?pid=1863567#p1863567
+ scripts/config --disable CONFIG_LATENCYTOP
+ scripts/config --disable CONFIG_SCHED_DEBUG
+
+ # FS#66613
+ # https://bugzilla.kernel.org/show_bug.cgi?id=207173#c6
+ scripts/config --disable CONFIG_KVM_WERROR
+
+ # fix naming schema in EXTRAVERSION of ck patch set
+ sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../${_ckpatch}"
+
+ # ck patchset itself
+ echo "Patching with ck patchset..."
+ patch -Np1 -i ../"${_ckpatch}"
+
+ # non-interactively apply ck1 default options
+ # this isn't redundant if we want a clean selection of subarch below
+ make olddefconfig
+
+ # https://github.com/graysky2/kernel_compiler_patch
+ # make sure to apply after olddefconfig to allow the next section
+ echo "Patching to enable GCC optimization for other uarchs..."
+ patch -Np1 -i "$srcdir/kernel_compiler_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v5.8+.patch"
+
+ if [ -n "$_subarch" ]; then
+ # user wants a subarch so apply choice defined above interactively via 'yes'
+ yes "$_subarch" | make oldconfig
+ else
+ # no subarch defined so allow user to pick one
+ make oldconfig
+ fi
+
+ ### Optionally load needed modules for the make localmodconfig
+ # See https://aur.archlinux.org/packages/modprobed-db
+ if [ -n "$_localmodcfg" ]; then
+ if [ -f $HOME/.config/modprobed.db ]; then
+ echo "Running Steven Rostedt's make localmodconfig now"
+ make LSMOD=$HOME/.config/modprobed.db localmodconfig
+ else
+ echo "No modprobed.db data found"
+ exit
+ fi
+ fi
+
+ make -s kernelrelease > version
+ echo "Prepared $pkgbase version $(<version)"
+
+ [[ -z "$_makenconfig" ]] || make nconfig
+
+ # save configuration for later reuse
+ cat .config > "${startdir}/config.last"
+
+ # uncomment if you want to build with distcc
+ ### sed -i '/HAVE_GCC_PLUGINS/d' arch/x86/Kconfig
+}
+
+build() {
+ cd linux-${pkgver}
+ make all
+}
+
+_package() {
+ pkgdesc="The long term support version ${pkgbase/linux/Linux} kernel and modules with the ck1 patchset featuring MuQSS CPU scheduler. Mostly just a fork of graysky's older Linux-CK package."
+ depends=(coreutils kmod initramfs)
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices')
+ provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+ #groups=('ck-generic')
+
+ cd linux-${pkgver}
+
+ local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+
+ echo "Installing boot image..."
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ #install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ #
+ # hard-coded path in case user defined CC=xxx for build which causes errors
+ # see this FS https://bugs.archlinux.org/task/64315
+ install -Dm644 arch/x86/boot/bzImage "$modulesdir/vmlinuz"
+
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
+ echo "Installing modules..."
+ #make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ # not needed since not building with CONFIG_DEBUG_INFO=y
+
+ make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+
+ # remove build and source links
+ rm "$modulesdir"/{source,build}
+}
+
+_package-headers() {
+ pkgdesc="Headers and scripts for building modules for ${pkgbase/linux/Linux} kernel"
+ depends=("$pkgbase") # added to keep kernel and headers packages matched
+ #groups=('ck-generic')
+
+ cd linux-${pkgver}
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
+
+ echo "Installing build files..."
+ install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
+ localversion.* version vmlinux
+ install -Dt "$builddir/kernel" -m644 kernel/Makefile
+ install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
+ cp -t "$builddir" -a scripts
+
+ # add objtool for external module building and enabled VALIDATION_STACK option
+ install -Dt "$builddir/tools/objtool" tools/objtool/objtool
+
+ # add xfs and shmem for aufs building
+ mkdir -p "$builddir"/{fs/xfs,mm}
+
+ echo "Installing headers..."
+ cp -t "$builddir" -a include
+ cp -t "$builddir/arch/x86" -a arch/x86/include
+ install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
+
+ install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
+ install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
+
+ # http://bugs.archlinux.org/task/13146
+ install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
+
+ # http://bugs.archlinux.org/task/20402
+ install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
+ install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
+ install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
+
+ echo "Installing KConfig files..."
+ find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
+
+ echo "Removing unneeded architectures..."
+ local arch
+ for arch in "$builddir"/arch/*/; do
+ [[ $arch = */x86/ ]] && continue
+ echo "Removing $(basename "$arch")"
+ rm -r "$arch"
+ done
+
+ echo "Removing documentation..."
+ rm -r "$builddir/Documentation"
+
+ echo "Removing broken symlinks..."
+ find -L "$builddir" -type l -printf 'Removing %P\n' -delete
+
+ echo "Removing loose objects..."
+ find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
+
+ echo "Stripping build tools..."
+ local file
+ while read -rd '' file; do
+ case "$(file -bi "$file")" in
+ application/x-sharedlib\;*) # Libraries (.so)
+ strip -v $STRIP_SHARED "$file" ;;
+ application/x-archive\;*) # Libraries (.a)
+ strip -v $STRIP_STATIC "$file" ;;
+ application/x-executable\;*) # Binaries
+ strip -v $STRIP_BINARIES "$file" ;;
+ application/x-pie-executable\;*) # Relocatable binaries
+ strip -v $STRIP_SHARED "$file" ;;
+ esac
+ done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+
+ #echo "Stripping vmlinux..."
+ #strip -v $STRIP_STATIC "$builddir/vmlinux"
+ # not needed since not building with CONFIG_DEBUG_INFO=y
+
+ echo "Adding symlink..."
+ mkdir -p "$pkgdir/usr/src"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
+
+}
+
+pkgname=("$pkgbase" "$pkgbase-headers")
+for _p in "${pkgname[@]}"; do
+ eval "package_$_p() {
+ $(declare -f "_package${_p#$pkgbase}")
+ _package${_p#$pkgbase}
+ }"
+done
+
+# vim:set ts=8 sts=2 sw=2 et: