summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17fc4ff9e588..ada6b42963f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -112,13 +112,6 @@ prepare() {
patch -Np1 -i "$srcdir/clearlinux/${i}"
done
- ### Patch source to unlock additional gcc CPU optimizations
- # https://github.com/graysky2/kernel_gcc_patch
- if [ "${_enable_gcc_more_v}" = "y" ]; then
- msg2 "Enabling additional gcc CPU optimizations..."
- patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch"
- fi
-
### Setting config
msg2 "Setting config..."
cp -Tf $srcdir/clearlinux/config ./.config
@@ -136,8 +129,6 @@ CONFIG_MODULE_COMPRESS_XZ=y|' ./.config
sed -i "s|# CONFIG_ACPI_REV_OVERRIDE_POSSIBLE is not set|CONFIG_ACPI_REV_OVERRIDE_POSSIBLE=y|g" ./.config
fi
- make olddefconfig
-
### Copying i915 firmware and intel-ucode
msg2 "Copying i915 firmware and intel-ucode..."
cp -a /usr/lib/firmware/i915 firmware/
@@ -145,9 +136,12 @@ CONFIG_MODULE_COMPRESS_XZ=y|' ./.config
cp ${srcdir}/intel-ucode-with-caveats/06* firmware/intel-ucode/
rm -f firmware/intel-ucode/0f*
- ### Prepared version
- make -s kernelrelease > ../version
- msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
+ ### Patch source to unlock additional gcc CPU optimizations
+ # https://github.com/graysky2/kernel_gcc_patch
+ if [ "${_enable_gcc_more_v}" = "y" ]; then
+ msg2 "Enabling additional gcc CPU optimizations..."
+ patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch"
+ fi
### Get kernel version
if [ "${_enable_gcc_more_v}" = "y" ] || [ -n "${_subarch}" ]; then
@@ -156,6 +150,10 @@ CONFIG_MODULE_COMPRESS_XZ=y|' ./.config
make prepare
fi
+ ### Prepared version
+ make -s kernelrelease > ../version
+ msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
+
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then