summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD306
1 files changed, 170 insertions, 136 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d05363d9c837..ac1466788089 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,24 @@
# Contributor:
### BUILD OPTIONS
-# Set these variables to ANYTHING that is not null to enable them
+# Set the next two variables to ANYTHING that is not null to enable them
# Tweak kernel options prior to a build via nconfig
-_makenconfig=
+: "${_makenconfig:=""}"
-_enable_gcc_more_v="y"
-# Optionally select a sub architecture by number if building in a clean chroot
-# Leaving this entry blank will require user interaction during the build
-# which will cause a failure to build if using makechrootpkg. Note that the
-# generic (default) option is 32.
+# Only compile active modules to VASTLY reduce the number of modules built and
+# the build time.
+#
+# To keep track of which modules are needed for your specific system/hardware,
+# give module_db a try: https://aur.archlinux.org/packages/modprobed-db
+# This PKGBUILD reads the database kept if it exists
+#
+# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
+: "${_localmodcfg:=""}"
+
+# Optionally select a sub architecture by number or leave blank which will
+# require user interaction during the build. Note that the generic (default)
+# option is 36.
#
# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3)
@@ -25,45 +33,50 @@ _enable_gcc_more_v="y"
# 10. AMD Excavator (MEXCAVATOR)
# 11. AMD Zen (MZEN)
# 12. AMD Zen 2 (MZEN2)
-# 13. Intel P4 / older Netburst based Xeon (MPSC)
-# 14. Intel Atom (MATOM)
+# 13. AMD Zen 3 (MZEN3)
+# 14. Intel P4 / older Netburst based Xeon (MPSC)
# 15. Intel Core 2 (MCORE2)
-# 16. Intel Nehalem (MNEHALEM)
-# 17. Intel Westmere (MWESTMERE)
-# 18. Intel Silvermont (MSILVERMONT)
-# 19. Intel Goldmont (MGOLDMONT)
-# 20. Intel Goldmont Plus (MGOLDMONTPLUS)
-# 21. Intel Sandy Bridge (MSANDYBRIDGE)
-# 22. Intel Ivy Bridge (MIVYBRIDGE)
-# 23. Intel Haswell (MHASWELL)
-# 24. Intel Broadwell (MBROADWELL)
-# 25. Intel Skylake (MSKYLAKE)
-# 26. Intel Skylake X (MSKYLAKEX)
-# 27. Intel Cannon Lake (MCANNONLAKE)
-# 28. Intel Ice Lake (MICELAKE)
-# 29. Intel Cascade Lake (MCASCADELAKE)
-# 30. Intel Cooper Lake (MCOOPERLAKE)
-# 31. Intel Tiger Lake (MTIGERLAKE)
-# 32. Generic-x86-64 (GENERIC_CPU)
-# 33. Native optimizations autodetected by GCC (MNATIVE)
-_subarch=
-
-# Compile ONLY used modules to VASTLY reduce the number of modules built
-# and the build time.
-#
-# To keep track of which modules are needed for your specific system/hardware,
-# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
-# This PKGBUILD read the database kept if it exists
-#
-# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
-_localmodcfg=
+# 16. Intel Atom (MATOM)
+# 17. Intel Nehalem (MNEHALEM)
+# 18. Intel Westmere (MWESTMERE)
+# 19. Intel Silvermont (MSILVERMONT)
+# 20. Intel Goldmont (MGOLDMONT)
+# 21. Intel Goldmont Plus (MGOLDMONTPLUS)
+# 22. Intel Sandy Bridge (MSANDYBRIDGE)
+# 23. Intel Ivy Bridge (MIVYBRIDGE)
+# 24. Intel Haswell (MHASWELL)
+# 25. Intel Broadwell (MBROADWELL)
+# 26. Intel Skylake (MSKYLAKE)
+# 27. Intel Skylake X (MSKYLAKEX)
+# 28. Intel Cannon Lake (MCANNONLAKE)
+# 29. Intel Ice Lake (MICELAKE)
+# 30. Intel Cascade Lake (MCASCADELAKE)
+# 31. Intel Cooper Lake (MCOOPERLAKE)
+# 32. Intel Tiger Lake (MTIGERLAKE)
+# 33. Intel Sapphire Rapids (MSAPPHIRERAPIDS)
+# 34. Intel Rocket Lake (MROCKETLAKE)
+# 35. Intel Alder Lake (MALDERLAKE)
+# 36. Generic-x86-64 (GENERIC_CPU)
+# 37. Generic-x86-64-v2 (GENERIC_CPU2)
+# 38. Generic-x86-64-v3 (GENERIC_CPU3)
+# 39. Generic-x86-64-v4 (GENERIC_CPU4)
+# 40. Intel-Native optimizations autodetected by GCC (MNATIVE_INTEL)
+# 41. AMD-Native optimizations autodetected by GCC (MNATIVE_AMD)
+: "${_subarch:=""}"
+
+# Use the current kernel's .config file
+# Enabling this option will use the .config of the RUNNING kernel rather than
+# the ARCH defaults. Useful when the package gets updated and you already went
+# through the trouble of customizing your config options. NOT recommended when
+# a new kernel is released, but again, convenient for package bumps.
+: "${_use_current:=""}"
### IMPORTANT: Do no edit below this line unless you know what you're doing
_major=4.19
-_minor=146
+_minor=295
_srcname=linux-${_major}
-_clr=${_major}.145-164
+_clr=${_major}.295-299
pkgbase=linux-clear-lts2018
pkgver=${_major}.${_minor}
pkgrel=1
@@ -71,14 +84,14 @@ pkgdesc='Clear Linux lts2018'
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux-lts2018"
license=('GPL2')
-makedepends=('bc' 'cpio' 'git' 'kmod' 'libelf' 'xmlto')
+makedepends=('bc' 'cpio' 'git' 'libelf' 'pahole' 'xmlto')
options=('!strip')
-_gcc_more_v='20200615'
+_gcc_more_v='20211114'
source=(
"https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-${_major}.tar".{xz,sign}
"https://cdn.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- "${pkgbase}::git+https://github.com/clearlinux-pkgs/linux-lts2018.git#tag=${_clr}"
- "enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz"
+ "$pkgbase::git+https://github.com/clearlinux-pkgs/linux-lts2018.git#tag=${_clr}"
+ "more-uarches-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/$_gcc_more_v.tar.gz"
)
export KBUILD_BUILD_HOST=archlinux
@@ -89,125 +102,138 @@ prepare() {
cd ${_srcname}
### Add upstream patches
- echo "Add upstream patches"
- patch -Np1 -i ../patch-${pkgver}
+ echo "Add upstream patches"
+ patch -Np1 -i ../patch-${pkgver}
### Setting version
- echo "Setting version..."
- scripts/setlocalversion --save-scmversion
- echo "-$pkgrel" > localversion.10-pkgrel
- echo "${pkgbase#linux}" > localversion.20-pkgname
+ echo "Setting version..."
+ scripts/setlocalversion --save-scmversion
+ echo "-$pkgrel" > localversion.10-pkgrel
+ echo "${pkgbase#linux}" > localversion.20-pkgname
### Add Clearlinux patches
- for i in $(grep '^Patch' ${srcdir}/${pkgbase}/linux-lts2018.spec | grep -Ev '^Patch0126' | sed -n 's/.*: //p'); do
+ for i in $(grep '^Patch' ${srcdir}/${pkgbase}/linux-lts2018.spec | grep -Ev '^Patch0126' | sed -n 's/.*: //p'); do
echo "Applying patch ${i}..."
patch -Np1 -i "$srcdir/${pkgbase}/${i}"
- done
+ done
### Setting config
- echo "Setting config..."
- cp -Tf $srcdir/${pkgbase}/config ./.config
+ echo "Setting config..."
+ cp -Tf $srcdir/${pkgbase}/config ./.config
### Enable extra stuff from arch kernel
- echo "Enable extra stuff from arch kernel..."
-
- # General setup
- scripts/config --enable IKCONFIG \
- --enable-after IKCONFIG IKCONFIG_PROC \
- --undefine RT_GROUP_SCHED
-
- # Power management and ACPI options
- scripts/config --enable ACPI_REV_OVERRIDE_POSSIBLE \
- --enable ACPI_TABLE_UPGRADE
-
- # Enable loadable module support
- scripts/config --undefine MODULE_SIG_FORCE \
- --enable MODULE_COMPRESS \
- --enable-after MODULE_COMPRESS MODULE_COMPRESS_XZ
-
- # Networking support
- scripts/config --enable NETFILTER_INGRESS \
- --module NET_SCH_CAKE
-
- # Device Drivers
- scripts/config --enable FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER \
- --enable DELL_SMBIOS_SMM \
- --module PATA_JMICRON \
- --enable-after SOUND SOUND_OSS_CORE \
- --enable SND_OSSEMUL \
- --module-after SND_OSSEMUL SND_MIXER_OSS \
- --module-after SND_MIXER_OSS SND_PCM_OSS \
- --enable-after SND_PCM_OSS SND_PCM_OSS_PLUGINS
-
- # Kernel hacking -> Compile-time checks and compiler options -> Make section mismatch errors non-fatal
- scripts/config --enable SECTION_MISMATCH_WARN_ONLY
-
- # Security options
- scripts/config --enable SECURITY_SELINUX \
- --enable-after SECURITY_SELINUX SECURITY_SELINUX_BOOTPARAM \
- --set-val SECURITY_SELINUX_BOOTPARAM_VALUE 0 \
- --enable SECURITY_SMACK \
- --enable-after SECURITY_SMACK SECURITY_SMACK_BRINGUP \
- --enable-after SECURITY_SMACK_BRINGUP SECURITY_SMACK_NETFILTER \
- --enable-after SECURITY_SMACK_NETFILTER SECURITY_SMACK_APPEND_SIGNALS \
- --enable SECURITY_TOMOYO \
- --enable SECURITY_APPARMOR \
- --set-val SECURITY_APPARMOR_BOOTPARAM_VALUE 0 \
- --enable SECURITY_YAMA
-
- make olddefconfig
-
- ### Patch source to unlock additional gcc CPU optimizations
- # https://github.com/graysky2/kernel_gcc_patch
- if [ "${_enable_gcc_more_v}" = "y" ]; then
- echo "Applying enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v4.19-v5.4.patch ..."
- patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v4.19-v5.4.patch"
- fi
-
- ### Get kernel version
- if [ "${_enable_gcc_more_v}" = "y" ] || [ -n "${_subarch}" ]; then
+ echo "Enable extra stuff from arch kernel..."
+
+ # General setup
+ scripts/config --set-str DEFAULT_HOSTNAME archlinux \
+ --enable IKCONFIG \
+ --enable IKCONFIG_PROC \
+ --undefine RT_GROUP_SCHED
+
+ # Power management and ACPI options
+ scripts/config --enable ACPI_REV_OVERRIDE_POSSIBLE \
+ --enable ACPI_TABLE_UPGRADE
+
+ # General architecture-dependent options
+ scripts/config --enable KPROBES
+
+ # Enable loadable module support
+ scripts/config --undefine MODULE_SIG_FORCE \
+ --enable MODULE_COMPRESS \
+ --enable MODULE_COMPRESS_XZ
+
+ # Networking support
+ scripts/config --enable NETFILTER_INGRESS \
+ --module NET_SCH_CAKE
+
+ # Device Drivers
+ scripts/config --enable FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER \
+ --enable DELL_SMBIOS_SMM \
+ --enable NET_VENDOR_AQUANTIA \
+ --module PATA_JMICRON \
+ --enable-after SOUND SOUND_OSS_CORE \
+ --enable SND_OSSEMUL \
+ --module-after SND_OSSEMUL SND_MIXER_OSS \
+ --module-after SND_MIXER_OSS SND_PCM_OSS \
+ --enable-after SND_PCM_OSS SND_PCM_OSS_PLUGINS
+
+ # Kernel hacking -> Compile-time checks and compiler options -> Make section mismatch errors non-fatal
+ scripts/config --enable SECTION_MISMATCH_WARN_ONLY
+
+ # Security options
+ scripts/config --enable SECURITY_SELINUX \
+ --enable SECURITY_SELINUX_BOOTPARAM \
+ --set-val SECURITY_SELINUX_BOOTPARAM_VALUE 0 \
+ --enable SECURITY_SMACK \
+ --enable SECURITY_SMACK_BRINGUP \
+ --enable SECURITY_SMACK_NETFILTER \
+ --enable SECURITY_SMACK_APPEND_SIGNALS \
+ --enable SECURITY_TOMOYO \
+ --enable SECURITY_APPARMOR \
+ --set-val SECURITY_APPARMOR_BOOTPARAM_VALUE 0 \
+ --enable SECURITY_YAMA
+
+ make olddefconfig
+ diff -u $srcdir/$pkgbase/config .config || :
+
+ # https://github.com/graysky2/kernel_compiler_patch
+ # make sure to apply after olddefconfig to allow the next section
+ echo "Patching to enable GCC optimization for other uarchs..."
+ patch -Np1 -i "$srcdir/kernel_compiler_patch-$_gcc_more_v/more-uarches-for-kernel-4.19-5.4.patch"
+
+ if [ -n "$_subarch" ]; then
+ # user wants a subarch so apply choice defined above interactively via 'yes'
yes "$_subarch" | make oldconfig
+ else
+ # no subarch defined so allow user to pick one
+ make oldconfig
+ fi
+
+ ### Optionally use running kernel's config
+ # code originally by nous; http://aur.archlinux.org/packages.php?ID=40191
+ if [ -n "$_use_current" ]; then
+ if [[ -s /proc/config.gz ]]; then
+ echo "Extracting config from /proc/config.gz..."
+ # modprobe configs
+ zcat /proc/config.gz > ./.config
else
- make prepare
+ warning "Your kernel was not compiled with IKCONFIG_PROC!"
+ warning "You cannot read the current config!"
+ warning "Aborting!"
+ exit
fi
-
- ### Prepared version
- make -s kernelrelease > version
- echo "Prepared $pkgbase version $(<version)"
+ fi
### Optionally load needed modules for the make localmodconfig
- # See https://aur.archlinux.org/packages/modprobed-db
- if [ -n "$_localmodcfg" ]; then
- if [ -f $HOME/.config/modprobed.db ]; then
+ # See https://aur.archlinux.org/packages/modprobed-db
+ if [ -n "$_localmodcfg" ]; then
+ if [ -e $HOME/.config/modprobed.db ]; then
echo "Running Steven Rostedt's make localmodconfig now"
make LSMOD=$HOME/.config/modprobed.db localmodconfig
- else
+ else
echo "No modprobed.db data found"
exit
- fi
fi
+ fi
- ### do not run `make olddefconfig` as it sets default options
- yes "" | make config >/dev/null
+ make -s kernelrelease > version
+ echo "Prepared $pkgbase version $(<version)"
- ### Running make nconfig
-
- [[ -z "$_makenconfig" ]] || make nconfig
+ [[ -z "$_makenconfig" ]] || make nconfig
### Save configuration for later reuse
-
- cp -Tf ./.config "${startdir}/config-${pkgver}-${pkgrel}${pkgbase#linux}"
+ cp -Tf ./.config "${startdir}/config-${pkgver}-${pkgrel}${pkgbase#linux}"
}
build() {
cd ${_srcname}
- make -j$(nproc) bzImage modules
+ make all
}
_package() {
pkgdesc="The $pkgdesc kernel and modules"
depends=('coreutils' 'kmod' 'initramfs')
- optdepends=('crda: to set the correct wireless channels of your country'
+ optdepends=('wireless-regdb: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices'
'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
@@ -227,7 +253,8 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ make ${BUILD_FLAGS[*]} INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -235,6 +262,7 @@ _package() {
_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+ depends=(pahole)
cd ${_srcname}
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
@@ -263,14 +291,17 @@ _package-headers() {
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/13146
+ # https://bugs.archlinux.org/task/13146
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
- # http://bugs.archlinux.org/task/20402
+ # https://bugs.archlinux.org/task/20402
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
+ # https://bugs.archlinux.org/task/71392
+ install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
+
echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
@@ -294,7 +325,7 @@ _package-headers() {
echo "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
@@ -306,6 +337,9 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+ echo "Stripping vmlinux..."
+ strip -v $STRIP_STATIC "$builddir/vmlinux"
+
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
@@ -321,9 +355,9 @@ done
sha256sums=('0c68f5655528aed4f99dae71a5b259edc93239fa899e2df79c055275c21749a1'
'SKIP'
- '65dcb7ed7241ec26e50b5b657a597c8a2f4a576ada514963720ac16a99bb7a84'
+ 'b78bba5af52addfd362dc8fc1f881fc8b653ed2412c8df58bf0fe63d14b46e94'
'SKIP'
- '278fe9ffb29d92cc5220e7beac34a8e3a2006e714d16a21a0427069f9634af90')
+ 'fffcd3b2c139e6a0b80c976a4ce407d450cf8f454e697d5ed39d85e8232ddeba')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds