summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 24 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cdcf438dbd3..1afc2d7d52fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ _enable_gcc_more_v="y"
# Optionally select a sub architecture by number if building in a clean chroot
# Leaving this entry blank will require user interaction during the build
# which will cause a failure to build if using makechrootpkg. Note that the
-# generic (default) option is 26.
+# generic (default) option is 27.
#
# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3)
@@ -24,22 +24,23 @@ _enable_gcc_more_v="y"
# 9. AMD Steamroller (MSTEAMROLLER)
# 10. AMD Excavator (MEXCAVATOR)
# 11. AMD Zen (MZEN)
-# 12. Intel P4 / older Netburst based Xeon (MPSC)
-# 13. Intel Atom (MATOM)
-# 14. Intel Core 2 (MCORE2)
-# 15. Intel Nehalem (MNEHALEM)
-# 16. Intel Westmere (MWESTMERE)
-# 17. Intel Silvermont (MSILVERMONT)
-# 18. Intel Sandy Bridge (MSANDYBRIDGE)
-# 19. Intel Ivy Bridge (MIVYBRIDGE)
-# 20. Intel Haswell (MHASWELL)
-# 21. Intel Broadwell (MBROADWELL)
-# 22. Intel Skylake (MSKYLAKE)
-# 23. Intel Skylake X (MSKYLAKEX)
-# 24. Intel Cannon Lake (MCANNONLAKE)
-# 25. Intel Ice Lake (MICELAKE)
-# 26. Generic-x86-64 (GENERIC_CPU)
-# 27. Native optimizations autodetected by GCC (MNATIVE)
+# 12. AMD Zen 2 (MZEN2)
+# 13. Intel P4 / older Netburst based Xeon (MPSC)
+# 14. Intel Atom (MATOM)
+# 15. Intel Core 2 (MCORE2)
+# 16. Intel Nehalem (MNEHALEM)
+# 17. Intel Westmere (MWESTMERE)
+# 18. Intel Silvermont (MSILVERMONT)
+# 19. Intel Sandy Bridge (MSANDYBRIDGE)
+# 20. Intel Ivy Bridge (MIVYBRIDGE)
+# 21. Intel Haswell (MHASWELL)
+# 22. Intel Broadwell (MBROADWELL)
+# 23. Intel Skylake (MSKYLAKE)
+# 24. Intel Skylake X (MSKYLAKEX)
+# 25. Intel Cannon Lake (MCANNONLAKE)
+# 26. Intel Ice Lake (MICELAKE)
+# 27. Generic-x86-64 (GENERIC_CPU)
+# 28. Native optimizations autodetected by GCC (MNATIVE)
_subarch=
# Compile ONLY probed modules
@@ -58,7 +59,7 @@ _localmodcfg=
### IMPORTANT: Do no edit below this line unless you know what you're doing
_major=4.19
-_minor=61
+_minor=62
_srcname=linux-${_major}
_clr=${_major}.57-60
pkgbase=linux-clear-lts2018
@@ -70,7 +71,7 @@ license=('GPL2')
makedepends=('bc' 'git' 'inetutils' 'kmod' 'libelf' 'linux-firmware' 'xmlto')
options=('!strip')
_ucode='20190618'
-_gcc_more_v='20180509'
+_gcc_more_v='20190714'
source=(
"https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-${_major}.tar".{xz,sign}
"https://cdn.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
@@ -133,8 +134,8 @@ CONFIG_MODULE_COMPRESS_XZ=y|' ./.config
### Patch source to unlock additional gcc CPU optimizations
# https://github.com/graysky2/kernel_gcc_patch
if [ "${_enable_gcc_more_v}" = "y" ]; then
- msg2 "Enabling additional gcc CPU optimizations..."
- patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch"
+ msg2 "Applying enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch ..."
+ patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch"
fi
### Get kernel version
@@ -329,10 +330,10 @@ done
sha256sums=('0c68f5655528aed4f99dae71a5b259edc93239fa899e2df79c055275c21749a1'
'SKIP'
- '68ffa9f14b80f19429b85deaf7e0cf66f4304d85fdfeb23d56e9233211d88826'
+ 'eda440f44b9889d13eb65f4515776401e903e1047fac33e912710b2451818550'
'SKIP'
'74ec7415988d40fa53686d994cf8cb27accdbd35c5373c4c3afc2e93372ebba5'
- '226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
+ '2466fb4aecc66d1b258b4cbdb2f215b5099f266d8c4386bb62ad1a0acd0caf5b'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
'ed9d35cb7d7bd829ff6253353efa5e2d119820fe4f4310aea536671f5e4caa37'