summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 20 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b8a4bb96083..919eaa87ca71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,7 +64,7 @@ _srcname=linux-${_major}
_clr=${_major}.79-86
pkgbase=linux-clear-lts2018
pkgver=${_major}.${_minor}
-pkgrel=3
+pkgrel=4
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux-lts2018"
license=('GPL2')
@@ -108,34 +108,34 @@ prepare() {
### Enable extra stuff from arch kernel
msg2 "Enable extra stuff from arch kernel..."
+ # General setup
+ scripts/config --module IKCONFIG \
+ --enable-after IKCONFIG IKCONFIG_PROC \
+ --undefine RT_GROUP_SCHED
+
+ # Power management and ACPI options
+ scripts/config --enable ACPI_REV_OVERRIDE_POSSIBLE \
+ --enable HIBERNATION
+
+ # Enable loadable module support
scripts/config --undefine MODULE_SIG_FORCE \
--enable MODULE_COMPRESS \
- --enable-after MODULE_COMPRESS MODULE_COMPRESS_XZ \
+ --enable-after MODULE_COMPRESS MODULE_COMPRESS_XZ
+
+ # Networking support
+ scripts/config --enable NETFILTER_INGRESS \
+ --module NET_SCH_CAKE
+
+ # Device Drivers
+ scripts/config --enable FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER \
--enable DELL_SMBIOS_SMM \
- --module IKCONFIG \
- --enable-after IKCONFIG IKCONFIG_PROC \
+ --module PATA_JMICRON \
--enable-after SOUND SOUND_OSS_CORE \
--enable SND_OSSEMUL \
--module-after SND_OSSEMUL SND_MIXER_OSS \
--module-after SND_MIXER_OSS SND_PCM_OSS \
--enable-after SND_PCM_OSS SND_PCM_OSS_PLUGINS
- # Scheduler features
- scripts/config --undefine RT_GROUP_SCHED
-
- # Queueing/Scheduling
- scripts/config --module NET_SCH_CAKE
-
- # PATA SFF controllers with BMDMA
- scripts/config --module PATA_JMICRON
-
- # Power management and ACPI options
- scripts/config --enable ACPI_REV_OVERRIDE_POSSIBLE \
- --enable HIBERNATION
-
- # Console display driver support
- scripts/config --enable FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER
-
# Security options
scripts/config --enable SECURITY_SELINUX \
--enable-after SECURITY_SELINUX SECURITY_SELINUX_BOOTPARAM \