summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da8787029294..07d5b70b8cef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Yurii Kolesykov <root@yurikoles.com>
-# based on testing/linux: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# based on testing/linux: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-drm-next-git
-pkgver=5.18.2022.02.18.r1.g0a131b69c141
+pkgver=6.0.r1123340.bafaf67c42f4
pkgrel=1
pkgdesc='Linux kernel with bleeding-edge GPU drivers'
_product="${pkgbase%-git}"
@@ -11,8 +11,8 @@ arch=(x86_64)
url='https://cgit.freedesktop.org/drm/drm'
license=(GPL2)
makedepends=(
- bc kmod libelf pahole cpio perl tar xz
- xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
+ bc libelf pahole cpio perl tar xz
+ xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick texlive-latexextra
git
)
options=('!strip')
@@ -22,12 +22,14 @@ source=(
config # the main kernel config file
)
sha256sums=('SKIP'
- 'a7e88715c86f2ea77e80cb0535d827406676cb8227a9367dd98931f511b06f31')
+ '85f7327e262056043514a24eb6c8d46e3ac6a10a6caff09d664dec8827829144')
pkgver() {
cd $_srcname
+ local version="$(grep \^VERSION Makefile|cut -d"=" -f2|cut -d" " -f2)"
+ local patch="$(grep \^PATCHLEVEL Makefile|cut -d"=" -f2|cut -d" " -f2)"
- git describe --long --tags | sed 's/^amd.drm.next.//;s/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "%s.%s.r%s.%s" "${version}" "${patch}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
export KBUILD_BUILD_HOST=archlinux
@@ -62,16 +64,15 @@ prepare() {
build() {
cd $_srcname
- make all
- make htmldocs
+ make htmldocs all
}
_package() {
pkgdesc="The $pkgdesc kernel and modules"
depends=(coreutils kmod initramfs)
- optdepends=('crda: to set the correct wireless channels of your country'
+ optdepends=('wireless-regdb: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
- provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+ provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE KSMBD-MODULE)
replaces=(virtualbox-guest-modules-arch wireguard-arch)
cd $_srcname
@@ -87,7 +88,8 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
rm "$modulesdir"/{source,build}