summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD45
1 files changed, 33 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c46149f166e..d177eee223c9 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
pkgbase=linux-fbcondecor # Build stock -ARCH kernel
#pkgbase=linux-custom # Build kernel with a different name
-_srcname=linux-4.0
-pkgver=4.0.1
-pkgrel=1
+_srcname=linux-4.1
+pkgver=4.1.2
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -17,21 +17,28 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
- "fbcondecor-4.0.patch"
+ "fbcondecor-4.1.patch"
# the main kernel config files
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
'linux-fbcondecor.preset'
- 'change-default-console-loglevel.patch'
- )
-sha256sums=('0f2f7d44979bc8f71c4fc5d3308c03499c26a824dd311fdf6eef4dee0d7d5991'
+ '0001-block-loop-convert-to-per-device-workqueue.patch'
+ '0002-block-loop-avoiding-too-many-pending-per-work-I-O.patch'
+ '0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch'
+ 'bitmap-enable-booting-for-dm-md-raid1.patch'
+ 'change-default-console-loglevel.patch')
+sha256sums=('caf51f085aac1e1cea4d00dbbf3093ead07b551fc07b31b2a989c05f8ea72d9f'
'SKIP'
- '9b4b47eb6584dc39aaa5db46843b83f7c60975abecbda4dc106a8722eabe96fb'
+ '1a8863e4cd7ef3d59b67061aaf5e3f98ad4c63dda015b9b483d458f2b673caef'
'SKIP'
'b8c95822b17a90b65431c518f349bdb7a448688da2774b5b652ef085824d7b42'
- '29557f1c147be731027040243f2566a75933c3b2af44f1448acf80352daafe30'
- '076ab498c60ce0aa6f8aba0841ce3b2b3999cafa8a0f03c70e741715570cc588'
+ '94d0987bca23a4c0a4d4e81df1badf655136f70b7541f1d47fe429159e737c96'
+ 'f0eae16576ddc5309ebf557e9f6026a5afbcdafba9517bb0a574fbb3d21a95d7'
'521b572c7fcd08112eb9b15d302fa30ac9bc72c590164742da3c405ba54e00ef'
+ '9e1d3fd95d768a46353593f6678513839cedb98ee66e83d9323233104ec3b23f'
+ 'bbe3631c737ed8329a1b7a9610cc0a07330c14194da5e9afec7705e7f37eeb81'
+ '08f69d122021e1d13c31e5987c23021916a819846c47247b3f1cee2ef99d7f82'
+ '959c4d71b5dc50434eeecf3a8608758f57f111c6e999289c435b13fc8c6be5f0'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -47,11 +54,25 @@ prepare() {
patch -p1 -i "${srcdir}/patch-${pkgver}"
# Add support for Framebuffer Decorations
- patch -p1 -i "${srcdir}/fbcondecor-4.0.patch"
+ patch -p1 -i "${srcdir}/fbcondecor-4.1.patch"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
-
+
+ # Fix deadlock with stacked loop devices (FS#45129)
+ # http://marc.info/?l=linux-kernel&m=143280649731902&w=2
+ patch -Np1 -i ../0001-block-loop-convert-to-per-device-workqueue.patch
+ patch -Np1 -i ../0002-block-loop-avoiding-too-many-pending-per-work-I-O.patch
+
+ # Fix bluetooth chip initialization on some macbooks (FS#45554)
+ # http://marc.info/?l=linux-bluetooth&m=143690738728402&w=2
+ # https://bugzilla.kernel.org/show_bug.cgi?id=100651
+ patch -Np1 -i ../0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch
+
+ # Fix kernel oops when booting with root on RAID1 LVM (FS#45548)
+ # https://bugzilla.kernel.org/show_bug.cgi?id=100491#c24
+ patch -Np1 -i ../bitmap-enable-booting-for-dm-md-raid1.patch
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)