summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 284aa5e274d7..813e9edf7e7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ _localmodcfg=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-gc
-pkgver=5.7.6
+pkgver=5.7.7
pkgrel=1
pkgdesc='Linux'
url="https://cchalpha.blogspot.co.uk/"
@@ -33,8 +33,8 @@ makedepends=(
)
options=('!strip')
_srcname=linux-${pkgver}
-_bmqversion=5.7-r1
-_bmq_patch="bmq_v${_bmqversion}.patch"
+_bmqversion=5.7-r2
+_bmq_patch="prjc_v${_bmqversion}.patch"
_gcc_more_v='20200615'
source=(
"https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sign}
@@ -42,22 +42,28 @@ source=(
"0000-sphinx-workaround.patch"
"${_bmq_patch}::https://gitlab.com/alfredchen/projectc/raw/master/${_bmqversion%-*}/${_bmq_patch}"
"enable_additional_cpu_optimizations-${_gcc_more_v}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gcc_more_v}.tar.gz"
- "0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch::https://git.archlinux.org/linux.git/patch/?id=77c07a8d6f12681914e8b6f0c709d45d8c2114b1"
- "0002-efi-libstub-Fix-path-separator-regression.patch::https://git.archlinux.org/linux.git/patch/?id=2eff8033714ddf05bb2fe52003921af8c8839ed2"
+ "0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch::https://git.archlinux.org/linux.git/patch/?id=a62bbaf1ba0f5e2c498fa9b3ae295aa166d4bb8e"
+ "0002-PCI-EDR-Log-only-ACPI_NOTIFY_DISCONNECT_RECOVER-even.patch::https://git.archlinux.org/linux.git/patch/?id=6535fe9061b6f1ce76ac658ae34b85fb3ed38ad9"
+ "0003-ALSA-usb-audio-Fix-packet-size-calculation.patch::https://git.archlinux.org/linux.git/patch/?id=17c5f7dd425becd30c4a2dafaecb054641a1fdc9"
+ "0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch::https://git.archlinux.org/linux.git/patch/?id=7fab9d4206e54d19b578c70cd0529045ad642f25"
+ "Fix-compilation-issues-when-CONFIG-SCHED-TRACER.patch::https://gitlab.com/alfredchen/linux-prjc/-/commit/12f9ffec7586ba30fcabd0ce9f13158f0158a529.patch"
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
'A2FF3A36AAA56654109064AB19802F8B0D70FC30' # Jan Alexander Steffens (heftig)
)
-sha256sums=('9fd4c93dc6df53efa904134aa2ede6100f7453c11383490dd32ebbed84f610e6'
+sha256sums=('f840b9679283343c165516585c3070ebb277528721c890e9410a58e9d071ee7f'
'SKIP'
'07bdb86bb34876ba99406b2174dac860b962a721dc9858d08e15e2608eeb96a7'
'19c19fef1fd46d1b184d888226d286be9b00e8feb8fb745f8d408cfce3d9622a'
- '9cf60ec74848ef807fc97e1c0f4bccca73ec65763a2adefa6758a4f7c0f243a7'
+ 'b19d09da5beef3433702157ac7975710fc815ada9ed2a088136bb87e0c89dfd7'
'278fe9ffb29d92cc5220e7beac34a8e3a2006e714d16a21a0427069f9634af90'
- 'afe1e5bd572688e75fc13faf548728579a0d4e74711ad7d01e5703e59a519a11'
- '6576ee1bf82c8d78b9e60b48fadc6b875cf9473917e57282db2fa6c6047548e9')
+ 'fa88f10dbab186cdba7ec64ffd4c07b86b2bd5fb7ff6be1d36c8a062aeb77a34'
+ '69dfd528a2ad7a57a5036c9250a2f99dc815eef011cdc17c323c49affdb051de'
+ '863f4d199f333fbbba9d42c287b566050d3716bfbd5aed9acf1f3745f8df3a2f'
+ '495d52edab5e226d24aeb3467f5f31366cf268b0cdfa6ea714e162e01067a0eb'
+ 'dd5d00c6e6c47e5869e994f656685db31f50b77dc26393505e941fe5be7faa33')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-gc}
@@ -92,6 +98,7 @@ prepare() {
echo "Applying patch ${_bmq_patch}..."
patch -Np1 -i "$srcdir/${_bmq_patch}"
+ patch -Np1 -i "$srcdir/Fix-compilation-issues-when-CONFIG-SCHED-TRACER.patch"
# non-interactively apply ck1 default options
# this isn't redundant if we want a clean selection of subarch below