summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD501
1 files changed, 158 insertions, 343 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33e8d18ae362..31afb83549f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
# Contributor: Jonas Heinrich <onny@project-insanity.org>
# Contributor: André Silva <emulatorman@riseup.net>
# Contributor: Márcio Silva <coadde@riseup.net>
@@ -8,332 +8,194 @@
# Contributor (Parabola): Luke Shumaker <lukeshu@sbcglobal.net>
# Contributor (Parabola): Luke R. <g4jc@openmailbox.org>
-# Based on linux package
-
-pkgbase=linux-libre # Build stock kernel
-#pkgbase=linux-libre-custom # Build kernel with a different name
-_srcbasever=5.2-gnu
-_srcver=5.2.5-gnu
-
-_replacesarchkernel=('linux%') # '%' gets replaced with _kernelname
-_replacesoldkernels=() # '%' gets replaced with _kernelname
-_replacesoldmodules=() # '%' gets replaced with _kernelname
-
-_srcname=linux-${_srcbasever%-*}
-_archpkgver=${_srcver%-*}
-pkgver=${_srcver//-/_}
+pkgbase=linux-libre
+pkgver=6.8.7
pkgrel=1
-rcnrel=armv7-x3
-arch=(i686 x86_64 armv7h)
+pkgdesc='Linux Libre'
url='https://linux-libre.fsfla.org/'
-license=(GPL2)
+arch=(x86_64)
+license=(GPL-2.0-only)
makedepends=(
- xmlto kmod inetutils bc libelf python-sphinx python-sphinx_rtd_theme
- graphviz imagemagick
-)
-makedepends_armv7h=(uboot-tools vboot-utils dtc) # for linux-libre-chromebook
-options=('!strip')
-source=(
- "https://linux-libre.fsfla.org/pub/linux-libre/releases/$_srcbasever/linux-libre-$_srcbasever.tar.xz"{,.sign}
- "https://linux-libre.fsfla.org/pub/linux-libre/releases/$_srcver/patch-$_srcbasever-$_srcver.xz"{,.sign}
- "https://repo.parabola.nu/other/linux-libre/logos/logo_linux_"{clut224.ppm,vga16.ppm,mono.pbm}{,.sig}
- config.i686 config.x86_64 config.armv7h # the main kernel config files
- 60-linux.hook # pacman hook for depmod
- 90-linux.hook # pacman hook for initramfs regeneration
- linux.preset # standard config files for mkinitcpio ramdisk
- "kernel"{.its,.keyblock,_data_key.vbprivk} # files for signing Chromebooks kernels
-
- # maintain the TTY over USB disconnects
- # http://www.coreboot.org/EHCI_Gadget_Debug
- 0001-usb-serial-gadget-no-TTY-hangup-on-USB-disconnect-WI.patch
- # fix Atmel maXTouch touchscreen support
- # https://labs.parabola.nu/issues/877
- # http://www.fsfla.org/pipermail/linux-libre/2015-November/003202.html
- 0002-fix-Atmel-maXTouch-touchscreen-support.patch
-
- # Arch's custom linux patches
- 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- 0002-ZEN-Add-CONFIG-for-unprivileged_userns_clone.patch
- 0003-iwlwifi-mvm-disable-TX-AMSDU-on-older-NICs.patch
- 0004-iwlwifi-Add-support-for-SAR-South-Korea-limitation.patch
- 0005-netfilter-nf_tables-fix-module-autoload-for-redir.patch
-)
-source_armv7h=(
- # armv7h patches, put in the source_armv7h variable just for a more comfortable loop patching
-
- # RCN patch (CM3 firmware deblobbed and AUFS/WireGuard removed)
- # Note: For stability reasons, AUFS has been removed in the RCN patch.
- # We are supporting AUFS in linux-libre-pck through PCK patch.
- # See https://wiki.parabola.nu/PCK for further details.
- "https://repo.parabola.nu/other/rcn-libre/patches/${_srcver%-*}/rcn-libre-${_srcver%-*}-$rcnrel.patch"{,.sig}
-
- # Arch Linux ARM patches
- 0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch
- 0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch
- 0003-SMILE-Plug-device-tree-file.patch
- 0004-fix-mvsdio-eMMC-timing.patch
- 0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
- 0006-set-default-cubietruck-led-triggers.patch
- 0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
- 0008-ARM-dove-enable-ethernet-on-D3Plug.patch
-)
-validpgpkeys=(
- '474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
- '6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
+ bc
+ cpio
+ gettext
+ libelf
+ pahole
+ perl
+ python
+ tar
+ xz
+
+ # htmldocs
+ graphviz
+ imagemagick
+ python-sphinx
+ python-yaml
+ texlive-latexextra
)
-sha512sums=('3359b0a10ac04243399a1b0aa84f6c09e3c1914880be19a7e931189da92900ca77e467e7ab5c296a03d2ff0ab3238ec75b13fd41bd2796049b63e71f6896900e'
+options=('!debug' '!strip')
+_srcname=linux-${pkgver%.*}
+source=("https://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver%.*}-gnu/linux-libre-${pkgver%.*}-gnu.tar.lz"{,.sign}
+ "http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${pkgver%.*}-gnu-${pkgver}-gnu.bz2"{,.sign}
+ 'https://repo.parabola.nu/other/linux-libre/logos/logo_linux_'{clut224.ppm,vga16.ppm,mono.pbm}{,.sig}
+ 'config')
+sha256sums=('f6c64e8ea831ffb71dedd1311e168fc7b142b025ec5fafa22ff6aedd9925bbe7'
'SKIP'
- '9b35cbb7b1b7ef851a0fb9531ade4360487a75723d8bd9ebfd064b54d3b9697741d60b4b38dca15317e1b1f11d403c830d8f85b663bae56615f1b361eedeae35'
+ '4cd27c89ef52256bd6efb03b4fbeaf5d0d9dc60f0ae8d7d36893a45701963036'
'SKIP'
- '13cb5bc42542e7b8bb104d5f68253f6609e463b6799800418af33eb0272cc269aaa36163c3e6f0aacbdaaa1d05e2827a4a7c4a08a029238439ed08b89c564bb3'
+ 'bfd4a7f61febe63c880534dcb7c31c5b932dde6acf991810b41a939a93535494'
'SKIP'
- '7a3716bfe3b9f546da309c7492f3e08f8f506813afeb1c737a474c83313d5c313cf4582b65215c2cfce3b74d9d1021c96e8badafe8f6e5b01fe28d2b5c61ae78'
+ '6de8a8319271809ffdb072b68d53d155eef12438e6d04ff06a5a4db82c34fa8a'
'SKIP'
- '267295aa0cea65684968420c68b32f1a66a22d018b9d2b2c1ef14267bcf4cb68aaf7099d073cbfefe6c25c8608bdcbbd45f7ac8893fdcecbf1e621abdfe9ecc1'
+ '13bd7a8d9ed6b6bc971e4cd162262c5a20448a83796af39ce394d827b0e5de74'
'SKIP'
- '174f1b3bc887fb5e244c4990f0b63366d15c25b2c19ba89b1f50c894232e6b8517dd9f6b51bd4325250e604fe34d9c2d2cb5383d7717ddcaedd2a9806b719b3f'
- 'ed182e126545a45fb9aaa8e689be8a9b0a0092426b3d354176b1e5197734d1c4a20549b1d5254dc1da79d0ee981d4eaf0414ce359ac4d029ea1c4b0e6fa87c16'
- '27fdc0085318c0ebb1ffe29fd25d258c3ad2c14e3b3c9c4f6eba5ab44e3aca0bfacf90aad2ca66c24896579796b4b731da149ffdd831eab92871e89f96951e84'
- '7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a'
- '2718b58dbbb15063bacb2bde6489e5b3c59afac4c0e0435b97fe720d42c711b6bcba926f67a8687878bd51373c9cf3adb1915a11666d79ccb220bf36e0788ab7'
- '2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf'
- '167bc73c6c1c63931806238905dc44c7d87c5a5c0f6293159f2133dfe717fb44081018d810675716d1605ec7dff5e8333b87b19e09e2de21d0448e447437873b'
- 'bb6718984a7357c9b00c37e4788480e5b8b75018c172ecc1441bc3fc5d2d42444eb5d8c7f9d2e3a7d6fed6d03acb565e3c0559486e494c40a7fe6bd0570c9ede'
- '143dea30c6da00e504c99984a98a0eb2411f558fcdd9dfa7f607d6c14e9e7dffff9cb00121d9317044b07e3e210808286598c785ee854084b993ec9cb14d8232'
- '02af4dd2a007e41db0c63822c8ab3b80b5d25646af1906dc85d0ad9bb8bbf5236f8e381d7f91cf99ed4b0978c50aee37cb9567cdeef65b7ec3d91b882852b1af'
- 'b8fe56e14006ab866970ddbd501c054ae37186ddc065bb869cf7d18db8c0d455118d5bda3255fb66a0dde38b544655cfe9040ffe46e41d19830b47959b2fb168'
- '38e1e19ac2536ffc0d9d6ea953597734151fc319e48fe7223618b51f362f504bf8164c7a439285063a1f81210928ea1d7524630d0e8c41bdcf3de221ead1e34f'
- '20392a6552f39f40919597af3ad767c66f265ccb7ba8c38ee9122de8e1c4ff43285864f9535bef9ad8cca76918ab38bc1fb4db265cd45ccfdb3849e30b198a64'
- 'ac7220d35b9a0e9765aba42458702b23dfe5065e56dff1456a131ead2b165e2dd316548078a23641ebadd35dec8428b250c83d1f21fb1572728ceefe2096d699'
- '00dceecb6b4a8da2deb757118a0a203d91926183bb42539d518ff2e2903b2750dc77f73f3f2e33aa13e1ec0578b05ad12d9828fd5d3a02caf9ca479f5e2f8db9'
- '06738961d1c87b8f3bf6409dace1c8b99c0bd1a8c64d5070e2c88a23191401292b7c6dca018df76213451cdae2d3e7edc80b94ccfaa17986e5d2196cecfa9113')
-sha512sums_armv7h=('dda9e03327dffb6425ec981f4e548802357f9e148d6cb7fa0e9fd8b95548144bfab8e3b15f7ac3cbf73c2d3ec3dcb380ca018b79b125832fd52bfd12662c0943'
- 'SKIP'
- 'cd064ca844aa2f0f1e4157ce7a7607850d7c4b531f5b8336d75ce2f49d3a76e09f1e41ebd712b942357068028896dd7f55d037f5c01367c5cd8297c98920e7dc'
- '066a9e3dca09e5dee2e4f852c1c446f9ccf0a8ebd1effedf9b11492be2ea4bf48b3cffdde809749e8602bb6d6af129c4087d97cb1158df89ad9e0b7eb6aa00d8'
- 'c8a8bf3e17d301325ab870130218df71f8114fbb389c687f4747e9b4f11596ac1b17b97ebf34d3e1f76f065a938ff08b01b16360e9c14345f7985372171e5c10'
- 'c2707250bb31c7f2b2f4d2955231b3d3fe86bd2e7347c6f44fa56dc591559d2824cd166c7c9624ef12e1446d286ce1485c722b37d6b02357504eed273af67e99'
- '3901b0eec723e2312811ef609d68696ff1ec7119efd43ca56f7f70b9f6663f0ea958b87c6b43b05b006bdb489166ab0c7e7da810d0918cc2f9c54a314b2cd2fc'
- '9d09755113b771b31ec95c26eed5f13122a1bdcb962099df71da0b1eba94d6bac1d09c0404f538a7ffa3f64172951db1f33a210a6db2534cb35a1bad6dd6bcdb'
- '565cd932a8a35822431d03f03219a9cf9ff289afd1c25e20e93eb7b69d614122af0407e4a1ed93b4f124f27af924042461ee99b9bc7ac43caec079e7eb8afa45'
- 'cb74edfc1cdb504a74c3b4ccad4f13a0e9ea7ab96ab9b87d35880d8dc8f54a8697cb2689201c8d5b3810802e0fd967193b64b7e6357ea07d369c72e066e43c87')
-
-_kernelname=${pkgbase#linux}
-_replacesarchkernel=("${_replacesarchkernel[@]/\%/${_kernelname}}")
-_replacesoldkernels=("${_replacesoldkernels[@]/\%/${_kernelname}}")
-_replacesoldmodules=("${_replacesoldmodules[@]/\%/${_kernelname}}")
-
-case "$CARCH" in
- i686|x86_64) KARCH=x86;;
- armv7h) KARCH=arm;;
-esac
+ '879a4a8e65790ae85ba69d73dd48d90324cdeb83449892aaf0589c0a46f52f5f')
+validpgpkeys=('474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
+ '6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78') # David P.
-prepare() {
- cd $_srcname
+export KBUILD_BUILD_HOST=archlinux
+export KBUILD_BUILD_USER=$pkgbase
+export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
- # add upstream patch
- if [ "$_srcbasever" != "$_srcver" ]; then
- patch -p1 -i ../patch-$_srcbasever-$_srcver
- fi
+prepare() {
+ cd "$_srcname"
- # add freedo as boot logo
- install -m644 -t drivers/video/logo \
- ../logo_linux_{clut224.ppm,vga16.ppm,mono.pbm}
+ # freedo boot logo
+ install -m644 -t drivers/video/logo ../logo_linux_{clut224.ppm,vga16.ppm,mono.pbm}
- msg2 "Setting version..."
- scripts/setlocalversion --save-scmversion
+ echo "Setting version..."
echo "-$pkgrel" > localversion.10-pkgrel
- echo "$_kernelname" > localversion.20-pkgname
-
- if [ "$CARCH" = "armv7h" ]; then
- local src_armv7h
- for src_armv7h in "${source_armv7h[@]}"; do
- src_armv7h="${src_armv7h%%::*}"
- src_armv7h="${src_armv7h##*/}"
- [[ $src_armv7h = *.patch ]] || continue
- msg2 "Applying patch $src_armv7h..."
- patch -Np1 < "../$src_armv7h"
- done
- fi
-
- local src
- for src in "${source[@]}"; do
- src="${src%%::*}"
- src="${src##*/}"
- [[ $src = *.patch ]] || continue
- msg2 "Applying patch $src..."
- patch -Np1 < "../$src"
+ echo "${pkgbase#linux}" > localversion.20-pkgname
+ sed -i 's|^-libre||' localversion.20-pkgname # minimize diff
+
+ local _src
+ ln -sf "patch-${pkgver%.*}-gnu-${pkgver}-gnu" "../patch-${pkgver%.*}-gnu-${pkgver}-gnu.patch"
+ for _src in "${source[@]}" "../patch-${pkgver%.*}-gnu-${pkgver}-gnu.patch"
+ do
+ _src="${_src%%::*}"
+ _src="${_src##*/}"
+ [[ $_src = *.patch ]] || continue
+ echo "Applying patch $_src..."
+ patch -Np1 < "../$_src"
done
- msg2 "Setting config..."
- cp ../config.$CARCH .config
+ echo "Setting config..."
+ cp ../config .config
make olddefconfig
+ diff -u ../config .config || :
- make -s kernelrelease > ../version
- msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
+ make -s kernelrelease > version
+ echo "Prepared $pkgbase version $(<version)"
}
build() {
- cd $_srcname
- if [ "$CARCH" = "armv7h" ]; then
- make zImage modules htmldocs dtbs
- elif [ "$CARCH" = "x86_64" ] || [ "$CARCH" = "i686" ]; then
- make bzImage modules htmldocs
- fi
+ make -C "$_srcname" htmldocs all
+ make -C "${_srcname}/tools/bpf/bpftool" vmlinux.h feature-clang-bpf-co-re='1'
}
_package() {
- pkgdesc="The ${pkgbase^} kernel and modules"
- [[ $pkgbase = linux-libre ]] && groups=(base base-openrc)
- depends=(coreutils linux-libre-firmware kmod mkinitcpio)
- optdepends=('crda: to set the correct wireless channels of your country')
- provides=("LINUX-ABI_VERSION=${_srcver%%-*}")
- backup=("etc/mkinitcpio.d/$pkgbase.preset")
- install=linux.install
-
- local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
-
- cd $_srcname
-
- msg2 "Installing boot image..."
- if [ "$CARCH" = "armv7h" ]; then
- make INSTALL_DTBS_PATH="$pkgdir/boot/dtbs/$pkgbase" dtbs_install
- fi
+ pkgdesc="The $pkgdesc kernel and modules"
+ depends=(
+ coreutils
+ initramfs
+ kmod
+ )
+ optdepends=(
+ 'wireless-regdb: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ )
+ provides=(
+ KSMBD-MODULE
+ VIRTUALBOX-GUEST-MODULES
+ WIREGUARD-MODULE
+ )
+ replaces=(
+ virtualbox-guest-modules-arch
+ wireguard-arch
+ )
+
+ cd "$_srcname"
+ local _modulesdir="$pkgdir/usr/lib/modules/$(<version)"
+
+ echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
- install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
-
- msg2 "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
-
- # a place for external modules,
- # with version file for building modules and running depmod from hook
- local extramodules="extramodules$_kernelname"
- local extradir="$pkgdir/usr/lib/modules/$extramodules"
- install -Dt "$extradir" -m644 ../version
- ln -sr "$extradir" "$modulesdir/extramodules"
-
- # remove build and source links
- rm "$modulesdir"/{source,build}
-
- msg2 "Installing hooks..."
- # sed expression for following substitutions
- if [ "$CARCH" = "armv7h" ]; then
- local subst="
- s|/boot/vmlinuz-%PKGBASE%|$kernver|g
- s|%PKGBASE%|$pkgbase|g
- s|%KERNVER%|$kernver|g
- s|%EXTRAMODULES%|$extramodules|g
- "
- else
- local subst="
- s|%PKGBASE%|$pkgbase|g
- s|%KERNVER%|$kernver|g
- s|%EXTRAMODULES%|$extramodules|g
- "
- fi
-
- # hack to allow specifying an initially nonexisting install file
- sed "$subst" "$startdir/$install" > "$startdir/$install.pkg"
- true && install=$install.pkg
-
- # fill in mkinitcpio preset and pacman hooks
- sed "$subst" ../linux.preset | install -Dm644 /dev/stdin \
- "$pkgdir/etc/mkinitcpio.d/$pkgbase.preset"
- sed "$subst" ../60-linux.hook | install -Dm644 /dev/stdin \
- "$pkgdir/usr/share/libalpm/hooks/60-$pkgbase.hook"
- sed "$subst" ../90-linux.hook | install -Dm644 /dev/stdin \
- "$pkgdir/usr/share/libalpm/hooks/90-$pkgbase.hook"
-
- msg2 "Fixing permissions..."
- chmod -Rc u=rwX,go=rX "$pkgdir"
+ install -Dm644 "$(make -s image_name)" "$_modulesdir/vmlinuz"
+
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$_modulesdir/pkgbase"
+
+ echo "Installing modules..."
+ ZSTD_CLEVEL=19 make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
+
+ # remove build link
+ rm "$_modulesdir"/build
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for ${pkgbase^} kernel"
-
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+ depends=(pahole)
- cd $_srcname
+ cd "$_srcname"
+ local _builddir="$pkgdir/usr/lib/modules/$(<version)/build"
- msg2 "Installing build files..."
- install -Dt "$builddir" -m644 Makefile .config Module.symvers System.map vmlinux
- install -Dt "$builddir/kernel" -m644 kernel/Makefile
- install -Dt "$builddir/arch/$KARCH" -m644 arch/$KARCH/Makefile
- if [[ $CARCH = i686 ]]; then
- install -Dt "$builddir/arch/$KARCH" -m644 arch/$KARCH/Makefile_32.cpu
- fi
- cp -t "$builddir" -a scripts
+ echo "Installing build files..."
+ install -Dt "$_builddir" -m644 .config Makefile Module.symvers System.map \
+ localversion.* version vmlinux tools/bpf/bpftool/vmlinux.h
+ install -Dt "$_builddir/kernel" -m644 kernel/Makefile
+ install -Dt "$_builddir/arch/x86" -m644 arch/x86/Makefile
+ cp -t "$_builddir" -a scripts
- # add objtool for external module building and enabled VALIDATION_STACK option
- if [[ -e tools/objtool/objtool ]]; then
- install -Dt "$builddir/tools/objtool" tools/objtool/objtool
- fi
+ # required when STACK_VALIDATION is enabled
+ install -Dt "$_builddir/tools/objtool" tools/objtool/objtool
- # add xfs and shmem for aufs building
- mkdir -p "$builddir"/{fs/xfs,mm}
+ # required when DEBUG_INFO_BTF_MODULES is enabled
+ install -Dt "$_builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
- # ???
- mkdir "$builddir/.tmp_versions"
+ echo "Installing headers..."
+ cp -t "$_builddir" -a include
+ cp -t "$_builddir/arch/x86" -a arch/x86/include
+ install -Dt "$_builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
- msg2 "Installing headers..."
- cp -t "$builddir" -a include
- cp -t "$builddir/arch/$KARCH" -a arch/$KARCH/include
- install -Dt "$builddir/arch/$KARCH/kernel" -m644 arch/$KARCH/kernel/asm-offsets.s
+ install -Dt "$_builddir/drivers/md" -m644 drivers/md/*.h
+ install -Dt "$_builddir/net/mac80211" -m644 net/mac80211/*.h
- install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
- install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
+ # https://bugs.archlinux.org/task/13146
+ install -Dt "$_builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
- # http://bugs.archlinux.org/task/13146
- install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
+ # https://bugs.archlinux.org/task/20402
+ install -Dt "$_builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
+ install -Dt "$_builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
+ install -Dt "$_builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
- # http://bugs.archlinux.org/task/20402
- install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
- install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
- install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
+ # https://bugs.archlinux.org/task/71392
+ install -Dt "$_builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
- msg2 "Installing KConfig files..."
- find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
+ echo "Installing KConfig files..."
+ find . -name 'Kconfig*' -exec install -Dm644 {} "$_builddir/{}" \;
- msg2 "Removing unneeded architectures..."
+ echo "Removing unneeded architectures..."
local arch
- for arch in "$builddir"/arch/*/; do
- [[ $arch = */$KARCH/ ]] && continue
+ for arch in "$_builddir"/arch/*/; do
+ [[ $arch = */x86/ ]] && continue
echo "Removing $(basename "$arch")"
rm -r "$arch"
done
- msg2 "Removing documentation..."
- rm -r "$builddir/Documentation"
-
- # Parabola changes
- #
- # since we don't want to diverge too much from Arch's PKGBUILD, we'll
- # start marking our changes as such
- if [ "$CARCH" = "armv7h" ]; then
- for i in dove exynos omap2; do
- mkdir -p "$pkgdir/usr/lib/modules/$kernver/build/arch/$KARCH/mach-$i"
- cp -a arch/$KARCH/mach-$i/include "$pkgdir/usr/lib/modules/$kernver/build/arch/$KARCH/mach-$i/"
- done
- for i in omap orion samsung versatile; do
- mkdir -p "$pkgdir/usr/lib/modules/$kernver/build/arch/$KARCH/plat-$i"
- cp -a arch/$KARCH/plat-$i/include "$pkgdir/usr/lib/modules/$kernver/build/arch/$KARCH/plat-$i/"
- done
- fi
- # end of Parabola changes
-
- msg2 "Removing broken symlinks..."
- find -L "$builddir" -type l -printf 'Removing %P\n' -delete
-
- msg2 "Removing loose objects..."
- find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
-
- msg2 "Stripping build tools..."
+ echo "Removing documentation..."
+ rm -r "$_builddir/Documentation"
+
+ echo "Removing broken symlinks..."
+ find -L "$_builddir" -type l -printf 'Removing %P\n' -delete
+
+ echo "Removing loose objects..."
+ find "$_builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
+
+ echo "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
@@ -343,86 +205,39 @@ _package-headers() {
application/x-pie-executable\;*) # Relocatable binaries
strip -v $STRIP_SHARED "$file" ;;
esac
- done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+ done < <(find "$_builddir" -type f -perm -u+x ! -name vmlinux -print0)
- msg2 "Adding symlink..."
- mkdir -p "$pkgdir/usr/src"
- ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase-$pkgver"
+ echo "Stripping vmlinux..."
+ strip -v $STRIP_STATIC "$_builddir/vmlinux"
- msg2 "Fixing permissions..."
- chmod -Rc u=rwX,go=rX "$pkgdir"
+ echo "Adding symlink..."
+ mkdir -p "$pkgdir/usr/src"
+ ln -sr "$_builddir" "$pkgdir/usr/src/$pkgbase"
}
_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase^} kernel"
-
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
- cd $_srcname
+ pkgdesc="Documentation for the $pkgdesc kernel"
- msg2 "Installing documentation..."
- mkdir -p "$builddir"
- cp -t "$builddir" -a Documentation
+ cd "$_srcname"
+ local _builddir="$pkgdir/usr/lib/modules/$(<version)/build"
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
+ echo "Installing documentation..."
local src dst
while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
+ dst="${src#Documentation/}"
+ dst="$_builddir/Documentation/${dst#output/}"
+ install -Dm644 "$src" "$dst"
+ done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
- msg2 "Adding symlink..."
+ echo "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
- ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
-
- msg2 "Fixing permissions..."
- chmod -Rc u=rwX,go=rX "$pkgdir"
-}
-
-_package-chromebook() {
- pkgdesc="Kernel image sign for ${pkgbase^} - Chromebooks"
- depends=(linux-libre=${_archpkgver})
- provides=("${_replacesarchkernel[@]/%/-armv7-chromebook=${_archpkgver}}")
- conflicts=("${_replacesarchkernel[@]/%/-armv7-chromebook}" "${_replacesoldkernels[@]/%/-armv7-chromebook}")
- replaces=("${_replacesarchkernel[@]/%/-armv7-chromebook}" "${_replacesoldkernels[@]/%/-armv7-chromebook}")
- install=linux-chromebook.install
-
- cd $_srcname
-
- msg2 "Setting options for device tree compiler..."
- cp ../kernel.its .
- mkimage -D "-I dts -O dtb -p 2048" -f kernel.its kernel.itb
- dd if=/dev/zero of=bootloader.bin bs=512 count=1
- echo 'console=tty0 init=/sbin/init root=PARTUUID=%U/PARTNROFF=1 rootwait rw noinitrd' > cmdline
-
- msg2 "Creating kernel sign..."
- vbutil_kernel \
- --pack vmlinux.kpart \
- --version 1 \
- --vmlinuz kernel.itb \
- --arch arm \
- --keyblock ../kernel.keyblock \
- --signprivate ../kernel_data_key.vbprivk \
- --config cmdline \
- --bootloader bootloader.bin
-
- msg2 "Installing kernel sign..."
- mkdir -p "$pkgdir/boot"
- cp vmlinux.kpart "$pkgdir/boot"
+ ln -sr "$_builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
}
pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
-[[ $CARCH = armv7h ]] && pkgname+=("$pkgbase-chromebook")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")
_package${_p#$pkgbase}
}"
done
-
-# vim:set ts=8 sts=2 sw=2 et: