summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 39 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index faa3393e7812..6c6b76aaa647 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@
pkgbase=linux-libre # Build stock kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
-_srcbasever=5.1-gnu
-_srcver=5.1.6-gnu
+_srcbasever=5.2-gnu
+_srcver=5.2.1-gnu
_replacesarchkernel=('linux%') # '%' gets replaced with _kernelname
_replacesoldkernels=() # '%' gets replaced with _kernelname
@@ -23,11 +23,14 @@ _srcname=linux-${_srcbasever%-*}
_archpkgver=${_srcver%-*}
pkgver=${_srcver//-/_}
pkgrel=1
-rcnrel=armv7-x5
+rcnrel=armv7-x2
arch=(i686 x86_64 armv7h)
url='https://linux-libre.fsfla.org/'
license=(GPL2)
-makedepends=(xmlto kmod inetutils bc libelf)
+makedepends=(
+ xmlto kmod inetutils bc libelf python-sphinx python-sphinx_rtd_theme
+ graphviz imagemagick
+)
makedepends_armv7h=(uboot-tools vboot-utils dtc) # for linux-libre-chromebook
options=('!strip')
source=(
@@ -50,10 +53,19 @@ source=(
# Arch's custom linux patches
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
+ 0002-ZEN-Add-CONFIG-for-unprivileged_userns_clone.patch
+ 0003-iwlwifi-mvm-disable-TX-AMSDU-on-older-NICs.patch
)
source_armv7h=(
# armv7h patches, put in the source_armv7h variable just for a more comfortable loop patching
+
+ # RCN patch (CM3 firmware deblobbed and AUFS/WireGuard removed)
+ # Note: For stability reasons, AUFS has been removed in the RCN patch.
+ # We are supporting AUFS in linux-libre-pck through PCK patch.
+ # See https://wiki.parabola.nu/PCK for further details.
"https://repo.parabola.nu/other/rcn-libre/patches/${_srcver%-*}/rcn-libre-${_srcver%-*}-$rcnrel.patch"{,.sig}
+
+ # Arch Linux ARM patches
0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch
0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch
0003-SMILE-Plug-device-tree-file.patch
@@ -67,9 +79,9 @@ validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
'6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
)
-sha512sums=('42510bffa69746e0f919fecef5a23da4adb2473239ee67730fa1eb2340256fb4618c6acab439c01ae781df768a2e1ac4b76ad80fe0e4a432eaceb7f01f275439'
+sha512sums=('3359b0a10ac04243399a1b0aa84f6c09e3c1914880be19a7e931189da92900ca77e467e7ab5c296a03d2ff0ab3238ec75b13fd41bd2796049b63e71f6896900e'
'SKIP'
- '7c860911baae3c94743981980f93928bde01679f5f8bc3c91f19eb23d1fb1cc590cc4dbb421c1ae9165dab9d1c697e19926fc265a4a2fcfdaaa262cb2b025455'
+ 'a257eb591ae55b4cd56adfd1a3235622aeeee1db39af477b497f01510a2994f7dc26d237999f509ca3c58663b747dda6bdc9ac2ae21866f576e351177c66023d'
'SKIP'
'13cb5bc42542e7b8bb104d5f68253f6609e463b6799800418af33eb0272cc269aaa36163c3e6f0aacbdaaa1d05e2827a4a7c4a08a029238439ed08b89c564bb3'
'SKIP'
@@ -77,9 +89,9 @@ sha512sums=('42510bffa69746e0f919fecef5a23da4adb2473239ee67730fa1eb2340256fb4618
'SKIP'
'267295aa0cea65684968420c68b32f1a66a22d018b9d2b2c1ef14267bcf4cb68aaf7099d073cbfefe6c25c8608bdcbbd45f7ac8893fdcecbf1e621abdfe9ecc1'
'SKIP'
- '4ecc5c328565188428a18f97fbdb849a34c0f4f29d637430adad50486e5be756f985bfa371897066586fe7ee48c098bd8ae5dd21d1234ac9a2e5eba2c47062d8'
- '3f8f695d19cf0fd9bb63aa9852195b13e2ee0294ca2407404958ada72386f1d3c28495a809fc937f4fa7e07ca9ae83c57883bb597ec6827c6168477c79399ebb'
- 'c845c78b20819f1a74917c3accef1c41b31b3e91d14ff9c1b524763290137c07fa4175b90a406e5e6aba11998196438e94ab8c578e6f4fb91e3c2b74057eae2a'
+ '9cd90ba3384c99c78e31d58198513886ce6bee3c5a222605e33c43973609dd4995e933843571e2492d37260204a540b0054869fa05b15b242661d9aad2b18787'
+ '9d597fa288507228fe333a137e013dbe1dad9745f7363069968058259d92aed4b01ca0769b55e8b03e204805f2a350cf7ecb11e8950a702d9852f741a4f8dc3d'
+ '413d761727e25c6b20f942588ec162d2a04fdbc06c22d59f16766b9fd9764c0b71458d32db7932417a712544149a3fa81ba290e3ea140bd276c78f4fcf8e8b1c'
'7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a'
'2718b58dbbb15063bacb2bde6489e5b3c59afac4c0e0435b97fe720d42c711b6bcba926f67a8687878bd51373c9cf3adb1915a11666d79ccb220bf36e0788ab7'
'2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf'
@@ -88,8 +100,10 @@ sha512sums=('42510bffa69746e0f919fecef5a23da4adb2473239ee67730fa1eb2340256fb4618
'143dea30c6da00e504c99984a98a0eb2411f558fcdd9dfa7f607d6c14e9e7dffff9cb00121d9317044b07e3e210808286598c785ee854084b993ec9cb14d8232'
'02af4dd2a007e41db0c63822c8ab3b80b5d25646af1906dc85d0ad9bb8bbf5236f8e381d7f91cf99ed4b0978c50aee37cb9567cdeef65b7ec3d91b882852b1af'
'b8fe56e14006ab866970ddbd501c054ae37186ddc065bb869cf7d18db8c0d455118d5bda3255fb66a0dde38b544655cfe9040ffe46e41d19830b47959b2fb168'
- '4dd2f5be666462549a70ae330e094c35970c0fa384d215884c84fe40ca7f82f9b90b155c96bb3d14d0a460c64f5fc251c156ae9cca595d0f5546674569f215ea')
-sha512sums_armv7h=('d5361f28165e59cc09f8728af84b095ba890c6d617c3e05d3feb9402221fb1affa699d786e5b32dd989141f96e9f273611b0434f03cf7ec0d00a1aa8eb5d3c6d'
+ '85a0c3e33d6c00e13fe5f0e575993b2e3299a00b633c0a2e09b9c9093b6c375ab414c27b417e2dc674322325626c1e45dc7e5580e1993ec3e7bc71562e621a27'
+ '75475d99a4843426201b50b89cf3a6f92adb1d9371b0038790e2d8be0c2b9fdfd1eb5104570e0c2cb86da5d79632bb76366ed365c5a5c90fd725f2e80db1fbc3'
+ '9e8a82569db44a635c1c9ccbd8ef15e008af655a9cf388a97e73dd5bba71dae8ce972f8e6751509abc23f9a982a48fe86ea81c61ce5284240646647300b693ee')
+sha512sums_armv7h=('56d27a8e61e47a8eb7c6efddd421e5452ba91b4d78c4398dfed1fad0b500deb4cdf83e0c602657e58bfc502e13ec75a3ded62e0ea1109bdb23881bbb6512a1c5'
'SKIP'
'cd064ca844aa2f0f1e4157ce7a7607850d7c4b531f5b8336d75ce2f49d3a76e09f1e41ebd712b942357068028896dd7f55d037f5c01367c5cd8297c98920e7dc'
'066a9e3dca09e5dee2e4f852c1c446f9ccf0a8ebd1effedf9b11492be2ea4bf48b3cffdde809749e8602bb6d6af129c4087d97cb1158df89ad9e0b7eb6aa00d8'
@@ -128,10 +142,6 @@ prepare() {
echo "$_kernelname" > localversion.20-pkgname
if [ "$CARCH" = "armv7h" ]; then
- # RCN patch (CM3 firmware deblobbed and AUFS/WireGuard removed)
- # Note: For stability reasons, AUFS has been removed in the RCN patch.
- # We are supporting AUFS in linux-libre-pck through PCK patch.
- # See https://wiki.parabola.nu/PCK for further details.
local src_armv7h
for src_armv7h in "${source_armv7h[@]}"; do
src_armv7h="${src_armv7h%%::*}"
@@ -162,9 +172,9 @@ prepare() {
build() {
cd $_srcname
if [ "$CARCH" = "armv7h" ]; then
- make zImage modules dtbs
+ make zImage modules htmldocs dtbs
elif [ "$CARCH" = "x86_64" ] || [ "$CARCH" = "i686" ]; then
- make bzImage modules
+ make bzImage modules htmldocs
fi
}
@@ -358,6 +368,18 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
+ msg2 "Removing doctrees..."
+ rm -r "$builddir/Documentation/output/.doctrees"
+
+ msg2 "Moving HTML docs..."
+ local src dst
+ while read -rd '' src; do
+ dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
+ mkdir -p "${dst%/*}"
+ mv "$src" "$dst"
+ rmdir -p --ignore-fail-on-non-empty "${src%/*}"
+ done < <(find "$builddir/Documentation/output" -type f -print0)
+
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"