summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 8 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7677da2c224b..f2fdae3a4b0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,3 @@
-# Maintainer (Arch): Tobias Powalowski <tpowa@archlinux.org>
-# Maintainer (Arch): Thomas Baechler <thomas@archlinux.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
# Contributor: Nicolás Reynolds <fauno@kiwwwi.com.ar>
# Contributor: Sorin-Mihai Vârgolici <smv@yobicore.org>
@@ -7,9 +5,12 @@
# Contributor: Márcio Silva <coadde@parabola.nu>
# Contributor: Luke Shumaker <lukeshu@sbcglobal.net>
-pkgbase=linux-libre # Build stock "" kernel
+# Based on linux package
+
+pkgbase=linux-libre # Build stock kernel
+#pkgbase=linux-libre-custom # Build kernel with a different name
_pkgbasever=4.1-gnu
-_pkgver=4.1.3-gnu
+_pkgver=4.1.4-gnu
_replacesarchkernel=('linux%') # '%' gets replaced with _kernelname
_replacesoldkernels=('kernel26%' 'kernel26-libre%') # '%' gets replaced with _kernelname
@@ -38,14 +39,10 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/li
'config.i686' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
'linux.preset'
- '0001-block-loop-convert-to-per-device-workqueue.patch'
- '0002-block-loop-avoiding-too-many-pending-per-work-I-O.patch'
- '0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch'
- 'bitmap-enable-booting-for-dm-md-raid1.patch'
'change-default-console-loglevel.patch')
sha256sums=('48b2e5ea077d0a0bdcb205e67178e8eb5b2867db3b2364b701dbc801d9755324'
'SKIP'
- 'd52669f17a1cd13abba4f47a04e1991be59cfa707926b21f9c5bf031ec10c5d0'
+ '4929cf8776f454ec34af5e1d89fa0ceda666da17e5d0878f7c9f6db5e0e1af97'
'SKIP'
'bfd4a7f61febe63c880534dcb7c31c5b932dde6acf991810b41a939a93535494'
'SKIP'
@@ -53,13 +50,9 @@ sha256sums=('48b2e5ea077d0a0bdcb205e67178e8eb5b2867db3b2364b701dbc801d9755324'
'SKIP'
'6de8a8319271809ffdb072b68d53d155eef12438e6d04ff06a5a4db82c34fa8a'
'SKIP'
- '0fc8d80f2a5acce485fd2fc243a87a325e5a242bdbaa538f1a9aa852776085be'
- '78fd6dfd2400a1e627a763709cd67bfd2b07aec86ea7be873f918995e6aa6ce5'
+ '7ec6927f4a4bc8e1aa50adfcce868f04b07b0de19a54554a8ad27ee0341b4b45'
+ 'ac457bf24c83a4af82251a67cb3de06f0b73e66bd08c2fb1eb936caa3b555c6f'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
- '9e1d3fd95d768a46353593f6678513839cedb98ee66e83d9323233104ec3b23f'
- 'bbe3631c737ed8329a1b7a9610cc0a07330c14194da5e9afec7705e7f37eeb81'
- '08f69d122021e1d13c31e5987c23021916a819846c47247b3f1cee2ef99d7f82'
- '959c4d71b5dc50434eeecf3a8608758f57f111c6e999289c435b13fc8c6be5f0'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99')
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
@@ -90,20 +83,6 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
- # Fix deadlock with stacked loop devices (FS#45129)
- # http://marc.info/?l=linux-kernel&m=143280649731902&w=2
- patch -Np1 -i ../0001-block-loop-convert-to-per-device-workqueue.patch
- patch -Np1 -i ../0002-block-loop-avoiding-too-many-pending-per-work-I-O.patch
-
- # Fix bluetooth chip initialization on some macbooks (FS#45554)
- # http://marc.info/?l=linux-bluetooth&m=143690738728402&w=2
- # https://bugzilla.kernel.org/show_bug.cgi?id=100651
- patch -Np1 -i ../0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch
-
- # Fix kernel oops when booting with root on RAID1 LVM (FS#45548)
- # https://bugzilla.kernel.org/show_bug.cgi?id=100491#c24
- patch -Np1 -i ../bitmap-enable-booting-for-dm-md-raid1.patch
-
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)