summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 10ac2e3d4795..690b60a5c9bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
#pkgbase=linux-lts
pkgbase=linux-lts-surface4
_srcname=linux-4.4
-pkgver=4.4.34
+pkgver=4.4.36
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -18,19 +18,21 @@ source=(https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.{xz,sign}
# standard config files for mkinitcpio ramdisk
linux-lts.preset
change-default-console-loglevel.patch
+ fix_race_condition_in_packet_set_ring.diff
0001-sdhci-revert.patch
- 0002-surface-wifi.patch
+ 0002-surface-wifi.patch
0003-surface-cover.patch
0004-surface-pro4-button.patch)
# https://www.kernel.org/pub/linux/kernel/v4.x/sha256sums.asc
sha256sums=('401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2'
'SKIP'
- 'b1e77807267aa3ec81e46c15b1a4be0c7169b6c19eb52cd371c4f58dd2183a9d'
+ '468ddfe3f29c314b40e32410c796fda9277620d50bc47b50fafc8a5a4c375e61'
'SKIP'
'e8d200b125b4391020c2bc1f43bf8f3a372f0bbdaf9bad71b31574edab7f908f'
'236fc805c543cb774785f630bf37c7fdc2ff7c9904bb240ff70e0b7213058de5'
'9e9e7ee3476e55e68390eda7e983fa18d44e76db5521f023fd2b388b1150bc40'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
+ 'ad1ee95f906f88d31fcdb9273cd08e02e8eda177449f0c98dc1bff8cbf1483c2'
'5313df7cb5b4d005422bd4cd0dae956b2dadba8f3db904275aaf99ac53894375'
'c59a18d38d75fec7e9cc3b4efb6a997b3714c3156f6f80a6915bd16db409cde9'
'26ed3893c370952f8310a0b2bdecdabf5e3185ad8e9100f1e2ef5260fdf52c84'
@@ -46,6 +48,10 @@ prepare() {
# add upstream patch
patch -p1 -i "${srcdir}/patch-${pkgver}"
+ # fix a race condition that allows to gain root
+ # https://marc.info/?l=linux-netdev&m=148054660230570&w=2
+ patch -p1 -i "${srcdir}/fix_race_condition_in_packet_set_ring.diff"
+
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git