summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 10 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cdec1397f4c8..dc9861bce697 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=linux-lts-tomoyo
_srcname=linux-4.14
-pkgver=4.14.41
+pkgver=4.14.59
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -14,29 +14,22 @@ license=('GPL2')
makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
- # the main kernel config files
- 'config'
- # pacman hook for initramfs regeneration
- '60-linux.hook'
- '90-linux.hook'
- # standard config files for mkinitcpio ramdisk
- 'linux-lts.preset'
- 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- 0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ 'config' # the main kernel config file
+ '60-linux.hook' # pacman hook for depmod
+ '90-linux.hook' # pacman hook for initramfs regeneration
+ 'linux-lts.preset' # standard config files for mkinitcpio ramdisk
+ '0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch'
+ '0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch'
)
sha256sums=('f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7'
- 'SKIP'
- '9899039be6a66e98272120c4c6d50f4029a6b4f9cc95e5ca3555cff513a7581c'
- 'SKIP'
+ '8444907cab31f19e555f809b4157c932eb3f44d9768a09cd23ceb41fa25971ac'
'c645053c4525a1a70d5c10b52257ac136da7e9059b6a4a566a857a3d42046426'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'36b1118c8dedadc4851150ddd4eb07b1c58ac5bbf3022cc2501a27c2b476da98'
- '6364edabad4182dcf148ae7c14d8f45d61037d4539e76486f978f1af3a090794')
+ 'b6c56ff2dffebe164941ac3428351e158c9c059e884057ecfc215eeea12e76eb')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -60,7 +53,7 @@ prepare() {
patch -Np1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
# https://bugs.archlinux.org/task/56711
- patch -Np1 -i ../0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ patch -Np1 -i ../0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
cp -Tf ../config .config