summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 58df1e14697e..da01c510cae1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
pkgbase=linux-lts-tomoyo
-_srcname=linux-4.14
-pkgver=4.14.78
+_srcname=linux-4.19
+pkgver=4.19.13
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -20,21 +20,19 @@ source=(https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.{xz,sign}
'90-linux.hook' # pacman hook for initramfs regeneration
'linux-lts.preset' # standard config files for mkinitcpio ramdisk
'0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch'
- '0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch'
)
validpgpkeys=('ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v4.x/sha256sums.asc
-sha256sums=('f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7'
+sha256sums=('0c68f5655528aed4f99dae71a5b259edc93239fa899e2df79c055275c21749a1'
'SKIP'
- 'd491f69f4075e514c5f2e8d520980a96066b6f5e087decff23c79a799ac199a2'
- 'c645053c4525a1a70d5c10b52257ac136da7e9059b6a4a566a857a3d42046426'
+ '6b9be1fe9446535e1fcdd50ec9be4aec538466e4b9121b3434a6c29669834610'
+ 'd0f62ce948ad58b96fea316b9cf1f08193c6b56e0ca4901d382494a071865dfd'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
- '36b1118c8dedadc4851150ddd4eb07b1c58ac5bbf3022cc2501a27c2b476da98'
- 'b6c56ff2dffebe164941ac3428351e158c9c059e884057ecfc215eeea12e76eb')
+ '36b1118c8dedadc4851150ddd4eb07b1c58ac5bbf3022cc2501a27c2b476da98')
_kernelname=${pkgbase#linux}
prepare() {
@@ -52,9 +50,6 @@ prepare() {
# disable USER_NS for non-root users by default
patch -Np1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- # https://bugs.archlinux.org/task/56711
- patch -Np1 -i ../0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
-
cp -Tf ../config .config
# Enable TOMOYO Linux
@@ -116,6 +111,10 @@ _package() {
make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
cp arch/x86/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ ln -sr "${pkgdir}/boot/vmlinuz-${pkgbase}" "${pkgdir}/usr/lib/modules/${_kernver}/vmlinuz"
+
# make room for external modules
local _extramodules="extramodules-${_basekernel}${_kernelname:--tomoyo}"
ln -s "../${_extramodules}" "${pkgdir}/usr/lib/modules/${_kernver}/extramodules"
@@ -177,9 +176,6 @@ _package-headers() {
install -Dt "${_builddir}/drivers/md" -m644 drivers/md/*.h
install -Dt "${_builddir}/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/9912
- install -Dt "${_builddir}/drivers/media/dvb-core" -m644 drivers/media/dvb-core/*.h
-
# http://bugs.archlinux.org/task/13146
install -Dt "${_builddir}/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h