summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 9 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff6259494819..df48290f9a9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,9 +24,8 @@ source=(
RFC-PCI-Workaround-to-enable-poweroff-on-Mac-Pro-11.patch
RFC-v2-PCI-Workaround-to-enable-poweroff-on-Mac-Pro-11.patch
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- 0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
- 0003-Partially-revert-swiotlb-remove-various-exports.patch
- 0004-xhci-Fix-USB3-NULL-pointer-dereference-at-logical-di.patch
+ 0002-ACPI-watchdog-Prefer-iTCO_wdt-on-Lenovo-Z50-70.patch
+ 0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -43,10 +42,9 @@ sha256sums=('63f6dc8e3c9f3a0273d5d6f4dca38a2413ca3a5f689329d05b750e4c87bb21b9'
'c5a714823c3418692bc5c212dd5d094a0e2ae6147d6726822911f1c26e3a1d1b'
'7c99aaeaea7837f83a3ad215cf07277934ccf39720acee7f1c371dc86bdf89fc'
'09189eb269a9fd16898cf90a477df23306236fb897791e8d04e5a75d5007bbff'
- '7fb607fe384dd814e9e45d7fc28f7b5b23a51d80784c54bf9209486ad428be14'
- 'ceaa19e0af3842c62eb666a4ac5c79d89b3e6d00593442f18d6508ca6d74bbaa'
- '5b397cf9eccdad0c1f2865842c29ba6f4e32ad7dbe4e0c6ef6ca6f07d2963cea'
- '052a39582f84c52b027c261fcec90325493f4d46f15647c274a58e39145deced')
+ '8d6a5f34b3d79e75b0cb888c6bcf293f84c5cbb2757f7bdadafee7e0ea77d7dd'
+ '2454c1ee5e0f5aa119fafb4c8d3b402c5e4e10b2e868fe3e4ced3b1e2aa48446'
+ '8114295b8c07795a15b9f8eafb0f515c34661a1e05512da818a34581dd30f87e')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-ARCH}
@@ -73,14 +71,11 @@ prepare() {
# disable USER_NS for non-root users by default
patch -Np1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- # https://bugs.archlinux.org/task/56711
- patch -Np1 -i ../0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
-
- # NVIDIA driver compat
- patch -Np1 -i ../0003-Partially-revert-swiotlb-remove-various-exports.patch
+ # https://bugs.archlinux.org/task/56780
+ patch -Np1 -i ../0002-ACPI-watchdog-Prefer-iTCO_wdt-on-Lenovo-Z50-70.patch
- # https://bugs.archlinux.org/task/58237
- patch -Np1 -i ../0004-xhci-Fix-USB3-NULL-pointer-dereference-at-logical-di.patch
+ # https://bugs.archlinux.org/task/56711
+ patch -Np1 -i ../0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
cat ../config - >.config <<END
CONFIG_LOCALVERSION="${_kernelname}"