summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 32 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01d0abaa572b..cc7dd662a202 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,3 @@
-# $Id$
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
@@ -6,24 +5,23 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-macbook # Build kernel with a different name
-_srcver=4.17.13-arch1
+_srcver=4.18.10-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
-url="https://github.com/archlinux/linux/commits/v$_srcver"
+url="https://git.archlinux.org/linux.git/log/?h=v$_srcver"
license=(GPL2)
-makedepends=(xmlto kmod inetutils bc libelf git)
+makedepends=(xmlto kmod inetutils bc libelf git python-sphinx graphviz)
options=('!strip')
_srcname=archlinux-linux
source=(
- "$_srcname::git+https://github.com/archlinux/linux?signed#tag=v$_srcver"
+ "$_srcname::git+https://git.archlinux.org/linux.git?signed#tag=v$_srcver"
config # the main kernel config file
60-linux.hook # pacman hook for depmod
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
macbook-wakeup.service # service file for suspend/resume events
RFC-PCI-Workaround-to-enable-poweroff-on-Mac-Pro-11.patch
- RFC-v2-PCI-Workaround-to-enable-poweroff-on-Mac-Pro-11.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -31,13 +29,12 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- 'aa7b6756f193f3b3a3fc4947e7a77b09e249df2e345e6495292055d757ba8be6'
- '36e326d8a88b4087a3a0ee0d47643fc03baeda487659980d0e9d08791e4c729c'
+ '1fc23bd2613b821d8bdca1a33dc421e21de296221108ce047176d27d37ce397f'
+ 'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'c5a714823c3418692bc5c212dd5d094a0e2ae6147d6726822911f1c26e3a1d1b'
- '7c99aaeaea7837f83a3ad215cf07277934ccf39720acee7f1c371dc86bdf89fc'
- '09189eb269a9fd16898cf90a477df23306236fb897791e8d04e5a75d5007bbff')
+ 'a4e044fb954f035aa70af4c7d79f8a6076933bdbbf9efee749304829621d77ed')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-ARCH}
@@ -69,7 +66,7 @@ prepare() {
build() {
cd $_srcname
- make bzImage modules
+ make bzImage modules htmldocs
}
_package() {
@@ -90,7 +87,7 @@ _package() {
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
- make INSTALL_MOD_PATH="$pkgdir/usr" DEPMOD=/doesnt/exist modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# a place for external modules,
# with version file for building modules and running depmod from hook
@@ -102,11 +99,11 @@ _package() {
# remove build and source links
rm "$modulesdir"/{source,build}
- msg2 "Running depmod..."
- depmod -b "$pkgdir/usr" -E Module.symvers -e "$kernver"
+ # copy macbook-wakeup.service to systemd
+ mkdir -p "${pkgdir}/usr/lib/systemd/system"
+ cp "${srcdir}/macbook-wakeup.service" "${pkgdir}/usr/lib/systemd/system"
msg2 "Installing hooks..."
-
# sed expression for following substitutions
local subst="
s|%PKGBASE%|$pkgbase|g
@@ -114,10 +111,6 @@ _package() {
s|%EXTRAMODULES%|$extramodules|g
"
- # copy macbook-wakeup.service to systemd
- mkdir -p "${pkgdir}/usr/lib/systemd/system"
- cp "${srcdir}/macbook-wakeup.service" "${pkgdir}/usr/lib/systemd/system"
-
# hack to allow specifying an initially nonexisting install file
sed "$subst" "$startdir/$install" > "$startdir/$install.pkg"
true && install=$install.pkg
@@ -207,6 +200,10 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+ msg2 "Adding symlink..."
+ mkdir -p "$pkgdir/usr/src"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase-$pkgver"
+
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -222,6 +219,22 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
+ msg2 "Removing doctrees..."
+ rm -r "$builddir/Documentation/output/.doctrees"
+
+ msg2 "Moving HTML docs..."
+ local src dst
+ while read -rd '' src; do
+ dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
+ mkdir -p "${dst%/*}"
+ mv "$src" "$dst"
+ rmdir -p --ignore-fail-on-non-empty "${src%/*}"
+ done < <(find "$builddir/Documentation/output" -type f -print0)
+
+ msg2 "Adding symlink..."
+ mkdir -p "$pkgdir/usr/share/doc"
+ ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
+
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}