summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 474bffd38e88..cabc112e36e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
pkgbase=linux-mainline # Build stock -ARCH kernel
#pkgbase=linux-custom # Build kernel with a different name
_srcname=linux-4.2
-_patchname=patch-4.2-rc8
-pkgver=4.2
+_patchname=patch-4.3-rc1
+pkgver=4.3rc1
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -17,7 +17,7 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
- #"https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_patchname}.xz"
+ "https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_patchname}.xz"
#"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
#"https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_patchname}.sign"
# the main kernel config files
@@ -26,6 +26,7 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'linux.preset'
'change-default-console-loglevel.patch')
sha256sums=('cf20e044f17588d2a42c8f2a450b0fd84dfdbd579b489d93e9ab7d0e8b45dbeb'
+ '5248a8e4fcf347cd918622b8f17057b50a8c367758fd4aed9b9e9dff0ad6a8d0'
'f4c6a5c2fc0ee2b792e43f4c1846b995051901a502fb97885d2296af55fa193d'
'58d49d4a3f6152394d903fd09113116fa3a0939d7d7ee419b2edbbd0c30e1755'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
@@ -44,7 +45,7 @@ prepare() {
#patch -p1 -i "${srcdir}/patch-${pkgver}"
# add mainline patch
- #patch -p1 -i "${srcdir}/${_patchname}"
+ patch -p1 -i "${srcdir}/${_patchname}"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git