summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9224682d93c..21dce630020f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -75,7 +75,7 @@ _package() {
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
- provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+ provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE linux-mainline)
replaces=(virtualbox-guest-modules-mainline wireguard-maineline)
cd $_srcname
@@ -99,6 +99,7 @@ _package() {
_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+ provides=(linux-mainline-headers)
depends=(pahole)
cd $_srcname
@@ -181,6 +182,7 @@ _package-headers() {
_package-docs() {
pkgdesc="Documentation for the $pkgdesc kernel"
+ provides=(linux-mainline-docs)
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"