summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 10 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e7bcc5504d2..2fa369aa3b1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,7 +47,7 @@ _1k_HZ_ticks=
### Do not edit below this line unless you know what you're doing
pkgbase=linux-next-git
-pkgver=20191118.r0.g519ead8f6a32
+pkgver=20191129.r0.g419593dad843
_srcname=linux-next
pkgrel=1
pkgdesc='Linux NEXT'
@@ -55,14 +55,14 @@ arch=('x86_64')
url="http://www.kernel.org/"
license=('GPL2')
options=('!strip')
-makedepends=('kmod' 'inetutils' 'bc' 'libelf' 'git' 'python-sphinx' 'python-sphinx_rtd_theme'
+makedepends=('kmod' 'bc' 'libelf' 'git' 'python-sphinx' 'python-sphinx_rtd_theme'
'graphviz' 'imagemagick')
-_lucjanver=5.3
+_lucjanver=5.4
#_lucjanpath="https://raw.githubusercontent.com/sirlucjan/kernel-patches/master/${_lucjanver}"
_lucjanpath="https://gitlab.com/sirlucjan/kernel-patches/raw/master/${_lucjanver}"
source=("git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git"
- "${_lucjanpath}/arch-patches-v2/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch"
+ "${_lucjanpath}/arch-patches/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch"
# the main kernel config files
'config')
@@ -289,7 +289,6 @@ _package-headers() {
chmod -Rc u=rwX,go=rX "$pkgdir"
}
-
_package-docs() {
pkgdesc="Kernel hacker's manual for the $pkgdesc kernel"
depends=('linux-next-git')
@@ -298,20 +297,12 @@ _package-docs() {
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
msg2 "Installing documentation..."
- mkdir -p "$builddir"
- cp -t "$builddir" -a Documentation
-
- msg2 "Removing unneeded files..."
- rm -rv "$builddir"/Documentation/{,output/}.[^.]*
-
- msg2 "Moving HTML docs..."
local src dst
while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
+ dst="${src#Documentation/}"
+ dst="$builddir/Documentation/${dst#output/}"
+ install -Dm644 "$src" "$dst"
+ done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
@@ -330,5 +321,5 @@ for _p in "${pkgname[@]}"; do
done
sha512sums=('SKIP'
- '8aac877c0dfcd6796bc217572c8b8c6473ab6b5b15b7cca0e7c0f4e7cbb7080557d32fd045e6608d8acbf98cf7c16834ed0c5de2ce9d9d5dfa0194d055642276'
- '4baed594b74bf5bde7f84f5b13a8781e67b7625f450f4828433aea4c38688152e04c9755bf88f95deefe56c641d73fe8b4a71f48165b5f75c17c47740bc8cd7d')
+ '823e5be350152e9f36342229156ffd59c2632d1aab3b85b55caad15bcf1fc6c55e7a22b5b28eecb84a9e96bbc351ca1d348c2ba4b66302134919bababef16a93'
+ '34d66658963dbd72fa3e96f2c5d5bccafb781fa14f6ebafe7859953929ba2fbb112f1435ca68cec8389d789cf0efa81d5fc0f5ac6dfa23a704348ab83709e9db')