summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68d73f07f254..e7840b0f1e2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgbase=linux-nitrous-git
_srcname=linux-nitrous-git
pkgver=5.7+
-pkgrel=12
+pkgrel=13
arch=('x86_64')
url="https://gitlab.com/xdevs23/linux-nitrous"
license=('GPL2')
@@ -32,7 +32,7 @@ pkgver() {
}
prepare() {
- cd "${_srcname}"
+ cd "linux-nitrous"
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
@@ -58,7 +58,7 @@ prepare() {
}
build() {
- cd "${_srcname}"
+ cd "linux-nitrous"
make HOSTCC=clang CC=clang nitrous_defconfig
makeflags="${MAKEFLAGS}"
@@ -80,7 +80,7 @@ _package() {
backup=("etc/mkinitcpio.d/linux-nitrous-git.preset")
install=${pkgbase}.install
- cd "${_srcname}"
+ cd "linux-nitrous"
KARCH=x86
@@ -142,7 +142,7 @@ _package-headers() {
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
- cd "${_srcname}"
+ cd "linux-nitrous"
# Fix for DKMS because clang doesn't like this
for f in Makefile kernel/Makefile; do
@@ -264,7 +264,7 @@ _package-docs() {
pkgdesc="Kernel hackers manual - HTML documentation that comes with the Linux kernel (git version)"
provides=('linux-docs')
- cd "${_srcname}"
+ cd "linux-nitrous"
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build"
cp -al Documentation "${pkgdir}/usr/lib/modules/${_kernver}/build"