summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea5665010e90..37cb6d7ebbfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ _srcname=linux-${_commit}
_kernelname=${pkgbase#linux}
_desc="Raspberry Pi 4 with the cacule scheduler"
pkgver=5.10.35
-pkgrel=2
+pkgrel=3
pkgdesc="Raspberry Pi 4 lts Kernel with the cacule scheduler, aarch64 and armv7"
arch=('armv7h' 'aarch64')
url="http://www.kernel.org/"
@@ -26,7 +26,6 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
'90-linux.hook'
'0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch'
'cacule-5.10.patch'
- 'interactivity_levels.patch'
)
source_armv7h=('config' 'config.txt' 'cacule-32bit-converter.patch')
source_aarch64=('config8' 'config8.txt')
@@ -36,11 +35,10 @@ md5sums=('86644ce5432d4e6f92322ad1c2ae0628'
'ce6c81ad1ad1f8b333fd6077d47abdaf'
'441ec084c47cddc53e592fb0cbce4edf'
'f66a7ea3feb708d398ef57e4da4815e9'
- '3f4e126d082c5cb3fee96a0c7a6b6313'
- 'a621493cad4df968b9b5c140c86d4d93')
+ '2b524cf468b920f6fb87204b6901de05')
md5sums_armv7h=('869c9f4314d92c14a45128c8af56b663'
'9669d916a5929a2eedbd64477f83d99e'
- '4982367e95e393b5937c75f0b30d87e9')
+ 'ff19fef26cbb90c2c41a3868a4ef458c')
md5sums_aarch64=('42bd8ecdb82ed46972e8d6c184cb0f45'
'9669d916a5929a2eedbd64477f83d99e')
@@ -64,7 +62,6 @@ prepare() {
patch -Np1 -i ../0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch
# cacule-scheduler
patch -Np1 -i ../cacule-5.10.patch
- patch -Np1 -i ../interactivity_levels.patch
if [[ $CARCH == "armv7h" ]]; then
patch -Np1 -i ../cacule-32bit-converter.patch #only needed if building on armv6 or armv7
fi