summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f225fad9396..53d0c32db47d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ _srcname=linux-${_commit}
_kernelname=${pkgbase#linux}
_desc="Raspberry Pi 4 with the cacule scheduler"
pkgver=5.11.19
-pkgrel=1
+pkgrel=2
pkgdesc="Raspberry Pi 4 Kernel with the cacule schedeuler, aarch64 and armv7"
arch=('armv7h' 'aarch64')
url="http://www.kernel.org/"
@@ -26,7 +26,6 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
'90-linux.hook'
'0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch'
'cacule-5.11.patch'
- 'interactivity_levels.patch'
)
source_armv7h=('config' 'config.txt' 'cacule-32bit-converter.patch')
source_aarch64=('config8' 'config8.txt')
@@ -36,11 +35,10 @@ md5sums=('bf694586470392017dc161d3965b35d0'
'ce6c81ad1ad1f8b333fd6077d47abdaf'
'441ec084c47cddc53e592fb0cbce4edf'
'f66a7ea3feb708d398ef57e4da4815e9'
- '740fa0f2ccb02a74be37e566b32f7a0c'
- 'a621493cad4df968b9b5c140c86d4d93')
+ '8b8958e64e2480dcd1787109dcdf425f')
md5sums_armv7h=('5697f0e23f8329047cfce076f0e904b4'
'9669d916a5929a2eedbd64477f83d99e'
- '4982367e95e393b5937c75f0b30d87e9')
+ 'ff19fef26cbb90c2c41a3868a4ef458c')
md5sums_aarch64=('c1fa6fc261864237ecdcd4daae0920be'
'9669d916a5929a2eedbd64477f83d99e')
@@ -64,7 +62,6 @@ prepare() {
patch -Np1 -i ../0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch
# cacule-scheduler
patch -Np1 -i ../cacule-5.11.patch
- patch -Np1 -i ../interactivity_levels.patch
if [[ $CARCH == "armv7h" ]]; then
patch -Np1 -i ../cacule-32bit-converter.patch #only needed if building on armv6 or armv7
fi