summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 6 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 58dda3b58852..7716a1612d77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgbase=linux-rc
pkgrel=1
_srcname=linux-4.18
-_stable=4.18.4
-_patchver=4.18.5
+_stable=4.18.5
+_patchver=4.18.6
_rcver=1
pkgver=${_patchver}rc${_rcver}
_rcpatch=patch-${_patchver}-rc${_rcver}
@@ -29,11 +29,11 @@ validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('12dbc87b5bdb7c47980fefea06911ea43b9ef226747e17e879428e6d4d8ba842'
+sha256sums=('fb090a3680eddf6f10bf895bc3075bd3f830e3d2429ce469982db5a28df647bd'
'SKIP'
- 'df64d750516fb613d7e70d391244173861d6e667923148e8126c24071f0577ea'
+ '5c3bb17a2b78e6001e3745b9174f6ebffaa5945a4814ee39fd9baf19e4165028'
'SKIP'
- 'bb700544d499a92dab141a218cc1eac62fdff0b67682748cb827035269c02a55'
+ '83d768f19193f6795b8159d81c6775b9f62f4994f2a0d8371ac243e7b0890db8'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
@@ -107,7 +107,7 @@ _package() {
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
- make INSTALL_MOD_PATH="$pkgdir/usr" DEPMOD=/doesnt/exist modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# a place for external modules,
# with version file for building modules and running depmod from hook
@@ -224,25 +224,6 @@ _package-headers() {
chmod -Rc u=rwX,go=rX "$pkgdir"
}
-_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel"
-
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
- cd $_srcname
-
- msg2 "Installing documentation..."
- mkdir -p "$builddir"
- cp -t "$builddir" -a Documentation
-
- msg2 "Adding symlink..."
- mkdir -p "$pkgdir/usr/share/doc"
- ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
-
- msg2 "Fixing permissions..."
- chmod -Rc u=rwX,go=rX "$pkgdir"
-}
-
pkgname=("$pkgbase" "$pkgbase-headers")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {