summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ba9ee199120..83c1268c0949 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,11 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgbase=linux-selinux
-pkgver=5.3.8.1
+pkgver=5.3.10.1
pkgrel=1
-_srcver=${pkgver%.*}-arch${pkgver##*.}
-url="https://git.archlinux.org/linux.git/log/?h=v$_srcver"
+pkgdesc='Linux SELinux'
+_srctag=v${pkgver%.*}-arch${pkgver##*.}
+url="https://git.archlinux.org/linux.git/log/?h=$_srctag"
arch=(x86_64)
license=(GPL2)
makedepends=(
@@ -26,7 +27,7 @@ groups=(selinux)
# you need to update the remote of the git repository, for example with the following command:
# git -C archlinux-linux remote set-url origin https://git.archlinux.org/linux.git
source=(
- "$_srcname::git+https://git.archlinux.org/linux.git?signed#tag=v$_srcver"
+ "$_srcname::git+https://git.archlinux.org/linux.git?signed#tag=$_srctag"
config # the main kernel config file
)
validpgpkeys=(
@@ -35,11 +36,11 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- 'e6d2df92f3079c740ca2cafd7e8b34b5dd43832d292284c2dc133d47600d1f29')
+ 'e749cd85d37d4d70099b0a7f54e852b039ae07c14e4ab8be299c64edae5d4ba4')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
-export KBUILD_BUILD_TIMESTAMP="@${SOURCE_DATE_EPOCH:-$(date +%s)}"
+export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
prepare() {
cd $_srcname
@@ -75,7 +76,7 @@ build() {
}
_package() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules"
+ pkgdesc="The $pkgdesc kernel and modules"
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
@@ -103,7 +104,7 @@ _package() {
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
@@ -181,7 +182,7 @@ _package-headers() {
}
_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel"
+ pkgdesc="Kernel hacker's manual for the $pkgdesc kernel"
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
@@ -190,8 +191,8 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
+ msg2 "Removing unneeded files..."
+ rm -rv "$builddir"/Documentation/{,output/}.[^.]*
msg2 "Moving HTML docs..."
local src dst