summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 759612559c44..811044e61eca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase=linux-selinux
_srcname=linux-3.16
-pkgver=3.16
+pkgver=3.16.1
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -14,18 +14,21 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
groups=(selinux)
source=("https://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
- #"https://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
+ "https://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
# the main kernel config files
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
'linux-selinux.preset'
'change-default-console-loglevel.patch'
+ 'compal-laptop-hwmon-fix.patch'
)
sha256sums=('4813ad7927a7d92e5339a873ab16201b242b2748934f12cb5df9ba2cfe1d77a0'
- 'a8c670844bb42876df5e5ccb3a0ddfc506ce52095fa777130db0dfa56b71e727'
- '975e41b6ac7a003b8d4972cbbeb30125b3d166bd8ecd012189d33995f0daf20f'
+ 'd2bf33289acf5c05b57aaca1fd8bb1935ac280c5c4090874e84806d35e17012e'
+ '2975fdb93a69bc11b06a2d07d9b27804b24427b0e957766e2cda3bf7edafbbee'
+ 'c985fcf6e978f7623db4c73c895108f64008f0d03825c3afc7c3ed8e51433ad1'
'375da3b030f17581cbf5be9140b79029ca85eebc70197f419a4de77e00fa84e9'
- '1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99')
+ '1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
+ 'f36f61a0a72bcb0a9c04264343503bfbf927c9ea0db819e66734a3933b060588')
_kernelname=${pkgbase#linux}
@@ -33,7 +36,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
- #patch -p1 -i "${srcdir}/patch-${pkgver}"
+ patch -p1 -i "${srcdir}/patch-${pkgver}"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
@@ -43,6 +46,9 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
+ # #41458 fix hwmon for compal-laptop module
+ patch -p1 -i "${srcdir}/compal-laptop-hwmon-fix.patch"
+
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config
else