summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 5 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d61f70ef2287..9589fb38e5c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,12 @@
pkgbase=linux-surface3-git
_srcname=linux
-pkgver=4.11rc3.r402.g0dc82fa59b9d
+pkgver=4.12.r10624.g9967468c0a10
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
-makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'libelf')
+makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'git' 'libelf')
options=('!strip')
source=(
'git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git'
@@ -24,16 +24,14 @@ source=(
# standard config files for mkinitcpio ramdisk
"${pkgbase}.preset"
# From https://github.com/hadess/fedora-surface3-kernel:
- "0001-power-MSHW0011-rev-eng-implementation.patch"
- "0002-power-surface3_power-Improve-battery-capacity-report.patch"
+ "v2-ACPI-surface3_power-MSHW0011-rev-eng-implementation.patch"
"0001-gpiolib-acpi-make-sure-we-trigger-the-events-at-leas.patch"
)
sha256sums=('SKIP'
'becc0c98cff692dee9500f19d38882636caf4c58d5086c7725690a245532f5dc'
'2bf64f96aa977a996d2aaeeb249a266a7c6f83483d49a31a23e595cd895f0846'
'95fcfdfcb9d540d1a1428ce61e493ddf2c2a8ec96c8573deeadbb4ee407508c7'
- '8fb00d96cb11ef3d9c250d6a5389c7eaf9f71d1259fb0a2cd210bf707adb8a71'
- '62eeb51c1ee81c2545fa0c1ac5a2b8f4a112ede4113095ce2ea4a66d07059734'
+ 'dfa18035512258f51e5f0f8c4400de3ae330fcd4a31bf6362055b0899fd34820'
'abae4abc0495026b35b982b426207e7cbad4bf5314a1e706fa295c7f91886307')
_kernelname=${pkgbase#linux}
@@ -62,8 +60,7 @@ prepare() {
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
- patch -p1 < ${srcdir}/0001-power-MSHW0011-rev-eng-implementation.patch
- patch -p1 < ${srcdir}/0002-power-surface3_power-Improve-battery-capacity-report.patch
+ patch -p1 < ${srcdir}/v2-ACPI-surface3_power-MSHW0011-rev-eng-implementation.patch
patch -p1 < ${srcdir}/0001-gpiolib-acpi-make-sure-we-trigger-the-events-at-leas.patch
# load configuration
@@ -193,10 +190,6 @@ _package-headers() {
cp arch/${KARCH}/kernel/asm-offsets.s "${pkgdir}/usr/lib/modules/${_kernver}/build/arch/${KARCH}/kernel/"
- # add docbook makefile
- install -D -m644 Documentation/DocBook/Makefile \
- "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/DocBook/Makefile"
-
# add dm headers
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/md"
cp drivers/md/*.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/md"
@@ -285,9 +278,6 @@ _package-docs() {
cp -al Documentation "${pkgdir}/usr/lib/modules/${_kernver}/build"
find "${pkgdir}" -type f -exec chmod 444 {} \;
find "${pkgdir}" -type d -exec chmod 755 {} \;
-
- # remove a file already in linux package
- rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/DocBook/Makefile"
}
pkgname=("${pkgbase}" "${pkgbase}-headers" "${pkgbase}-docs")