summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-x[-rw-r--r--]PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7701be683102..f35c34954718 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
-# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
pkgname=linux-test-project
-pkgver=20170516
+pkgver=20180515
pkgrel=1
pkgdesc="A collection of tools for testing the Linux kernel and related features"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://linux-test-project.github.io/"
-depends=('acl' 'bash' 'gawk' 'libcap' 'libtirpc' 'python2')
+depends=('acl' 'bash' 'gawk' 'libcap' 'libtirpc' 'python2' 'libaio' 'numactl')
source=("https://github.com/linux-test-project/ltp/releases/download/$pkgver/ltp-full-$pkgver.tar.bz2")
-md5sums=('12e2d693e73acbfe7e04a7be176a26ff')
+md5sums=('e104b70ae4b0d7f7e728ef5345242d2c')
prepare() {
cd "$srcdir/ltp-full-$pkgver"
+
find . -type f -exec sed -i 's|^#!.*python$|#!/usr/bin/env python2|' '{}' ';'
+ ./configure --mandir=/usr/share/man --with-bash
}
build() {
cd "$srcdir/ltp-full-$pkgver"
- ./configure --mandir=/usr/share/man --with-bash
make all
}