summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 13 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4679b98857f9..1c34dc4960e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,26 @@ pkgname="linux-timemachine-git"
pkgdesc="Rsync-based OSX-like time machine for atomic and resumable local and remote backups"
url="https://github.com/cytopia/linux-timemachine"
-pkgver=1.1
+pkgver=v1.2.r0.g19d6e9a
pkgrel=1
arch=("any")
license=("MIT")
-makedepends=(
- "git"
-)
-depends=(
- "rsync"
-)
-optdepends=(
- "openssh: backup to remote (SCP) locations"
-)
-
-source=(
- "${pkgname}-${pkgver}::git+https://github.com/cytopia/linux-timemachine.git"
-)
-sha256sums=(
- "SKIP"
-)
+makedepends=("git")
+depends=("rsync")
+optdepends=("openssh: backup to remote (SCP) locations")
+
+source=("${pkgname}::git+https://github.com/cytopia/linux-timemachine.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}/"
+ cd "${srcdir}/${pkgname}"
install \
-Dm755 \