summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 34 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3eb9dd50bea..3af4659f39e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgbase=linux-tomoyo
-_srcname=linux-4.15
-pkgver=4.15.1
+_srcname=linux-4.16
+pkgver=4.16.3
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -27,18 +27,26 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'linux.preset'
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ 0003-Partially-revert-swiotlb-remove-various-exports.patch
+ 0004-Fix-vboxguest-on-guests-with-more-than-4G-RAM.patch
+ 0005-Revert-drm-amd-display-disable-CRTCs-with-NULL-FB-on.patch
+ 0006-net-aquantia-Regression-on-reset-with-1.x-firmware.patch
)
-sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
+sha256sums=('63f6dc8e3c9f3a0273d5d6f4dca38a2413ca3a5f689329d05b750e4c87bb21b9'
'SKIP'
- '202a0a34f221ae335de096c292927d7a7d4bcdbc2dd46d43b8a5f6420f95a0cf'
+ '336252cb15f2f2574461c1d3daabf5dc207842526085802270e1e5223f645db3'
'SKIP'
- '76fdf8b3a2451cb38ec5b66cd266d5b2411353bc5e7a9d3bdefc7cf113b32e5c'
+ '51f794dee6098b19b5f8ec2277f52a313584f2ff8b3abf111f2fd92a6ea118dd'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
- '7b7363b53c68f52b119df994c9c08d4f29271b408f021366ab23f862518bd9bc'
- 'ac996455cddccc312d93e63845d92b2d8ab8fb53208a221948d28c76c678d215')
+ 'a6119b46856ed2652c509fed380052e6df2be89c69a0d748cf7d8745bf35b871'
+ '545566a7358d711b8d4f9924df685e2410549e20d99e5d1c0dfaccdfeafda60d'
+ 'bef6dd7b3a749ec072614ea4ed0bd5ea1d90519731f3438e4938d5b957032cc5'
+ 'd647211e288436bcc010019a69f4ebf9a94c33b423c650aea8098969208ec836'
+ '6fb4fb81dab69ff432767e02585b3eb6a5a39c941e4bc2a6d4940ee17116c14e'
+ 'd49a70d3b3f60c81d93735871f01ea60cafca87588d8d0d01801b2aec92e0e93')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -62,6 +70,18 @@ prepare() {
# https://bugs.archlinux.org/task/56711
patch -Np1 -i ../0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ # NVIDIA driver compat
+ patch -Np1 -i ../0003-Partially-revert-swiotlb-remove-various-exports.patch
+
+ # https://bugs.archlinux.org/task/58153
+ patch -Np1 -i ../0004-Fix-vboxguest-on-guests-with-more-than-4G-RAM.patch
+
+ # https://bugs.archlinux.org/task/58158
+ patch -Np1 -i ../0005-Revert-drm-amd-display-disable-CRTCs-with-NULL-FB-on.patch
+
+ # https://bugs.archlinux.org/task/58174
+ patch -Np1 -i ../0006-net-aquantia-Regression-on-reset-with-1.x-firmware.patch
+
cat ../config - >.config <<END
CONFIG_LOCALVERSION="${_kernelname}"
CONFIG_LOCALVERSION_AUTO=n
@@ -74,8 +94,10 @@ END
-i -e 's/CONFIG_DEFAULT_SECURITY_YAMA=y/# CONFIG_DEFAULT_SECURITY_YAMA is not set/' \
-i -e '/CONFIG_DEFAULT_SECURITY=""/ s,"","tomoyo",' ./.config
- # set extraversion to pkgrel
- sed -i "/^EXTRAVERSION =/s/=.*/= -${pkgrel}/" Makefile
+ # set extraversion to pkgrel and empty localversion
+ sed -e "/^EXTRAVERSION =/s/=.*/= -${pkgrel}/" \
+ -e "/^EXTRAVERSION =/aLOCALVERSION =" \
+ -i Makefile
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
@@ -98,7 +120,7 @@ END
build() {
cd ${_srcname}
- make ${MAKEFLAGS} LOCALVERSION= bzImage modules
+ make bzImage modules
}
_package() {
@@ -113,12 +135,12 @@ _package() {
cd ${_srcname}
# get kernel version
- _kernver="$(make LOCALVERSION= kernelrelease)"
+ _kernver="$(make kernelrelease)"
_basekernel=${_kernver%%-*}
_basekernel=${_basekernel%.*}
mkdir -p "${pkgdir}"/{boot,usr/lib/modules}
- make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
+ make INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
cp arch/x86/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
# make room for external modules
@@ -182,9 +204,6 @@ _package-headers() {
install -Dt "${_builddir}/drivers/md" -m644 drivers/md/*.h
install -Dt "${_builddir}/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/9912
- install -Dt "${_builddir}/drivers/media/dvb-core" -m644 drivers/media/dvb-core/*.h
-
# http://bugs.archlinux.org/task/13146
install -Dt "${_builddir}/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h