summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db9331f653c4..9c9d41bfb9fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -286,6 +286,13 @@ prepare() {
"${srcdir}"/auto-cpu-optimization.sh
fi
+ ### Disabling CONFIG_CPU_SRSO
+ # More infos here: https://github.com/CachyOS/linux-cachyos/issues/150
+ if [ "$_use_llvm_lto" != "none" ]; then
+ echo "Disabling CONFIG_CPU_SRSO..."
+ scripts/config -d CPU_SRSO
+ fi
+
### Selecting CachyOS config
if [ -n "$_cachy_config" ]; then
echo "Enabling CachyOS config..."