summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 24 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6578995b67e..4512bd0e88f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,9 @@
pkgbase=linux-usermode
pkgname=('linux-usermode' 'linux-usermode-modules')
_kernelname=-usermodelinux
-_major=5.3
-pkgver=${_major}
-#_minor=0
-#pkgver=${_major}.${_minor}
+_major=6.8
+_minor=7
+pkgver=${_major}.${_minor}
_srcname=linux-${pkgver}
pkgrel=1
pkgdesc="User mode Linux kernel and modules"
@@ -16,15 +15,19 @@ license=('GPL2')
url="http://user-mode-linux.sourceforge.net/"
depends=('coreutils')
makedepends=('bc' 'inetutils')
-source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-${pkgver}.tar.xz"
- "https://www.kernel.org/pub/linux/kernel/v5.x/linux-${pkgver}.tar.sign"
+options=(!debug)
+#_lucjanpath="https://raw.githubusercontent.com/sirlucjan/kernel-patches/master/${_major}"
+_lucjanpath="https://gitlab.com/sirlucjan/kernel-patches/raw/master/${_major}"
+
+source=("https://www.kernel.org/pub/linux/kernel/v6.x/linux-${pkgver}.tar.xz"
+ "https://www.kernel.org/pub/linux/kernel/v6.x/linux-${pkgver}.tar.sign"
'config'
'70-uml.hook')
-sha256sums=('78f3c397513cf4ff0f96aa7d09a921d003e08fa97c09e0bb71d88211b40567b2'
+sha256sums=('291d1a1faf4e87b3b0ea9729080db887aafd1ff2fac1430ceca921e46bc22fae'
'SKIP'
- '616ce4015a3d56c49bc5f839eed4c021483b08f730b36c9a7172724bed2cbdce'
- '452b8d4d71e1565ca91b1bebb280693549222ef51c47ba8964e411b2d461699c')
+ 'f9f7ee25feb617bbbce20ff9de7e9cfb5fc6871acc26c2e8b9b10312a8dbd21c'
+ '05ea4e00d1e99bf8140a21c94e3c42acf17b9debad9c6f5decbe1dd1fe04332c')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -34,9 +37,8 @@ validpgpkeys=(
prepare() {
cd ${_srcname}
- msg2 "Setting version..."
+ echo "Setting version..."
sed -e "/^EXTRAVERSION =/s/=.*/=/" -i Makefile
- scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "$_kernelname" > localversion.20-pkgname
@@ -45,18 +47,19 @@ prepare() {
src="${src%%::*}"
src="${src##*/}"
[[ $src = *.patch ]] || continue
- msg2 "Applying patch $src..."
+ echo "Applying patch $src..."
patch -Np1 < "../$src"
done
-
- msg2 "Setting config..."
+
+ echo "Setting config..."
cp ../config .config
yes "" | make ARCH=um config >/dev/null
+ diff -u ../config .config || :
- make ARCH=um kernelrelease > ../version
- msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
+ make ARCH=um kernelrelease > version
+ echo "Prepared $pkgbase version $(<version)"
- msg2 "Save configuration for later reuse"
+ echo "Save configuration for later reuse"
cat .config > "${startdir}/config.last"
}
@@ -75,12 +78,12 @@ _package() {
}
_package-modules() {
-
- local kernver="$(<version)"
+ depends=('kmod')
cd ${_srcname}
- # make ARCH=um INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
- make ARCH=um INSTALL_MOD_PATH="${pkgdir}/usr" _modinst_
+ local kernver="$(<version)"
+ make ARCH=um INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
rm -f $pkgdir/usr/lib/modules/${kernver}/{source,build}
# sed expression for following substitutions
local _subst="