aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8fb9f7000727..7a5936b7f104 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=linux-vfio
_srcname=linux-4.16
-pkgver=4.16.10
+pkgver=4.16.13
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -18,10 +18,12 @@ source=(
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- 0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ 0002-ACPI-watchdog-Prefer-iTCO_wdt-on-Lenovo-Z50-70.patch
+ 0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
# patches for pci passthrough
add-acs-overrides.patch
i915-vga-arbiter.patch
+ PCI-Add-Intel-7th-8th-Gen-mobile-to-ACS-quirks.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -29,16 +31,18 @@ validpgpkeys=(
)
sha256sums=('63f6dc8e3c9f3a0273d5d6f4dca38a2413ca3a5f689329d05b750e4c87bb21b9'
'SKIP'
- '9fe6093be401fe0ff3f6cb3d428f137119a7befaf86d70f18c7e88871c1852d6'
+ '9efa0a74eb61240da53bd01a3a23759e0065811de53d22de7d679eabf847f323'
'SKIP'
'8566a49997faf3f8678440c52578a7a0ee901e598d3b67d3bee3799fb92e8f86'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
- '7fb607fe384dd814e9e45d7fc28f7b5b23a51d80784c54bf9209486ad428be14'
- 'ceaa19e0af3842c62eb666a4ac5c79d89b3e6d00593442f18d6508ca6d74bbaa'
+ '8d6a5f34b3d79e75b0cb888c6bcf293f84c5cbb2757f7bdadafee7e0ea77d7dd'
+ '2454c1ee5e0f5aa119fafb4c8d3b402c5e4e10b2e868fe3e4ced3b1e2aa48446'
+ '8114295b8c07795a15b9f8eafb0f515c34661a1e05512da818a34581dd30f87e'
'abe269c6596b54a412bd8415472153f419026d4f367fa3ee1ebc8693ac66915d'
- 'fe3d47fe6f54d4a82c869fd29484d3f097b5906ef4d456409961a8dd647daad0')
+ 'fe3d47fe6f54d4a82c869fd29484d3f097b5906ef4d456409961a8dd647daad0'
+ '429ed1161b9b178df97e53dc6439f770e5198b5544f7421d0e48a3dd77fe371f')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-ARCH}
@@ -55,8 +59,11 @@ prepare() {
# disable USER_NS for non-root users by default
patch -Np1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
+ # https://bugs.archlinux.org/task/56780
+ patch -Np1 -i ../0002-ACPI-watchdog-Prefer-iTCO_wdt-on-Lenovo-Z50-70.patch
+
# https://bugs.archlinux.org/task/56711
- patch -Np1 -i ../0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ patch -Np1 -i ../0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
# patches for vga arbiter fix in intel systems
patch -p1 -i "${srcdir}/i915-vga-arbiter.patch"
@@ -64,6 +71,9 @@ prepare() {
# Overrides for missing acs capabilities
patch -p1 -i "${srcdir}/add-acs-overrides.patch"
+ # patches for specific intel cpus
+ patch -p1 -i "${srcdir}/PCI-Add-Intel-7th-8th-Gen-mobile-to-ACS-quirks.patch"
+
cat ../config - >.config <<END
CONFIG_LOCALVERSION="${_kernelname}"
CONFIG_LOCALVERSION_AUTO=n