summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD97
1 files changed, 39 insertions, 58 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b956778d8e44..6a7a3f499f44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,85 +3,66 @@
# Contributor: Mark Weiman <markzz@archlinux.net>
pkgbase=linux-vfio-selinux
-_srcname=linux-4.15
-pkgver=4.15.7
+_srcname=linux-4.18
+pkgver=4.18.14
pkgrel=1
arch=('x86_64')
-url="http://www.kernel.org/"
+url="https://www.kernel.org/"
license=('GPL2')
-makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'libelf')
+makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
-source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
- # the main kernel config files
- 'config'
- # pacman hook for depmod
- '60-linux.hook'
- # pacman hook for initramfs regeneration
- '90-linux.hook'
- # standard config files for mkinitcpio ramdisk
- 'linux.preset'
- # patches for pci passthrough
- 'add-acs-overrides.patch'
- 'i915-vga-arbiter.patch'
- 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- 0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+source=(
+ https://cdn.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.{xz,sign}
+ https://cdn.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz
+ config # the main kernel config file
+ 60-linux.hook # pacman hook for depmod
+ 90-linux.hook # pacman hook for initramfs regeneration
+ linux.preset # standard config files for mkinitcpio ramdisk
+ # patches for pci passthrough
+ add-acs-overrides.patch
+ i915-vga-arbiter.patch
)
-sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
- 'SKIP'
- '0dad200b26837acd0340dfe18d9610467c111df5719440248cd8be6fb8d6dd02'
+validpgpkeys=(
+ 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
+ '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+)
+sha256sums=('19d8bcf49ef530cd4e364a45b4a22fa70714b70349c8100e7308488e26f1eaf1'
'SKIP'
- 'd06d81416611619a150a757d8827b0aa13c40adc0ee03762a9b9c217c4810bb9'
+ '97d012dd62e3e9cb24c6097f9b1e21f91e39e27059a4c17e2cf0377fdfff3d49'
+ 'fb798c4bc70c6ee62b061420c3b9a2772683d16b86d29c46c45385c331afaf72'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'8f407ad5ff6eff106562ba001c36a281134ac9aa468a596aea660a4fe1fd60b5'
'99d0102c8065793096b8ea2ccc01c41fa3dcb96855f9f6f2c583b2372208c6f9'
- '1a4a992199d4d70f7f35735f63a634bb605c2b594b7352ad5fd54512737d2784'
- '7cb4a5da6bf551dbb2db2e0b4e4d0774ee98cc30d9e617e030b27e6cba3e6293'
- '7b7363b53c68f52b119df994c9c08d4f29271b408f021366ab23f862518bd9bc'
- 'ac996455cddccc312d93e63845d92b2d8ab8fb53208a221948d28c76c678d215'
-)
-validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
- )
+ '4b6df9e82460ef1fb2b55fec2d01b8ace8331547e5d3b374a42bb84271e4f866'
+ '7cb4a5da6bf551dbb2db2e0b4e4d0774ee98cc30d9e617e030b27e6cba3e6293')
_kernelname=${pkgbase#linux}
+: ${_kernelname:=-ARCH}
prepare() {
cd ${_srcname}
# add upstream patch
patch -p1 -i ../patch-${pkgver}
- chmod +x tools/objtool/sync-check.sh # GNU patch doesn't support git-style file mode
-
- # security patches
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
- # disable USER_NS for non-root users by default
- patch -Np1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
-
- # https://bugs.archlinux.org/task/56711
- patch -Np1 -i ../0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
-
# patches for vga arbiter fix in intel systems
patch -p1 -i "${srcdir}/i915-vga-arbiter.patch"
# Overrides for missing acs capabilities
patch -p1 -i "${srcdir}/add-acs-overrides.patch"
- cp -Tf ../config .config
-
- if [ "${_kernelname}" != "" ]; then
- sed -i "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_kernelname}\"|g" ./.config
- sed -i "s|CONFIG_LOCALVERSION_AUTO=.*|CONFIG_LOCALVERSION_AUTO=n|" ./.config
- fi
+ cat ../config - >.config <<END
+CONFIG_LOCALVERSION="${_kernelname}"
+CONFIG_LOCALVERSION_AUTO=n
+END
- # set extraversion to pkgrel
- sed -ri "s|^(EXTRAVERSION =).*|\1 -${pkgrel}|" Makefile
+ # set extraversion to pkgrel and empty localversion
+ sed -e "/^EXTRAVERSION =/s/=.*/= -${pkgrel}/" \
+ -e "/^EXTRAVERSION =/aLOCALVERSION =" \
+ -i Makefile
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
@@ -104,7 +85,7 @@ prepare() {
build() {
cd ${_srcname}
- make ${MAKEFLAGS} LOCALVERSION= bzImage modules
+ make bzImage modules
}
_package() {
@@ -118,16 +99,16 @@ _package() {
cd ${_srcname}
# get kernel version
- _kernver="$(make LOCALVERSION= kernelrelease)"
+ _kernver="$(make kernelrelease)"
_basekernel=${_kernver%%-*}
_basekernel=${_basekernel%.*}
mkdir -p "${pkgdir}"/{boot,usr/lib/modules}
- make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
+ make INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
cp arch/x86/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
# make room for external modules
- local _extramodules="extramodules-${_basekernel}${_kernelname:--ARCH}"
+ local _extramodules="extramodules-${_basekernel}${_kernelname}"
ln -s "../${_extramodules}" "${pkgdir}/usr/lib/modules/${_kernver}/extramodules"
# add real version for building modules and running depmod from hook
@@ -186,9 +167,6 @@ _package-headers() {
install -Dt "${_builddir}/drivers/md" -m644 drivers/md/*.h
install -Dt "${_builddir}/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/9912
- install -Dt "${_builddir}/drivers/media/dvb-core" -m644 drivers/media/dvb-core/*.h
-
# http://bugs.archlinux.org/task/13146
install -Dt "${_builddir}/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
@@ -216,6 +194,9 @@ _package-headers() {
# remove files already in linux-docs package
rm -r "${_builddir}/Documentation"
+ # remove now broken symlinks
+ find -L "${_builddir}" -type l -printf 'Removing %P\n' -delete
+
# Fix permissions
chmod -R u=rwX,go=rX "${_builddir}"