summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc2aa9ea39e3..f6a519defe2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=linux-wifi-hotspot
-pkgver=1.9
-pkgrel=3
+pkgver=2.0.0
+pkgrel=1
pkgdesc='Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)'
arch=('x86_64')
url='https://github.com/lakinduakash/linux-wifi-hotspot'
@@ -12,25 +12,30 @@ depends=('hostapd'
'gtk3'
'gksu'
'procps-ng'
- 'util-linux'
- 'dnsmasq'
- 'iptables')
+ 'dnsmasq')
conflicts=('create_ap')
provides=('create_ap' 'wihotspot')
optdepends=('haveged: For random MAC generation')
makedepends=('cmake' 'gendesk')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/wihotspot-${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v${pkgver}.tar.gz"
'https://github.com/lakinduakash/linux-wifi-hotspot/raw/master/src/desktop/hotspot.png')
-sha256sums=('964166d2411395ae0b8d5042ea367ceecc5a43c31251682c465044cc4a01fdd8'
+sha256sums=('c364b3ac184f7939a8ed2d545e958791cfabc94ea9d5dcc077ca8625ef9b96c0'
'00b1f5a4c225ea83d8cd1036d57de17a41c4428b667818180eea45610147b5b9')
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ sed -i "s|running_info|h_running_info|g" src/ui/h_prop.c
+ sed -i "s|running_info|h_running_info|g" src/ui/h_prop.h
+ sed -i "566s|get_running_info|get_h_running_info|" src/ui/ui.c
+}
+
build() {
- cd "${pkgname}-wihotspot-${pkgver}"
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd "${pkgname}-wihotspot-${pkgver}"
+ cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm644 ${srcdir}/hotspot.png "${pkgdir}/usr/share/pixmaps/wihotspot.png"