summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5494600561c4..7264abef8ac0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase=linux-x205ta
_srcname=linux-4.15
-pkgver=4.15.2
+pkgver=4.15.15
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -20,7 +20,6 @@ source=(
linux.preset # standard config files for mkinitcpio ramdisk
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
- 0003-ssb-Do-not-disable-PCI-host-on-non-Mips.patch
https://raw.githubusercontent.com/harryharryharry/x205ta-patches/master/4.15-patches/fix_c-state_patch_v4.15.patch
https://raw.githubusercontent.com/harryharryharry/x205ta-patches/master/4.15-patches/Revert-several-pm-4.15-rc1-merges-for-low-power-suspend.patch
https://raw.githubusercontent.com/harryharryharry/x205ta-patches/master/4.15-patches/Revert-several-pm-4.15-rc1-merges-for-low-power-suspend-2-rc6.patch
@@ -37,14 +36,13 @@ validpgpkeys=(
)
sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
'SKIP'
- '812499c5d0cc5183606dc9388084df162ca2eb5fa374d8f8b00136fd82825847'
+ 'd8e7f93e24db5517a1be2030a765431120e07f7cd55e510d0de562c70e45bc00'
'SKIP'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
- 'b20e25656c9423591afd0325fe26320f50bc3421ff204acbfe5dd88ffb3866fe'
- '68575230693b374eb68e6100e719c71a196db57fe0ac79ddae02fe72b404e09e'
- 'b21406c060cf601f879528cfa1b83f524c44d8ecd99689c331a7c6326653d0be'
+ '4ffdc2a458845c2a7c03c735477dbf51b5b01b10568bf577b37a29e872135cab'
+ '12b281dc45f1954cc3f52276927bb2965c3132c0a8bd7f485869ced2c541d485'
'e576fcf6b61c50b7ea358e9980c4d04901adfe9b050b87bf45506a8452202505'
'dfc7fe519d8b95fbe263889ad8e432c55a89d915e905b7729a2ffc958c310754'
'1772125253dbe3cd6e191bc8ab5c0297e294d4778857c9e90e22e4999af00929'
@@ -52,7 +50,7 @@ sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
'ad0f318809d074ee387f48fdfcb711b0fa3eb378867ac65c6da3d490834e649d'
'e3e3873d7d5d781913e1e2f3a7968d0cf0967ee70be0db58bff91c31b37fabe8'
'e9d407c4e437c6e93d8c985fcd496dee0115dcc6c616ee56129fe7a9e96bb746'
- '2d8638cc71ffa3277315a171a60bcb5fd7fd07e2c6e9c0a6d1615e15f9f647d7')
+ 'c75b5d9cc7236e4a8a1021f4703212a5eb084d6b69ffc1ce2dd450df219b480b')
_kernelname=${pkgbase#linux}
@@ -73,9 +71,6 @@ prepare() {
# https://bugs.archlinux.org/task/56711
patch -Np1 -i ../0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
- # https://bugs.archlinux.org/task/57327
- patch -Np1 -i ../0003-ssb-Do-not-disable-PCI-host-on-non-Mips.patch
-
# Here start x205ta patches, refer to https://goo.gl/dcXIM0 for harryharryharry's guide which is the main starting point
# for info on these patches.
@@ -128,8 +123,10 @@ prepare() {
# Here ends x205ta stuff.
- # set extraversion to pkgrel
- sed -i "/^EXTRAVERSION =/s/=.*/= -${pkgrel}/" Makefile
+ # set extraversion to pkgrel and empty localversion
+ sed -e "/^EXTRAVERSION =/s/=.*/= -${pkgrel}/" \
+ -e "/^EXTRAVERSION =/aLOCALVERSION =" \
+ -i Makefile
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
@@ -152,7 +149,7 @@ prepare() {
build() {
cd ${_srcname}
- make ${MAKEFLAGS} LOCALVERSION= bzImage modules
+ make bzImage modules
}
_package() {
@@ -166,12 +163,12 @@ _package() {
cd ${_srcname}
# get kernel version
- _kernver="$(make LOCALVERSION= kernelrelease)"
+ _kernver="$(make kernelrelease)"
_basekernel=${_kernver%%-*}
_basekernel=${_basekernel%.*}
mkdir -p "${pkgdir}"/{boot,usr/lib/modules}
- make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
+ make INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
cp arch/x86/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
# make room for external modules